Moving RW 8 to another computer

I have found it impossible to move my RW 8 installation stacks library from my desktop runing High Sierra to my laptop running Mojave. In Mojave, stacks appear as folders with no content.

Does anyone have a solution to this problem?



How Did you install RW8 on the new machine?
How did you copy the addons ?

This is on RW7 but still should apply:

This might help as well:

1 Like

Same problem here. Impossible to install stacks in RW 8.1.7 under Mojave.

Stacks files disappear and folders appear with image and stuff in them.

This is totally unacceptable.

Yes. The Addons archive does not install. I have tried everything.

Have you tried reinstalling RapidWeaver itself? Stacks are in fact a special kind of folder (a Package), and my understanding is the installation of the base Rapidweaver product makes the OS recognize these folders as packages. You can go to the release notes page and grab a new copy of RapidWeaver and try that. If that doesn’t work then perhaps you should contact @isaiah at YourHead support.

Thanks, but these are not helpful.

Clean install of RW 8.1.7
Tried both copying stacks file out of resources from High Sierra and using archive export.
Neither worked. Files of stacks appear as folders with no executable in them

Did you test this? I appears not.

This appears not to be related to RW. Nor is it a developer specific problem.

Something is happening to ALL stacks files from High Sierra when they come over to Mojave.

The packages is being unwound.

Yes. Clean install of RW 8.1.7

I have a clue and have been using RW pretty much since the original version several years ago.

I assure you that nothing works in the Mojave invironment. It is impossible to get stacks into RW.

Not sure what you’re asking, did I test what? I’m having no issues with stacks that came from high Sierra. Stacks for most users running Mojave aren’t having problems.

This is from YourHeads FAQ page

Since you have installed the latest RapidWeaver you can also download and install the latest version of stacks (the plugin not the 3rd party stacks) if you haven’t yet. If that doesn’t work then contact YourHead support with the information requested in the FAQ.

Have you tried selecting the stack, then “get Info” and then choosing “Open With”?
It should now identify those unknown folders with RapidWeaver…

It should not be so hard to accomplish moving? Something is being missed.
Likely with your transfer between the quite different O.S.'s
I also would simply try running first aid from disk utility on the new mac after moving :wink:

I have done all of that and much !See screen cap for what stacks, all of them, look like when they come into Mojave. No way to install these directories in RW 8. Nada.

Capto_Capture%202019-03-29_12-53-29_PM|251x367 more.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.