Stacks do not install RW 8.1.7 Mojave

I is impossible for me to install stacks, including Joe Workman Cycler in RW 8.1.7 running under Mojave.

Stacks file disappears and nothing but a folder with images and so on appears.

What is going on?


Tagging @isaiah

do you have RW 7 installed or running?


This I think is the same issue you posted here:

It’s best not to double post.


When installing things on a new machine, often the challenge is getting the stacks installed to the correct spot.

Stacks will only look in the currently active add-ons folder. Depending on where you purchased RW (AppStore, web, or SetApp), which version of RW you’re using, and if you’ve customized the installation location, the location will be in a different place.

The easiest way to find the correct spot to install your Stacks is to pull up a Stacks page then click on the Gear Menu under the Stacks Library and choose Show Stacks Library in Finder

This will open up the location where Stacks is currently looking. So no matter what any other settings or versions or anything – this is definitely the right folder.

Then to install:

  1. Quit RapidWeaver
  2. Drag all of your stacks into the folder that opened
  3. Launch RapidWeaver

They should show up just fine after that.
If you are still having trouble after that, then share whatever new details arise (error messages, screenshots, add-on folder location/details, etc.) and we’ll work from there.

And, just in general, It’s probably worth mentioning…
I’ve found that most people who report issues similar to this have just transferred things to a new machine or restored from a backup. There seems to be an awful lot of “smoke” for their to be no “fire” here – in other words – it seems like perhaps there’s a problem associated with this unique situation – perhaps sandbox permissions have not been set for custom addons location, perhaps some permissions issues after install, perhaps???
i should mention this to @dan to make sure he knows that I answer this question quite a bit – because it is not Stacks that does this installation – RapidWeaver itself does all the add-on installations.


@isaiah, cool dark mode brought to Stacks! …
When will Stacks 4 be launched? …

Noting has worked. Nothing, including disk first aid, numerous reinstalls, etc.
See screen cap. It shows what stacks look like when they come into Mojave.


I’ve had problems with stacks installing in the wrong folder. The simplest thing, I find, is to establish where they should go as described by @isaiah and then add that directory to the directory bar, or whatever it is called, on the left. You do this by simply dragging the relevant folder into the bar. Then, you can just drag your stacks to it. Saves a lot of time trying to fin the folder each time.


Hi Peter,

Here is what I am seeing under Mojave. The packets seem to become undone from moving from High Sierra to Mojave. My installation of Mojave is perfect. Something is fundamentally wrong in RW 8 and/or the code supporting Stacks. I have been unable to find the cause, much less devise a solution.


I disagree! I’ve been using RW8 and Stacks for months with Mojave. No issues at my end. There are also 100s of other users without the issue you mention.

Sweeping, inaccurate statements like the one above help no one.


Actually, I have been using RW since pretty much the beginning. There were, intact, a number of serious issues in 8.1.3 to 8.1.5. I was probably one of the first to find these. Other RW users quickly confirmed. They were subsequently fixed with 8.1.6 and 8.1.7.

So, before ranting, you should look at my specific issues.

Here, is what I am seeing when stacks come over to Mojave. These directories cannot be read by RW 8, or at least not that I have found. This shows one of Joe Workman’s stacks, cycler as it appears under Mojave.


Not ranting, never do. Just pointing out that your statement is inaccurate, which it is. You’ve also pointed out that the issues are specific to you, not RW or stacks.


Who’s “ranting”?

The screenshot you are showing is in fact what a stack package looks like.

It’s probably more like thousands of others users not having issues. This is something unique to your setup and NOT “Something is fundamentally wrong in RW 8 and/or the code supporting Stacks”.

As I answered in your other post on this same subject you should read and follow the instructions given in YourHeads FAQ page.

If you can’t get It working following the steps in the FAQ mentioned in this post, the last step tells you to contact YourHead support. Did you do that?


I understand abut the contents of the stack directory. The problem is that the directly does not load in RW 8, or at least not that I have found.

In investigating this issue, I found that a stacks packet on High Sierra shows an app assignment of stackinstaller or something like that. I can find no equvalent in the RW 8 installation on Mojave. This leads me to believe that what I am seeing is the default to a standard OS X directory on Mojave. For some reason, RW 8 installed on Mojave may not have the stacksinstaller, or RW 8 may be looking for different file extension for the stacks directory.

I have spent a lot of time on this, and I cannot figure out what is going on. Returning to my statement, something is fundamentally wrong. I stand on that one until someone can help me understand what I am seeing and how to fix the problems I have experienced installing stacks in RW 8.1.7 under Mojave.

Any help you can be will be greatly appreciated. I do need to know specifics at this point.

Finally, I have tried to contact tech support. No response.




  1. Reinstall the latest version of RapidWeaver from here
  2. Reinstall the stacks plugin from here (may require re-entering serial #)
  3. If that doesn’t work contact YourHead Support with the following information “include the exact version numbers of Stacks, RapidWeaver, and the OS that you have installed.”

And if there are any virus programs or add-ons unique to your system, disable them during installation. Try the reinstall in “Safe Mode”.
Good luck.

Thanks, man.

I am in the process of reinstalling everything. I have already done an exhaustive check of my system, including three different virus eradication apps.

Problem is that RW 8.1.7 under Mojave does not see the stacks directories as packages. These are what RW and Stacks are looking for.

Under High Sierra, the default app for stacks is something like stacksinstall. This app is no where to be found when I reinstall RW 8.1.7 and the latest and greatest Stacks 3.

Strange, very strange.

I found part of the problem.

File info under High Sierra shows the default app for stacks to be stackinstaller1.0 When I moved this app over to Mojave and activated it, magically stacks packages reappeared. The file creation date of stacksinstaller is Nov 11 2011.

Again, there is something really strange going on here. Reinstalling RW 8.1.7 and Stacks 3, does not yield the same results. stackinstaller1.0 is require. Here is a screen cap after stacksinstaller has been activated.


1 Like

Tagging @isaiah