Mystery - constant timing out when uploading - experienced on Rapidweaver & Freeway 7


(Rob Mallows) #1

I posted up elsewhere in response to another user’s question my problems. I’m posting up here as I’m still experiencing them, even thought I’ve had direct support from Brian of RealMac Software. My problem seems to be unique to my machine, rather than Rapidweaver, I think, but I don’t know why. And it’s driving me crazy. I’m posting up again to see if anyone has any idea what I can do. I’m completely stuck.

Background on Freeway 7.
I had built a site using Freeway 7 by Softpress. It ran fine for years. But, when Freeway 7 was no longer supported, I chose to purchase Rapidweaver 7 instead to build a new version of the site.

Problem encountered
My site had lots of images and graphics in it, embedded video, Exhibio galleries etc. It worked flawlessly on uploading to my host site.

Then, about two months ago, on my iMac I - inadvertently - relocated all of the stored images I’d used on my Freeway 7 website into a new location on my iMac, in the same drive. Then, when I next came to upload something through Freeway 7, that’s when I started getting “timeout” messages.

I thought it might be something to do with my server so on my server file manager I deleted all the html files that there on there (which I realise wasn’t a sensible thing, now), in the hope that uploading everything new again might solve the problem. But, I couldn’t upload anything from my previous site through the ftp server. I was left without a website.

Where previously images, Exhibio galleries etc had loaded up without problem, I somehow think that since moving this folder of stored images, nothing loaded up. If I tried to add an Exhibio gallery - that had worked previously - or a simple jpeg image to my site, nothing now uploads.

So, using Freeway 7, I rebuilt a basic site from scratch, using the same images (that were stored in a different file location on my computer). However, Freeway 7 would now always time out when uploading larger images and any Exhibio files.

Switch to Rapidweaver
I couldn’t work out the problem, but I managed to somehow get a vanilla version of my website to upload onto my server using Freeway 7. So, I switched to Rapidweaver and built a very basic version of a site again, using images stored on my computer.

I built it and tested it on Safari, and it all worked fine. I had only added a couple of basic images to it. But when I went to publish it, it always timed out after about 10-15 of the 120 files were uploaded. Always getting the same message of ‘timeout’.

I checked with Brian at RealMac, and sent him my Rapidweaver Project to upload to my server, and he said he could do so without any problems. I’ve just tried again today, and again, on a simple two-page site, with no graphic images embedded, it just keeps timing out.

So, I’m stuck and at my wits end. CAN ANYONE OFFER ANY SOLUTIONS/IDEAS?. The facts are:

  • Timing out issues are experienced now on Rapidweaver and Freeway 7 - two separate programmes, same timing out issue

  • It seems to be linked - but I don’t know why - to when I copied a whole bunch of image files from one folder into a new one on my system, and deleted the old one (I thought all the images were contained within the site folder, and weren’t somehow ‘linked’ back to what’s stored on my computer). Since that point, I’ve not been able to add or upload any images, and Exhibio Galleries I still have, which I know worked before, no longer upload on Freeway 7

  • Using Freeway, I have created the simplest of two-page sites, with no images in it, to try and see if the problem is something to do with image size - the timeouts always happen when the ftp reaches a new image file it hasn’t uploaded - but even a vanilla site will no longer upload.

  • Since purchasing Rapidweaver, I have not been able to upload ANY pages. It seems like it’s ‘inherited’ the problem I experienced with Freeway 7 - the timeouts. I can’t see how this can be the case, which makes me think it’s not an issue with Rapidweaver, but a setting on my iMac or something to do with my files which means they cannot be uploaded. But I’ve no idea what.

  • Brian from RealMac managed successfully to upload this basic site from an external computer onto my site host without any problems, making me think there’s something I’ve changed on my computer that no longer allows either Rapidweaver or Freeway 7 to upload anything to my server and timeout.

  • I use hi-speed internet connection. I was asked if the issue might be my connection - I don’t think so: I manage to upload large video files up to Dropbox, for example, with no problem. But a very basic html file on Rapidweaver it just timesout. There’s nothing wrong with my server, as I’ve checked with my host company - they’ve managed to upload files to the site fine.

  • So, I’m stuck. Since experiencing the original problem with Freeway 7, I’ve encountered the fact that I can create a site on Rapidweaver fine, but just cannot upload it at all.

  • I’ve transferred the simple text site to an ftp uploading software app, and again, I get the timeout issue using an ftp client app, which again suggests the issue is on my iMac or in my uploading settings (on what?) or perhaps my security settings, maybe?

  • So, I’m stuck. I don’t think it’s Rapidweaver that’s at issue, but the fact that it and Freeway 7 are constantly timing out on anything I try and upload - where the latter has previously done so without issue - suggests that it’s something I’m doing.

  • I’ve since done a complete clean install of my computer and files using Time Machine, to try and get back to the way things were before, but I’m still experiencing this timeout issue.

What have I changed on my system that might cause this on Rapidweaver, Freeway 7 and an ftp client app - constant timing out on even basic html files, not even video or large images?

How can I resolve this, when even a clean restore of my system, and the Rapidweaver software re-installed, doesn’t solve the problem.

Where should I be looking for problems that might unlock this timing out issues. Would really appreciate any help anyone can provide, as I’m at my wits end. I’m an experienced Mac user, and have mastered building a site on Rapidweaver, but am absolutely stumped by this uploading timing out issue.


(Rob Mallows) #2

Today, I tried on Rapidweaver to add a new image file I took today, which is unconnected to any of the previous images I used on my earlier site, and which were timing out.

Nothing, it just timed out again. So, I don’t think it’s an issue with the images. There must be a setting or something on my Mac, or something I’ve turned on or off, which means on Rapidweaver AND Freeway 7 - two separate web building programmes - I cannot upload anything via ftp to my server.

What could cause that?


(Rob D) #3

Hey, Rob,

Once you built the fresh website in RW, your images became linked to your project, so the fact that you’ve relocated them previously to a new folder should not matter. You do not “inherit” your Freeway problems, if you build a new site in RW.

Since you are starting afresh, I suggest that you build one page at a time. First, with just the simplest content (a line or two of text). Publish it and see if it works. Then, add more content and complexity. That way, if you run into trouble, you will be able to easily figure out what causes it.

Make sure that your images are not too heavy. Depending on the quality of images you want to maintain, they should be in the range of 150 kB to around 1 MB. My images are between 250 kB and 800 kB (a couple of them are around 1400 kB) and they load without a problem and without any visible speed penalty. How heavy are your images?

Make sure that all your image-file names are free of spaces and illegal characters. Are you certain, that your image files did not get corrupted somehow when you’ve moved them around and done reinstalling your system?

Make sure that in your RW publishing setup you choose the Extended Passive connection mode and the slowest (no.1) connection rate. If that works, go to a higher one. Get into habit of backing up your projects (in general, computer backup should be frequent and redundant).

Finally, if you can create a site fine, but just can’t publish it within RW, do what many of us do: use a 3rd party FTP program (like Transmit or Yummy, or any one of the others) to upload your site to your server. Just export your website to a local folder first. This is a completely fail-proof method that may save you a lot of time and frustration.


(Rob Mallows) #4

Thanks. I have followed your approach. I tried uploading a vanilla one page index.php page to the site with no graphics whastoever - it just would not load. Previously, using Freeway, I’ve had no problems uploading big pdf or image files. So, I don’t think it’s an issue of image size, as such.

I’ve tried also uploading one page at a time - still get the same issue.

Most of the images I had on the previous site, which I’ve tried to add but which timeout, are only about 140 kb or thereabouts.

I can’t see how my images files will have got corrupted - I just moved them from one place to another. But, I’ve tried creating a brand new image, not a stored one, and adding it to the website - it just times out.

I’ve also tried on Cyberduck to upload a whole site. Again, simply times out, usually when it tries to load up a graphic item. I’m absolutely stumped.


(Rob D) #5

So, images are not the problem.

In light of all your explanations, I can only conclude that there is something wrong with your Internet connection (or bandwidth), or the way your hosting provider accepts uploads to their server. Hence my last suggestion to contact your IP and your hosting company for help.

Of course, there are wonderful people on this forum, who are a lot more experienced than I am. Perhaps someone could chip in?


(Rob Mallows) #6

I have contacted my broadband provider. I don’t think bandwidth is an issue, as I’ve never had any problems uploading massive files to, say, Dropbox. I can only think it’s either an issue with ftp files being blocked/limited somehow, or perhaps something to do with my security settings or similar. I didn’t have any uploading problems for years, until about two months ago, so I think either I’ve changed something, or perhaps then maybe my broadband provider has.


(Stuart) #7

@Bloodknok

I have looked into, with some depth, the problems you are describing (timeouts).

Indulge me. Forget chasing your broadband provider for now. Do this:
Go back to your hosting provider and ask them to give you the IP address/connection details for a physically DIFFERENT FTP host to use to transfer your files. In many hosting layer architectures it makes no difference which IP/Host you use for the FTP connection… its the credentials and destination path you provide which gets the files to the desired location.

Tell them that you are experiencing FTP timeouts and you wish to transfer the files to you plan using a different FTP host on THEIR side and to give you the IP/hostname needed to do that. It does not matter if they say that they see no issues on the FTP host you are currently using. Ask for the details needed to allow you to try a different one.

Then retry using that. I’ve been there with this problem and the hosting provider insisted that there was no issue on their side. Until we tried this and it worked 100% of the time. They then asked their 3rd line support to investigate and they found a problem and fixed it.

It was nothing to do with RW at all.

Got to be worth a try… let me know.


(Rob Mallows) #8

Okay, well that’s a new suggestion. I’ll have to try that out next week and get in touch with my host


(Brian LaPan) #9

And there’s always this page (though a lot has been said already) - good resource nonetheless.

http://kb.realmacsoftware.com/article/42-how-to-fix-ftp-publishing-issues


(john) #10

Also the same problem here.

the solution is to contact your ISP and tell them that your IP-adress is set on the black-list.
Your ISP (hosting provider) can remove your IP from that black-list and everything works fine.

If you try several times again to upload and upload , your ip will be blocked as a security reason.

Succes.


(Rob Mallows) #11

That sounds helpful, I’ll contact them. I’ve not tried uploading anything for ages. I’m going to get the new site finished, then get back to this uploading issue.