Navigation Stack Updated to Stacks 4


(Eric Vaughn) #1

Do you have any idea if/when your Navigation stack will be updated for Stacks 4? @yuzool


(Jannis from inStacks Software) #2

What are you missing?


(Eric Vaughn) #3

I have since reverted back to Stacks 3, but I recall I was missing, start content below the stack.


(Doug Bennett) #4

Just noticed - That option does seem to be missing.


(Doug Bennett) #5

Never mind I found it, was look in the wrong spot.
2019-08-19_14-42-12

So Eric (@dropgates), Not sure what was missing. I haven’t used navigation a lot but it seems to work fine in Stacks 4. I think @dave uses this as his goto menu, Dave are you running stacks 4?


(Eric Vaughn) #6

I made a comparison for you. This particular client is very clear about their design and we have managed to stay within their parameters for about 6 projects using the Navigation stack.

I now have a computer in the office that is not updated so we can make adjustments to these designs. I can figure out another navigation for it, but would rather wait and see the stack updated rather than touch the 6 projects we have the stack on for this client. Other clients, we’ve just made some design changes and no one seems to mind or even notice.


(Dave) #7

I will check one of my RW site files in the morning, but I just checked a couple of sites using my iPad, and they are working fine. I’m not positive, but am pretty sure that I have start content below Navigation in the ones I chose do, and I’m quite sure the sites have been updated since moving to S4 (I’m republishing all files for each site after moving to S4).

Any chance you have two copies of Navigation in your addon folder? I ask because after upgrading, I found out I had two copies of S4S Embed in my system. The older version is named Embed and the newer version is named s4s-embed (or something similar). S4 “chose” the “wrong” version, and a feature of the latest version of Embed wasn’t in the old version. As a result, that portion of the webpages were broken.

This error was 100% my fault- I never should have had two versions of the same stack available (long story as to why I did). @willwood diagnosed my issue and solved it for me. I removed the old version, reinstalled the latest version, restarted RW, and, voila- problem solved!


(Michael Frankland) #8

Thanks for the report @dropgates

Everything seems to be working fine in Stacks 4 in testing so not sure if this is Stacks 4 specific… but can you try and find more details?

Can you publish a demo somewhere of that page in S4 and S3 to compare… I’m guessing a CSS issue?

Start content below navigation is still included in the latest version. Maybe double check you have this on and republish to the test domain? (see in RW preview even)


(Eric Vaughn) #9

Thanks @yuzool. I will put something together by tomorrow. I’m traveling today.


(Eric Vaughn) #10

@yuzool, here’s a link to an RW file. It has an image and Nav stack and that’s it. It appears like I’m missing a lot of options for some reason.


(Dave) #11

I just checked my copy of Navigation, and it’s working as expected in S4. All of the items I expect to find in the HUD are there.

I found your website, but it’s published with S3. Can you publish your small project to a hidden URL and let us look at the code for it? That might help in leading to a resolution.


(Dave) #12

I was able to download your project and open it using S4. The HUD is different than shown in your screenshot (it looks correct to me). Which leads me back to suggesting that you might have two copies of Navigation available to RW, and that S4 is choosing the wrong one. Have you tried reinstalling Navigation to see if that clears the issue up? (if so, look for an earlier version and delete it)


(Eric Vaughn) #13

@Dave @yuzool Problem cleared up. I deleted the Navigation stack and downloaded it again, and everything appears right in Stacks 4. I truly appreciate the help and relieved to get back to using Stacks 4 and away from a 2011 iMac thats super sloooow.


(Michael Frankland) #14

Glad to hear it @dropgates!