Stacks 4 compatibility with older Stacks


(LJ) #1

Regretably have not had the chance to play with Stacks 4 beta - which looks like a fantastic release. My question is to what extent stacks need to be updated to work with Stacks 4? Will some / most / all legacy stacks continue to work even if you can’t do anything new with them? if it is variable, perhaps we could get a list of known problem stacks?


(Doug Bennett) #2

I started with public beta day one and didn’t find any stacks that didn’t work. Not saying I’ve tested every single one of them but I think it’s pretty safe to upgrade.


(LJ) #3

That’s good news. I’ll be upgrading this weekend!


(Isaiah Carew) #4

Starting last year (yes, all the way back in 2018) with a select set of developers we worked to make things as compatible as possible. A large developer beta started in early 2019. There’s been about six months to figure it out. It usually takes a fair bit of work both on my end and on the end of the developers to make sure everything’s right – but most developers made any necessary changes months ago. There will certainly be somethings that were missed, but we’er shooting for 100% compatibility or as close to that as we can get on an update of this magnitude.

If you do find something, and I’m certain there are a few things out there waiting to be found, make sure to notify the developer of the stack, but also let me know too – this stuff isn’t easy and sometimes takes more than one pari of eyes. :face_with_monocle:


(LJ) #5

Many thanks – it’s really top notch update.

Only issue I am finding currently is possible problem with Nick Cates Depth. Working on a couple of Depth projects I am getting random RW crashes. Will save a crash report nect time it happens but of course it’s not easy to replicate!!

Other than Depth, things are faster, new text editing leads zero text jumping on big text stacks, multi-stack manipulation is a massive time saver and more. Really pleased.

Len


(Isaiah Carew) #6

One of the perils of releasing software in mid-August – something i’ve been known to do before – is that I always catch more than a few devs right in the middle of family vacations.

I don’t want to give away too much personal info, but a little bird told me that Nick might be taking some family time. He and I will tackle this issue when he returns. We’ll get it sorted out, I’m certain. :slight_smile:

Isaiah


(LJ) #7

Great thanks – it’s not unusable in my case – just need to continually save as you go along.


(Isaiah Carew) #8

does it cause a crash? if so, can you send me a crash report. crashes with clear crash reports are often very easy to fix.


(LJ) #9

No I don’t get an RW crash report - only the Apple one. I emailed one over along with RW logs.


(Isaiah Carew) #10

Yes the Apple one, the RW one – whatever – a crash report is a crash report. Unfortuanately if you only email it to RW then I will never see it and, if it’s a stacks issues, it will go unfixed. A lot about writing plugins is easier than writing apps, but collecting crash reports is not one of them. LOL :stuck_out_tongue_closed_eyes:

But if you send it to me, or to YourHead support, or skip all the lines and just post it straight to my bug tracker, then I can probably fix it in a few days. :slight_smile:

Isaiah


(LJ) #11

No - I thought I emailed you a copy? Will check and send again. Many thanks


(LJ) #12

:joy::joy: senior moment - i sent it to Yabdab by mistake. Mike will be wondering what’s going on! Copy gone to you now!


(Isaiah Carew) #13

So, I’m afraid the code in question does not have any recognizable markers of mine or anyone else’s code since it seems to be crashing deep in apple’s libraries while running out of memory while attempting to render images with absurd dimensions.

The last bit in your log messages doesn’t look like RW at all – more like some other utility. the thing logging messages is “AppCenter”, which is a pretty generic name but I always associate it with MS Visual Studio. so… not many clues in that file either.

But I did notice that you have quite a list of installed plugins. And that is worth spending some time on. Whenever trying to narrow down which bit of code a crash is coming from, one of the first steps is to try to identify the culprit plugin or app.

Your Installed Plugins

FormLoom
PayLoom
PlusKit
Stacks
Waterfall

Your Installed (disabled) Plugins

RapidBot
RapidSearch
sitemap 3

  1. would you mind terribly trying to completely uninstall everything but stacks for a few minutes and see if the problems persist?

  2. i would always recommend having PlusKit far away from your projects – totally uninstalled from the addons folder completely – unless you specifically need to have it installed.
    plus kit is like declaring martial law – it lets you do pretty much anything you want – but there may be some serious collateral damage, so save it for when you really need that power. :stuck_out_tongue_winking_eye:

  3. I think I would start by uninstalling everything but stacks – since stacks is new, it’s the most likely culprit.
    then i’d put in plus kit,
    then i’d put in pay loom,
    then form loom.
    then just do some of the things that are most likely to cause problems. guessing from the crash report it has something to with images.

  4. if you do get another crash and the report looks any different could you send it to support. or to the bug list – which is always preferable – but whatever suits you is fine with me – i’m happy to get bugs any which way.


(LJ) #14

Thanks for this. Curious! Not sure what the images with absurd dimensions might be - certainly none of mine in RW - I’m fairly ruthless in keeping image sizes down. Can only be Pixelmator or Affinity Photo.

I’ll uninstall plugins as suggested although nothing has crashed for the last hour anyway! I think PlusKit can go but with over 100 projects it may well still be in use somewhere if only for zooming images! Likewise Payloom is only in 1 project which is waiting for an update budget!

I am doing a first time Backblaze back up currently which is a lengthy affair and using a fair bit of bandwidth?

Anyway - will update as soon as I get any further. However I know I’m not the only person experiencing depth crashes with RW4.


(Isaiah Carew) #15

I can read in the tone of your response that you feel a bit put upon and perhaps blamed. Nothing could be further from the truth. Let me say this bluntly and in bold:

A crash is NEVER the user’s fault.

NEVER

I’m trying to fix this bug. I assumed since you were a frequent poster, obviously technically proficient, and an expert in RW you might be interested in helping solve this one. But I gather from your reply that you’re a bit busy now. That’s A-OK with me. If it’s a common problem eventually it will be reported by someone else too.

I’m totally serious. Feel free to just drop it. I won’t be bothered in the slightest. I was so busy last week I didn’t respond to a single personal email. I get busy. Don’t even worry. :slight_smile:

OK, that out of the way, if your’e still reading… and you do have time to help a bit… here are some more details.

This might be a stack/theme developers fault – it’s possible – there are some API routines that must be handled with care – but that’s VERY rare. Not never, but rare enough that not-the-stack is a pretty safe bet.

A crash is almost certainly a plugin or app problem.
That’s where the code lives. Code does the crashing.

I don’t want to blame you for issue.
Nor do I even want to fix your project (yet).

I want to fix this bug.
To do that I need to make this problem really really bad – i know that seem counter intuitive – but things that happen 100% of the time are easy to find. Finding a bug is usually about 95% of the work of fixing it.

sorry to make your worry – i doubt is has much to do with you. the dimensions weren’t large, they really were literally absurd – one was a negative number. it’s just part of the bug causing that craziness. but the fact that it was doing something with images – resizing i think – that is a clue.

oh no! we want that bug to come back out into he light where we can smash it. once it goes hiding it might never come back… which is great for you… but terrible for me… because it definitely will visit with other users. :frowning:

don’t worry, pluskit is a good tool. i write it. and i stand behind it. but it does make debugging a bit more difficult as it moves memory around with something called a swizzle. when debugging it’s the first thing to go. again, not to fix the problem – but to understand it.

i am not at all suggesting you make any of these changes permanently. these experiments are just to us help dive the bug out into the open and try to isolate it from other things. once we’ve found and solved this go back to whatever you were doing. if it works for you, go for it!

i’d be happy to do this experimenting myself and let you get back to work – but it sounds like the bug comes after some indeterminate time and indeterminate actions – that means that it may rely on your own files/hardware/environment/usage-patters – indeterminate bugs like this are often impossible for others to reproduce.

if i can’t reproduce the bug and the crash report is unhelpful then i’ve got, quite literally in fact, nothing. and that means that bug will just continue to crop up and annoy everyone. :frowning:

but if we can get this bug a bit repeatable – open a simple file and, a few mouse-clicks, and boom! then we’re in business. then you can just zip up the project and your whole addons folder and heave it over the fence to me. i can take it from there and stop bothering you with this nonsense. :slight_smile:


(LJ) #16

Hi - I don’t feel put upon at all just a headache when trying to finish a client project and things go wrong - nobody’s fault though. No as soon as I have a bit of time which will be soon I’ll systematically try these. I am very grateful for your prompt availability!

What I have noticed meanwhile is that a project using Depth combined with Foundation is crashing more frequently whereas a Depth project using the depth theme is crashing only occasionally. May be a red herring but observed nonetheless.


(LJ) #17

On a bit of a tangent, I get this issue on my Mac whereby window tabs seem to overlap with the Favourites bar and the background shows through any space. Hopefully the screengrab will show what’s happening. A simple move of the window and all becomes normal again but I’m wondering if this might indicate some deeper issue with the graphics card or something? Happens randomly but fairly frequently. Apple Diagnostics don’t report any errors.


(Isaiah Carew) #18

that is not good. something is up. i should note that the crashes you were reporting were in WebKit. the obvious problem is that it’s stacks 4 issue, but i would not completely discount this being safari issue either. that fits the symptoms a little too well for my comfort. :wink:

you’re running an older version of macOS correct? you might consider an update if you can – or maybe just a force-reinstall. i had to do this recently myself to correct a certificate error in Safari that i could not resolve any other way.

are you using Safari extensions? it might be worth disabling any for a bit if you are. any other utilities that might interact with window chrome? i’d pay especially close attention to all the little always-running utilities in the menu bar. again, might not hurt to just give everything a try with ** all of the things ** disabled for a bit – utilities, extensions, everything you can stop running – stop. Just for a day or two.


(LJ) #19

Thanks and apologies for my absence. issues definitely seem to have calmed down - no idea why. Have had a couple of crashes but nothing like I had before. If I can see any pattern I will of course let you know. So far the worst issues seem to be using Depth sections within foundation.

I’m not running any Safari extensions

I will update to Mojave shortly but at the moment I’m in the middle of a 38 day initial back up to Backblaze - oh for Fibre broadband!! i’d like to complete this before any upgrade. Delayed upgrading previously because I have a lot of Filemaker 14 data and it wont run in Mojave - have now migrated Filemaker to Airtable as FM is way too pricey.

Regarding Safari, I have had random issues; for example, a while back I highlighted an issue with a couple of projects using Go-CMS where the pages didn’t load at the top in Safari - i.e. they would instantly scroll down. In particular, this played havoc with a Screens project (Joe Workman). However, other Safari users couldn’t replicate. I did a fresh OS install and the problem went away only to return a day later. Mystery but that problem seems to have resolved itself now.


(Isaiah Carew) #20

@manofdogz - i was able to get to the bottom of the Depth issues just yesterday. a very helpful user sent a very complete set of info along with exactly what he was doing at the time of all the crashes. this info proved to be the silver bullet. i was able to locate, (and with more user assistance) test a fix for an unusual property setting in Depth that was throwing stacks off the rails – it seems only on some hardware and only on macOS 10.13 – I don’t really know why it crashes just these Macs – but pretty interesting.

So I worked a bit late to get a new beta out for all the Depth users to try…

Download: http://yourhead.com/appcast/RW6/beta/Stacks4/Stacks_4.0.2b2_4743.zip
Release Notes: http://yourhead.com/appcast/RW6/beta/Stacks4/release_notes_4.0.2b2_4743

If you’d like to play with this version just download and install.
You’ll continue to get beta version updates so long as you have a beta version installed.
When you want to get back to the release version, just download and install from our main website.

I’ve also informed Nick of this issue, it’s probably for the best that this is corrected in Depth as I think this could affect older versions of Stacks given the right circumstances. Also, it’s a very simple change – once you know where to look. :face_with_monocle:

Isaiah