New Mac, OS, RW, stacks - nested Stacks directory problem


I seem to have a problem after a new install (RW 8, Mojave, new stacks) with having Stacks (except for default) not being visible in my library.

It would appear my Mac/RW made a Stacks directory within a stacks directory. If I move the stacks to the root stacks directory, it will be visible within the “add-on/stack” interface but not in the library. If I move the stacks to the “inner” stacks directory, the opposite happens, they will be visible and useable but not visible within the add-on/stack interface.

I have reloaded and deleted and moved the stacks to create one root stacks directory… but the second inner stacks directory keeps on getting created automatically upon restarts.

Is this a known problem? Am I missing something?

Any insight would be greatly appreciated.


I’m afraid I don’t know the answer to the question. It’s likely something pretty esoteric – multiple versions of RW, or a custom add-ons location that doesn’t have sandbox permissions or something like that.

But here’s what I’d recommend:

  1. Set the custom location of your add-ons folder to be somewhere really boring. Like your desktop or home folder or Documents folder. Avoid Dropbox and iCloud and Google Drive and other places that are going to be affected by some outside app or utility.
    This isn’t a permanent move, this is just to eliminate some sources of potential issues – hopefully by simplifying the setup and eliminating enough things we’ll narrow down the issue until there are not many complex things left.

  2. Do a clean-up of your addons folder. Eliminate all but the addons you absolutely need right now. Again, this is not a permanent change – just trying to narrow things down. Some old, out-of-date, plugins that you’re not even using could be causing issues and you wouldn’t even know it.

  3. In the Gear menu under the Stacks Library, choose Show Stacks Library in Finder. Make sure that the Stacks library that is opened is really the same one that you just set the custom location to.

If any one of these things happens to eliminate the problem – then, well, that’s a big clue – and you can likely use that info alone to help you isolate the issue a bit.

But I suspect the issue may still remain even after this – in that case report back what you find. What things remain in your add-ons folder, what items show/don’t-show in the Stacks folder?

I’ve also use your question as a starting point to talk about the add-ons folder, all the constituent parts, how to use each one, and how to clean things up. It’s not really an answer to your question – but it is related. You might want to have a watch if you have a bit of extra time.


I occasionally use AppCleaner in the following way.
I drag the app I’m interested in (RW) and then use it to selectively review the elements. Without deleting.
At least you know which files are related and where they are located. And you can delete a .plist file for example and see if that corrects the situation, and if not, you can replace it in it’s original location.
I have no clue what APPLE or RW are doing but in the past, a corrupt .plist (preference file) could cause issues. They are rebuilt I believe after a restart. For example, I’ve included a screen shot of my working install of 8.1.7 on Mojave on my mini if it gives any clues? .
Good Luck.

Watched the live stream ! Thanks.

Well, your advice worked. It came down to cleaning it out and ensuring the proper file layout. I removed the parent Stacks directory carefully and ensured the Stacks.rapidweaverplugin is at the same level as Stacks. Not sure how it got messed up considering this was a fresh new install, but regardless, your fix worked. Many thanks!

1 Like

That’s great news – I hope that a few more people find that info and are able to use it in the future too. Similar add-ons folder tangles seem to be a very common problem right now.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.