New User RW7 - beginner questions - Themes


(Michael McNamee) #1

I am new to RapidWeaver. I’ve not used the earlier versions. I was attracted due to some reviews that praised for easy to build website. I’m not into the code-world at all and after trying the demo for couple days I bought the license.

I’m attaching 3 screen shots clumped into one jpg.
I’m trying to create a personal picture gallery scrapbook listing hundreds of pictures that I’ve gathered and want to share with friends and former customers of a small shop I used to own.
I’ve been using the “Off Road” theme which on the whole looks good on my desktop Macmini uising Safari, Chrome and Firefox. Also looks good on my iPad and iPhone… with some reservations.

*Note the red arrow pointed to a blank field in the OffRoad theme. I wish I could get rid of it. Or maybe it has some function that I haven’t figured out?

  • I’m also early enough in this whole process to switch to a different theme that would support dragging/swiping across the smartphones/tablets from picture to picture. I’d also like the pictures to display larger. Is there a different RapidWeaver7 theme that fits this? Or a 3rd party?

Thanks from first time user – senior retired guy in SF. I’d like to get up and running to share my scrapbooks on the web.

ps:

  • I’ve seen the troubleshooting regarding not able to save files after loading elements. Yes… I’ve experienced that and it’s disappointing. I’ve done the restart of my Mac to clear it. I’ve never dived into the “terminal” modes… and hope an update comes through.

*Servers? I’m using GoDaddy. They’ve been very helpful with some phone support. I needed to trash my first attempt to make a site and they did it for me in their support call.


(Christopher Watson) #2

That area is the “Sidebar”. You can turn it off by going to Settings -> Master Style and set the Sidebar to “Hidden”.

You may have to purchase a third party theme that allows smart phone image swiping. (or purchase one of the plethora of stacks that can do this) http://rapidweavercommunity.com/addons

GoDaddy should do what you need.

Cheers for your ears.


(Rob Beattie) #3

Hi there and welcome to the forums.

I don’t have the Off Road theme but it looks to me as though that bar is the theme’s sidebar and it looks like that because it’s turned on in the theme settings but you haven’t put any content in it yet.

If you’d like to use that space, make sure you’re in Edit mode and then hover your mouse pointer over the icons in the row at the top left. Little tooltips should pop up. Click the one that says Sidebar. Try typing some text in there and see what happens.

If you don’t want to use that space, then you’ll need to go to Settings in the left hand column and choose Master Styles, then scroll down the list of options in the right hand column and find the one that lets you choose whether the sidebar is left, right or hidden.

There are plenty of ways to get a swipeable gallery in Rapidweaver but they involve purchasing an extra plugin called Stacks and then individual gallery stacks to make it work.


(Michael McNamee) #4

I carefully went to the settings area that you listed. Changed the right sidebar to HIDDEN. Then I saved the site, reloaded to the server. Next went to my browsers and trashed the histories. No luck. That sidebar is still visible. I repubished the entire site a 2nd time. Trashed browser history and the right side bar is still visible.
Maybe this is a bug? Or maybe GoDaddy server has a glitch – or maybe time for me to explore some other Themes since I’m very early into this project.

STACKS: I’m going to start checking that out for swipeable galleries.


(Christopher Watson) #5

Does it show up when you preview the page within rapid weaver?

You might need to check the individual page inspector site styles. (Top right)
Check that it set to master theme style.


(Michael McNamee) #6

The individual page inspector is checked to “master theme style.”

When I check the site in “preview” in RW – it looks just fine. The right side bar is hidden.

Also interesting is at my page bottom on the published site “contact-me” appears even though I have deselected that box in the “general” settings - choosing instead to use a “contact me” as a separate page.
(and in RW preview contact-me at page bottom is missing – as is my preference)

My site is young enough where I’m ready to move on to another theme that can be more friendly to what I’m trying to achieve.

I’m discovering and reading up on the STACKS - and “swipe galleries” – currently watching demo of Stacks4Stacks.

Thanks for helping me through this learning-curve.


(scott williams) #7

If you share the Utk we can see what is showing. Probably browser cache causing your view if you already republished all.


(Michael McNamee) #8

I checked the newly published on Safari, Chrome and Firefox. I emptied the histories from all of them… quit them, restarted. Same issue.

I’ve put some text content in this little beta ‘beginning’ that I’d prefer not to share as it’s a little silly and some may even find a touch of vulgar.:imp: On my next round I’ll make sure I have the style and performance nailed down before I publish certain content that is targeted to a somewhat limited audience…

As a new user I now have actually made a site…:sweat_smile: But I’m going to scrap this OffRoad theme. I’ve learned a quite bit in the RapidWeaver world “freshman class” :slight_smile:
I need to look for a different theme, add the “swipe” options to the galleries that I’ll be creating. I’m reading through the the demos on what I need to “build” a site that has that feature.

Thanks all for your help. I’ll be back to share… and hopefully help some other beginners down the road.