New Years Day Nightmare with RW [Resolved]

I have RW Ver 8.4, I downloaded ECWID and try to install software but, RW has totally locked up!
The only other thing I can think of is I have updated OS to Sur.

I have deleted the RW App many times of the laptop completely but, everytime I load Ver 8, 8.2 or 8.3 - they all go to same locked screen!Screenshot 2020-12-31 at 21.36.55


Could my issue be Sur OS or ECWID install. Either way, I cant us RW anymore… I have tried everything… Also, if I have Ver 8.4 to go to Ver 8.7 for Sur do I have to pay for upgrade?

Happy New Year to RW Community

All 8.x’s are free upgrades for RapidWeaver 8 users.

Looks like you have 3 RapidWeaver’s running,

I’d force quite them all.

Then launch RW again.

If it locks up again force quite, and try launching with the option key held down. Then see if RW will start w/o 3rd party addons.



Happy New Year!

Thanks for the suggestion. I tried your suggestion and I also, downloaded Ver 7.8 - and completely restarted the laptop. Feel much better now!



Not really related to RW8.7, but I have been having Big Sur issues as you have with apps “not responding”, and having to Force Quit them, especially if the iMac has been asleep for awhile. Affinity Photo, ACDSee, Preview, and a few other Apple Apps. RW has had to be force quit only a couple of times in the past couple of months. Should have just stayed with Catalina for awhile longer. Updating to Big Sur was discussed in a different thread I noticed as well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.