Official: Photo stack by Nick Cates Design


(Nick Cates) #1

Hello everyone! The launch of my Photo stack (for Stacks 3) has been a success beyond expectations, thank you guys! If you haven’t checked it out, here’s a link to Photo. Because there’s a good size userbase already, I wanted to create an offical forum thread for all things Photo stack related. Since Photos release, there’s been some uncovered bugs and many feature requests. I’d like to outline where Photo is at right now, and update this post every so often with new features.

Latest Photo version 1.0.3

Added: Batch sequential filenaming is FAR less strict. Any image naming that ends with “1” is now acceptable.
Added: NEW feature, Randomize Thumbnail Order (Photo Base > Avanced > Random Thumbnail Order)

1.0.2

Fixed: Lightbox overlay not appearing when choosing Lightbox caption behavior “hide”.
Fixed: Special keyboard characters in Photo Title names prevent images from appearing in lightbox.
Fixed: Small tint box would still appear if thumbnail title and caption individually hidden.

1.0.1

Added: Loader animation for Lightbox
Added: Thumbnails are optional
Fixed: Bug where scroll freezes on first click
Fixed: Contrast light theme color formatting
Fixed: Foundation Top Bar Menu button unresponsive after Photo Lightbox

If there’s anything issues, concerns, or request for Photo, just let me know!


(Mathew Mitchell) #2

@nickcates I have a question about batch sequential naming. There are a number of apps that see, e.g., image 11 as coming before image 2. So what is the best way to name images with your stack? Start with 01, 02, etc. (that’s my usual trick) or does your stack “know” 11, 12, etc. come after 3, 4, 5, etc.?

Many thanks. The stack looks very promising.


(Nick Cates) #3

Glad you ask Matt, as of Photo 1.0.3, the only requirement is the the first image starts with “1”.

No leading zero like “01”. Also “.jpg” file type is a requirement too, but normally that’s not an issue when dealing with a mass of images. Let me know if you have any more questions!


(Mathew Mitchell) #4

@nickcates Thanks! So 10 will be automatically recognized as coming after 9 rather than before 2? Some ordering approaches on the web do this: 1, 11, 12, … , 2, 21, 22, … and so on.


(Nick Cates) #5

Yes, 8, 9, 10, 11, etc is the correct way.


(Mathew Mitchell) #6

Fantstastic. Thanks for the confirmation. Looking forward to exploring Photo: you seem to have some great features built in.


(Nick Cates) #7

Since last week, here’s what’s new with Photo, the biggest news is, much requested Total CMS integration is now added in Photo 1.0.6!

1.0.6

Added: Photo is now integrated with (Drum roll…) TotalCMS Image, Gallery, and Blog Gallery! See manual for quick setup.
Fixed: Under certain conditions, sticky site elements were not clickable due to Photo z-index value.

1.0.5

Added: Thumbnails can now link to pages.
Added: “Loop Lightbox Images” options (Photo Base > Advanced). Default is enabled.
Added: Increased animation support for legacy Safari, Chrome, and Firebox browsers.
Fixed: Photo Base, enabling “Hide Title Caption” still shows group title on mobile devices.

1.0.4

Fixed: Disabling “Generate Low Res Thumbnail” not working for Grid layout.
Fixed: CSS from some themes causing right side cropping of thumbnail layout.
Fixed: Flow thumbnails not appearing with themes that animate the parent container.


(Marcel) #8

Good to know and it works to me also, but what about the name of the image? ''Flower1.jpg ?
Thnx
Mars


(Nick Cates) #9

Flower1.jpg will work.

For this example, the Batch URL would go http://my-website.com/folder/Flower1.jpg


(Matt Johnson) #10

Hi Nick –

A question: Is there any way of autoplaying the slideshow in Photo Stack (without a lot more expenditure)? I see it’s Total CMS compatible and there might be something there, but for that I’d probably have to get another stack as well – is that how you see it?

Thanks
M


(Nick Cates) #11

Autoplay, I’ve had a few requests for this. Short answer is, it’s currently not a feature, but on the “to add” list. I want to have this be an option, but the difficulty is in making it flexible enough for everyone who desires something like autoplay.


(Matt Johnson) #12

Thanks Man, for replying – I get that it must not be that easy. What I like most about Photo Stack is that it completely hides the gallery behind a single thumbnail. When I see the autoplay stacks, I still get a large amount of thumbnails visible either on the page or as a runner across the bottom of said page. Right now, it’s best for me to have the thumbnails not be visible, so I’m going with Photo Stack until you (or I somehow) figure out a way to autoplay the slideshow.

Best of luck to you.

Thanks, again.


(David) #13

In Progallery you can turn off the thumbnail runner completely. Have you tried the demo?


(Matt Johnson) #14

Downloaded – I’ll see if I can figure it out.


(Matt Johnson) #15

Hi – well, I’ve tried the demo with no success. One of my problems is that there is no instruction for the novice. The webpage says follow the instructions given in edit mode, but those are woefully inadequate for me. The thumbnails are huge and I don’t see how to adjust them and the slideshow doesn’t autoplay. I have no doubt that I’m doing everything wrong, but without detailed instruction I’m lost.

To give Nick Cates credit, his instructions are to the point and easy to follow to get exactly what I’m looking for – except the autoplay.

Thank you so much for your suggestion, but I guess I’m a dolt in these things. I’ll stick to what I have for now and I’ll continue with the demo and other things when I have time to learn by experimentation.

Cheers,
M


(Nick Cates) #16

My Photo stack has been updated (1.0.9), Autoplay is now a new feature! Very easy to implement.


(Matt Johnson) #17

That’s great! Do we need to repurchase to download the upgrade (I just bought it a few weeks a go)?


(Robert Ziebol 🖖🏼) #18

Check for updates in the Stacks Plugin.


(Nick Cates) #19

Yep, the built in Stacks update system is all that’s needed :slight_smile:

Autoplay can be found under… Photo Base > Advanced > Autoplay


(Matt Johnson) #20

You guys rock – thank you from a real newbie.