OS Monterey (Developer Beta) Upgrade

Accidentally upgraded to OS12.0 beta, what to do now? Crashes after startup.

I’d say rollback to Big Sur asap, did a quick google and found a video on how to do it — Downgrade from macOS Monterey to Big Sur or Catalina on Intel and M1 Macs! - YouTube

It turns out Monterey doesn’t include a PHP web server, so you won’t have much luck when trying to preview in RapidWeaver 8.x – We’re looking into a fix and will publish an update as soon as we can.


Thanks! …I was such an idiot!

No worries, these things happen!


Any news on this topic? I’m a developer and rolling back to macOS BS isn’t an option. Got a second computer, of course, so I’m not without RapidWeaver. But I use the macOS Monty computer for testing.

We’re working on it, but it’s not a quick fix… will post as soon as I have more news.

Hang in there, we’ll get it working!


Thanks, Dan. This is the first time I hit upgrade without checking all my apps first. Today, I’m the idiot. Appreciate all your hard work!

Hi, Dan. I was a bit too fast with upgrading to macOS Monterey as well. Will the RapidWeaver compatibility update be a regular update for everyone or a beta update? I look very much forward to this particular update. :wink: Thank you for your hard work!

All who have upgraded: Why are you not reinstalling PHP with Homebrew on your Monterey machines? This should fix the PHP server issue and enables preview of PHP pages inside RW again.


Ive tried homebrew, it installed but I think I need extra instructions on what to do next as RW still crashes on preview. No worries, its not my main Mac.

1 Like

I wonder if you could symlink /usr/bin/php to /usr/local/bin/php?

You cannot tell RW to use homebrew php to my knowledge.


Careful with PHP 8 though. It will break a lot of things right now. Stick with 7.4 for now

1 Like

Hello, Joe. First, thanks for all your amazing work and contributions to the RW community. You make things SO much easier for old print designers like me. That said… any chance you could explain in simple words what your comment means and if that actually would work?

I made the mistake of upgrading too early and now am struggling with this whole preview thing. THANKS again!

I have to be honest. I keep that comment very technical on purpose because it is…

All of this needs to be done via terminal. You need to install homebrew and then use that to install PHP 7.4. Then you need to create a symlink (similar to an alias in Finder) from where Apple used to store PHP to where homebrew installs it.

Off the top of my head, these are the commands to accomplish the above once you have homebrew installed.

$ brew install php@7.4
$ ln -s /usr/local/bin/php /usr/bin/php

Good luck! Again, I don’t have a Mac with Monterey so I have no clue if it will work. But it’s worth a shot.

Everyone, please keep in mind that there is a reason that Apple calls these developer betas. If you are not a Developer that ships Mac apps, you should probably wait for the official release.


I’m not a developer, so I downloaded the public beta. :innocent: Now waiting for the RapidWeaver public beta. :wink:

You might want to consider downgrading back to Big Sur, or it could be a long wait.

If you prefer written instructions


We’re aware of this issue and are working on a fix. We’ll hopefully have some more news on this next week. Fingers crossed.


Okay @david79 @MaxDadEO @jspencer2 @instacks @joeworkman @bwil @montanaken

We have an officially unofficial beta of RapidWeaver 8 for Monterey, please take it for a whirl!

This new build includes PHP 7.4.21 and runs on both Intel and M1 based Macs.

Download RapidWeaver 8.8.3 (20878b) for Monterey (fixed link!)

If this is working great for everyone (it’s worked in our tests) then we’ll probably release it later this week/early next as RapidWeaver 8.9.

Let me know how you all get on.

Happy Weaving!



Seems to work just perfectly here. Thanks, Dan!