Page Inspector not working


(cyclingone) #1

Hi all:

This seems to be a recurring problem for me. First of all Stacks, RW, and El Capitan are current and up to date.This problem was happening in Yosemite as well.

Using Foundation on a one page site. When I go to the page inspector and click on one of the arrows to expand the options, the options expand for a millisecond and then close again. This happens with all my stacks. Sometimes they work properly expanding but most times they don’t.

I’ve closed RW 6.3.7 and reopened it - same problem, reinstalled it but same problem. I’ve rebooted, same problem. I’ve opened other RW projects, same problem. (sure am getting tired of writing ‘same problem’)

The strange thing is that very occasionally the inspector works as it should and I don’t know why.

Any help would be much appreciated.

-Barry
SilkyWebDesign.Com


(Mark Sealey) #2

Barry,

Long shot here: it couldn’t be that the Delay Until Repeat setting in your mouse configuration are too short, could it?

(Doubt it. Good luck!)


(cyclingone) #3

Thanks for taking a shot…but, no, still same problem (there I go again). I appreciate the try Mark.


(Mark Sealey) #4

Barry - fears as much :frowning: sorry!

It looks as though something may perhaps be preventing whatever values corresponding to the Inspector’s settings stored on your disk from loading - and hence from displaying. Sound plausible?

Have you tried viewing your (computer’s local) logs in real time while you replicate this phenomenon.

In Console look at all logs but with a filter for ‘RapidWeaver’ in force.

Do any new entries appear when you click as described?


(Brad Halstead) #5

@cyclingone

I have the same problem but with Safari Zoom feature… I do not trigger it, it just happens all on it’s own… am wondering if this particular issue is an El Capitan issue… of course, I have not done a clean install so that may be part of legacy code from within previous OSX… it’s as if there is a false double click or something happening correct?

What is your pointing device? Mine is first gen  magic mouse (Glass top). I also have a  trackpad but have not tried that yet as a mouse is more my style…

Unfortunately I find a reboot resolves the issue for awhile for me, but the issue does not occur in anything other than Safari.

Not much help I know, but maybe more insight?

Brad


(cyclingone) #6

@Turtle: This was happening in Yosemite on occasion as well. And it’s a problem with page inspector not the preview. I can’t even get that far. Have several pointing devices ie. 2nd gen magic mouse, Logitech MX Revolution, Anker Vertical mouse and a couple more…none of them solve the problem though.

@Mark:
I don’t see anything in the console that would lead me to think I found a problem. As a matter of fact there were not even any entries from today, even though I spent a couple of hours trying to do different things in the inspector. Tried different stacks, drank a pot of coffee, spun around 3 times, but still the same problem.

Here’s a cut/paste of the latest RW console entry from last night. Again, nothing shows in the console from today.

Command: RapidWeaver 6
Path: /Users/USER/Downloads/RapidWeaver 6 4.app/Contents/MacOS/RapidWeaver 6
25 __76+[RWDocumentController restoreWindowWithIdentifier:state:completionHandler:]_block_invoke24 + 109 (RapidWeaver 6 + 347965) [0x108ab4f3d]
Process: RapidWeaver 6 [13426]
Path: /Users/USER/Downloads/RapidWeaver 6 4.app/Contents/MacOS/RapidWeaver 6
25 __76+[RWDocumentController restoreWindowWithIdentifier:state:completionHandler:]_block_invoke24 + 109 (RapidWeaver 6 + 347965) [0x108ab4f3d] 1-25
0x108a60000 - 0x108b33fff com.realmacsoftware.rapidweaver6 6.3.7 (15153) /Users/USER/Downloads/RapidWeaver 6 4.app/Contents/MacOS/RapidWeaver 6
Responsible: RapidWeaver 6 [13426]


(Brad Halstead) #7

This is a good one for @nikf

I know it is Sunday, but perhaps send an email to support@realmacsoftware.com describing your issue and see if they have suggestions.

Have not seen this particular issue on the forums before (in last 8 months)…

Sorry can’t help more
Brad


(cyclingone) #8

@Turtle:

Yeah, I’m sure he’ll see this one and want to comment.

Thanks for trying…

-Barry
SilkyWebDesign.Com


(Brad Halstead) #9

@cyclingone

Try this thread in the forum… I missed it in previous search…

Brad


(cyclingone) #10

@Brad:

If I were ‘that way’ I would give you a humongous kiss. But, suffice to say, this worked and I owe you a HUGE debt of gratitude. You did my work for me. I should have done a more thorough search than I did.

I read the thread as you suggested…did what it suggested, then took the dog for a walk before testing it because even though I read all the positive comments in that thread, I really didn’t want to get my hopes up.

So, me and the dog (or the dog and I…I’m so excited I can’t speak right), we came back in from her walk, I made myself a cup of coffee, crossed the fingers of both hands (which is hard to do with a cup of coffee in one of them) and sat down at the Mac, restarted RW, checked the inspector and BOOM, everything is working like the proverbial charm.

Thank you, thank you, thank you for your efforts. Now it’s back to work. I’ve got a lot of projects to catch up on. You 'da man!

BTW, I hope you got your ‘zoom’ problem fixed.

-Barry
SilkyWebDesign.Com


(Brad Halstead) #11

@cyclingone, whew, I’m glad you’re not that way lol… you’re very welcome, glad I stumbled on it and was able to point you to it.

Brad