Page Links Aren’t Working


(Lance Pettis) #1

So I set Links On the Home/landing page to direct visitors to the about page. They worked fine on preview. After publishing, however, only one is working and now I can’t get them to work even in preview. Am I missing something? I did disable the about page when first publishing but have since enabled and published that page as well. Thank you for any help you can give me.

Lance


(Greg Schneck) #2

can you provide a link to the website?


(Lance Pettis) #3

atouchingtribute.org


(scott williams) #4

are you referring to the menu or are there links somewhere else? The menu links work for me…


(Lance Pettis) #5

On home page if you click on the “the long war memorial” it takes you to the about page. Clicking on the artwork is also supposed to take you there. I also had a “Learn More…” link at the bottom of the page that was set to link there. In Preview mode, Everything was redirecting as intended but after publishing, only “The Long War Memorial” link was working. I tried to reset the links but now I can’t get them to work even in preview. I’ve tried using the Link button in edit mode as well right clicking to set the link that way but the links won’t set.


(scott williams) #6

the long war memorial links to …page7/page1/index.html and seems to work.
I can see where there are some other links but they seem to be covered by the extra content3 area.
The first thing I would do since you disabled and re-enabled a page is go to file menu and select re-publish all files. That may get things back in the proper order.

As a side note, you should name your folders something relevant (for SEO and your own sanity) in the page inspector. Leave the file name blank RW will name that index for you.

Make those changes and re-publish all files - see if that fixes things for you


(Isaiah Carew) #7

This page is pretty strange. And it has a number of issues, I’m afraid.

The one you’ve noticed is because one transparent container “myExtraContent3” is overlapping the whole page. It absorbs all the clicks and doesn’t let any of the clicks fall through to the links underneath.

You can see in the screenshot I took below. The green is your main image. It is correctly linked. But aside from a tiny bit that is visible on the far right side, you can’t click it because the pink covers the whole thing.

I

I should also note that I see a few other strange issues with the page too.

One is that your links contain " " (space" characters. While most browsers are OK with that, it’s definitely not valid code and is highly discouraged. Usually RW takes care of that kind of thing for you during publish – I’m not sure how you got those sneaked under the wire. :stuck_out_tongue_closed_eyes:

This page loads over 20 css files, 7 javascript, and… 5 fonts OMG :scream:

The page is also a stacks page – but its – well – it’s unrecognizable as one – it seems to be missing some bits somehow.

I’m honestly not sure how you did this. Either there is some interesting JS re-organizing the page on the fly (what i suspect), you’ve dismantled and reassembled the page by hand, or … well… or you’ve found some pretty strange bug in Stacks (i hope not). :wink:

For all of these problems I’d recommend the same thing: simplify simplify simplify.

This page is not too terribly complicated – but the code/scripts/fonts/structure is REALLY complicated.

I suspect you’ve got some pretty custom setups, a very adventurous theme wizard, and/or pluskit/extra-content/i-don’t-know-what that seem to be working at cross-purposes.

I might try re-building the page using just basic tools. Toss ALL the extra bits out for the time being. Try to build the page with just the basic built in stacks.

Then, slowly, one by one – addd back in the extra bits you absolutely NEED. And realize that each one will slow the page down – and slow pages are unread pages on the internet.

And if you discover it breaks again while adding things back, then… well… take a step back.

Good luck,
Isaiah