Problem opening RW7 files in RW8

Hello, I can’t seem to preview my RW7 project files in RW8. I’m getting this error message. Looking for some help please.

You said “preview” and “opening”, when did you get the exception?
Can you still open the project with RW7?
Have you tried an older (TimeMachine) copy of the project?

Hi Doug,
File opens in RW7. It’s only RW8 & Browser Preview when the problem occurs. Edit mode is fine. Seems to be an issue only with complex projects with lots of pages. Smaller files are upgrading as they should. I have restored a TimeMachine backup of one of the problem files (pre system upgrade) but getting the same error message. The only way I can think to fix this is to open a new project in RW8, add stacks pages with same theme/settings then copy and paste all the Stacks elements into the new file page by page. That seems to work but VERY TIME CONSUMING. Thankfully RW8 has multiple stacks selection and copy & paste. Maybe someone from RW can shed some light on this.
Many thanks,

Thinking about this further, this may be the result of an OS upgrade from El Capitain to Mojave.

If could be the OS update, but I think that would affect RW7 as well.

Haven’t encountered this issue opening any project files in RW7.

If you can get a small project to fail everytime, perhaps someone from RealMac could check it out for you.
any errors that start with NS (NextStep) are program errors.

@Aaron @dan ?

1 Like

This sounds like a plug-in which was working in RW7 but not in RW8. Does your project rely on a plugin like pluskit? Then update them for RW8‘from

1 Like

It looks like you have some incompatible plugins. I would recommend removing any that you’re not using actively and updating all the rest.

If that doesn’t help, then I’d recommend removing them all – then adding back one by one until you find the source of the problem.

All of the YourHead and LogHound plugins have free updates for Catalina and the latest RW. You can find them all here: just download each one and double click to install. :smiley:

Thanks @teefers, @Fuellemann and @isaiah. Upgrading to Pluskit 4 fixed the problem :smiley:

Hi @isaiah, I have SiteMap Plus 3.2.1 installed. I see from your download section that you are calling it SiteMap (dropped the “Plus”). I also have the RW plugin Sitemap 7.0 installed. Which should I use?

The built in one is the one that comes with RapidWeaver (and so has a related version number – RapidWeaver 7 comes with SiteMap 7).

SiteMap+ is the one you paid for – it has some more features, and has a sitemap file that you can customize a bit, and can send info to Google to help your site get recognized.

Most people that purchased SiteMap+ prefer to use its extra features, but it’s entirely up to your which you use.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.