Problem with top bar stack


(CaFra Arabians) #1

I have a prob with my menu in the top bar stack.

Menu settings are:

Then i export my website to a folder and open it with firefox.
Folder names are page 1, page 2, …
The folder structure is:

Now clicking on a page in the menu, the page does not open, but i get.

I may solve this problem by giving exact names to the .html files of the pages, so in the page5-folder not index.html but page5.html. Then the page is found.
But in the moment, the page name is index.html the page will not be found.

I worked with RW before, never had a similar problem, but i am new with foundation.

Any suggestions please?


(scott williams) #2

Are you actually publishing?, do you have a web server running?


(CaFra Arabians) #3

I didn’t because it is brand new and still private.
I am used to test my new projects via the export function on my local Mac.
Works fine with all other templates by now.
But not with Foundation.
So i published it and - wondering - it works online!

Thanks for your help, problem solved!

Thank you very much, Barbara


(CaFra Arabians) #4

Never the less, it’s a pity.
Because so i may not send the project as a zip-file to my client so he may have a look on it on his private computer.
Hmmm…


(Brad Halstead) #5

@cafra

Barbara

Having folder names of Page1, Page2, etc is not that descriptive to Google or the end viewer of the website…

Change the folder names in the inspector tab of each page, first tab to be more descriptive, short as possible, no special characters, spaces or capital letters.

As for sending a zip file and having the end user view the site offline, they would need a server of some sort to extract the site into. For best results, post to a testing domain for the customer to look at and verify everything ok prior to sending site so you don’t get your hard work stolen… (its a cover your butt thing…)

HTH
Brad


(scott williams) #6

In this instance, you should publish it to a test area, maybe even lock it down.

Once you have approval, publish to the perminant location.


(CaFra Arabians) #7

My prob had nothing to do with foundateion :wink:

I solved it by deactivating the button in the settings (don’t know the exact translation, but you will see what i mean).