Problems uploading sftp strato (Resolved!)

Hello @dan hello people, anyone experiencing the same problems?

Publishing on since RW8.1 is getting problematic.

Sometimes it works, sometimes not. Mainly it works at first issue, publishing one only page.
As soon as the work is bigger (even with compatibility mode speed) and involves more than one page it does not work. Timeout reached says the information about the error.
I tried:

  • new site
  • new ftp access
  • new parameters

With exactly the same parameters Cyberduck performs the task, but it is not the same way of working! It does not permit trial and error


Yes, I have a similar problem with strato for about 3 months now. The error message is not the same but it is probably a RapidWeaver problem as this occurs only since an upgrade.

I have resorted to exporting the site to a directory on my desktop and using “Yummy ftp Pro” to upload the content to a directory that I then swap names with the original. Of course a fix would be good but life is too short. ! Attached the ftp settings I use.

Screenshot 2021-04-11 at 01.54.35 Uhr|523x406

FTP is outside of my area of influence, but I do FTP a lot of files, so I’ll tell you what I do when this kind of thing happens to me:
First, I’d try a different protocol, if your hosting company supports it.

Some hosts have much better support for FTPS than for SFTP and of course, vice versa. Sometimes one is very fast and the other is very slow. It’s worth trying even if things are working.

Then, I’d try deleting all of the Publishing settings, and re-adding FTPS and SFTP again by hand. No copy/paste from the broken one – just in case.

My short anecdote:
Once, a long time ago, I had an FTP issue I couldn’t fix for the longest time. I knew my password was right, I knew URL was right, and all the rest looked just like the working setup to the same host in Coda.
So I deleted everything, but when re-entering it from scratch I took a shortcut to copy from the old setup – and the “Path” had an extra space character.
I’m not sure if the problems started occurring when I accidentally typed the extra " ", or perhaps the host just stopped being tolerant of the extra space one day. But I know that removing the space fixed the problem.

If you have tried doing this sort of thing already, then don’t bother doing it again obviously – but do tell us a few of the things you have tried over the past three months.

Knowing what things have been tried and failed to have an effect can help bug hunters at Realmac narrow down their search too.


1 Like

Hi @MadComposer , at least is not just mine problem… geteiltes Leid…

Thank You @Isaiah , it is a very good suggestion… I’ve tried it several times renewing and rewriting the whole, no hidden spaces or strange characters. It happened to me once with a ctrl-D that was an invisible character since then I’m very careful with typing.

…it looks I have to wait for the next upgrade. Meanwhile I’ll try to figure out the steps that lead to success :wink: because it is far more seldom in the last week.

Did you try setting a new FTP user in Strato and to use this one in RW?

1 Like

Yes, done this as well. But I will try it again to be sure

Thank You for the idea @Fuellemann

I just set a new sftp account. This worked. Let’s see if it will continue working in the next few days… functioning was random 98% negative in the last week.
I keep You informed, if this is the solution.

1 Like

take a screenshot of the functional settings. it won’t show the password, but it will show everything else. that way you can always be 100% sure on every setting other than the password. and if everything else is known, you can always sent the host a password-reset and get that last bit too.

once you have a working setup – you know all other failures are either host (your webserver), client (RapidWeaver), or the connection – your 'net provider.

so from here, pay close attention to any error messages. there’s a small blue “i” in some of the FTP feedback windows that you can click on to get the actual server messages and low level network errors when they happen.

if you have a failure and get one of those messages, post it back here and we’ll go from there. :smiley:

Thank You @Isaiah . I took the Sunday off. Later on today I’ll work on that. Should I have problems, I’ll post them here.
Should the problem be lost, then I’ll post the solution that worked for me :cowboy_hat_face:

Have a good day and a good week!!

Thank You all for the hints.
Apparently the mistake was mine… caused by Strato.

What worked for me was:

  • Setup of a new sftp account at Strato
  • erase old ftp account from Strato and Rapidweaver
  • on Strato allow only sftp connections
  • insert the new sftp account on Rapidweaver from scratch manually

Have a good day and thank You for the great support!!


@sandokandrea I’m please you resolved the issue, and are back-up and running.

For anyone else reading this thread and having problems publishing, please remember to go through our How to Fix Publishing Issues help guide, and to use RapidWeaver 8.8.2 or greater as it has the “Upload Logging” feature.

1 Like

@dan Will you issue the 8.8.2 today?

That’s the plan, just waiting for Apple to “notarise” the direct build :roll_eyes:

AppStore and Setapp versions will be a while longer as we need to wait for both parties to approve the builds.

I’m sure it takes longer to ship updates than it actually takes to fix the issues these days :crazy_face:

Will post an official announcement once 8.8.2 is available!

RapidWeaver 8.8.2 is available directly now:

App Store and Setapp coming as soon as they are approved.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.