Problems with uploading website after update from RW 5 to 8

I update from Rapid Weaver 5 to the latest version, nr. 8. I load the Rapid Weaver website file in to Rapid Weaver 8 and after making changings in the website i try to load it up to my hoster. (Siteground is my hosting company). Didn’t change nothing in the publishing settings but now i can get in my server. I always get the message:“Couldn’t sign in to your FTP server, URL using bad/illegal format or missing URL.” What i try, i can’t manage it. Even called the support of Siteground, but even with them we could’t manage it. Maybe some of you had the same problem and so yes, did you have found a solution for this problem?

I really hope that you can help me!!! Thanks on forhand.

Can you take a screenshot of your publishing settings and post it here? There may be a clue as to what is going wrong there.


1 Like

Sure i can Rob!
This is RW 5.

And here is RW 8.
Much more things to “fill in” must say eveything was already filled by loading the RW5 file in Rapid Weaver 8. That what is making it so strange. Don’t think that much is changed. But still no possibility to get in with 8 and no problem in to get to my server with 5.

Looking to picture of 8, did some chancing, Mode, normally “Extended Passive” and Backup Fr. normally on “Never”. There was no different in the setting as above as the standing as standard.

what happens if you click browse for the path setting?
Does it connect and let you browse the folders?

If not, there is something amiss with one of the seetings above( Method, server username or password.)
edit: I am assuming you are not using Cloudflare or similar CDN in the above statement.

No i am not using Cloudflare, and using browse i still can’t make a connection. Maybe the problem is with the “port”?

Port number should be 21,

there sould be filled in 21 but it ask for a much higher number, and of course clicked different times auto and restart Web server. If i click “currently running” i go to the web page. So one a way there is a connection. But why not when i want to up-load. Maybe in Advanced settings the most change that there is something wrong?

then you have a credential or server address issue )or maybe you have been locked out because of too many failed attempts) try putting: in the Server field, or instead of the ip address

I tryd, but also same result. And i don’t think i’ve locked out because with the old version of RW 5 i can get in without any problem. If i use test connection there is no problem. And yesterday/early in the morning i did a complete upload with RW 5

thats not for ftp, thats for the built in webserver for preview I believe.

Do you have an ftp app?

Trying to discover if its your credentials/ftp settings or something else.

Assume you have restarted RW and your MAC.

No i don’t have a ftp app at this moment, on a older Macbookpro i used Duck… maybe sued get it again. But it’s so nice and easy to just do it by page out of Rapid Weaver. :frowning:

Yes I understand. I publish from RW but just trying to see if it is a RW issue or something else. Everything points to your log in credentials and ftp settings. Since you never achieve an actual connection to the server.

What happens when you try:

  1. Test
  2. Changing the Mode to ‘Extended Passive’


Did a lot of times “test” and also with Extended passive, the default setting. Think the problem has to do with advanced setting, the help from the helpdesk of SiteGround was saying that the port has to stand on 21. Filling that in had no success and auto also not. And i can’t remember if the “port” in RW 5 could be filled in or where you can find it in RW 5. Would nice to see what it says in 5!?

add :21 to the end of the server address

William, i tried that also with 21. There was no succes. But don’t know why, but i am very glad, he is doing it, after again replacing the username it suddenly works. So know he is very busy with up-loading. I think something went wrong with “transmission” from 5 to 8. The username was in 5 only once and by trying in 8, clicking in the username, it shows the username 3 times. So i deleted two of it. But probably not good enough? Copied just from my users page of SiteGround again and suddenly the server connected. Bill and William, i thank you both for helping me!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.