Publishing can't updating... again


(marantz pratama) #1

Hello all, I have a problem with updating the website. the publishing set up seems all ok and all the processes… the path and the server still same as previous… the browse button also can be connected and locate the file directory of the cpanel…

I have the same issue as I posted to this forum on Feb 5, only that time it was the provider’s fault regarding server down…

but this time they say their server is up and its the developer’s fault…

is anyone familiar with mochahost or using the service?

thanks in advance…


(Rob Beattie) #2

Given your host was reluctant last time to admit being at fault, I’d press them again. If you’ve changed nothing your end then it may well be down to them again. Maybe time to consider another hosting company?

Rob


(marantz pratama) #3

thanks for reply and really appreciate your comment, Rob.

I have pressed them about the issue as the last february… still they say its the third party problem.
now they’re asking me to upload manually… I really consider about changing the hosting company… but sadly, I just extended for another 3 years last week.

do you know how to upload the file manually to the cpanel?
taking “the file” from rapidweaver then extracting it in the directory files…

its totally old school and I’m still way out of league for this.

thanks again…

Marantz


(Rob Beattie) #4

I wouldn’t bother with CPanel.

Best bet is to use an FTP program. FileZilla was free last time I looked, and there are very good paid-for ones like Yummy - which I use - Forklift, and others.

  1. Open your web site in Rapidweaver
  2. Open the File menu and choose Export
  3. Choose a destination on your hard disk for the exported web site - I usually create a new folder with the name of the website
  4. Export the site
  5. Look in the folder you just created and you’ll see all the exported files that go to make up your site - there’ll be an index.html or index.php, and folders called things like rw_common, resources, files, etc.
  6. These files need to be copied - using the FTP program - to the root of your web server - usually in the public_html folder (but not always)
  7. Ask your web host where the root is and then get the credentials you’ll need to sign into the server via FTP - this will be the name and password you use in RW when you’re publishing.
  8. Then you drag and drop your website files onto the server, a bit like copying them from folder to folder on your Mac. You’ll see a warning that you’re about to over-write the website files that are already stored on the server but assuming you’re updating the site, that’s OK.
  9. Unfortunately, you’ll have to do this every time you update the site - though some FTP programs let you automate this.

Good luck!

Rob


(Doug Bennett) #5

As I answered in the pm you sent me.

Without knowing additional information it’s difficult for folks to help you out.

  1. Does the hosting company have a file manager?
  2. Does the last maintenance date change in file manager?
  3. screenshot of the publishing settings
  4. what happens when you publish? Any error messages?
  5. hosting company name

FileZilla is an open source project so it’s free and probably always will be. It’s probably the most popular ftp app on Linux and very reliable on all platforms. The UI can be a bit intimidating (kinda Busy) but once you get used to it’s easy to use.


(marantz pratama) #6

thanks for providing the steps…

unfortunately the upload is not complete in the file manager.
only the index.html and sitemap.xml are completed.
the rest of the files are hanging in the middle…

so the content is not completely showing.

the limit says 512MB, my file is only 21MB
my package : Business 3y (Linux) G28

problem with the upload?


(marantz pratama) #7

thanks for the reply

  1. yes it has the file manager

  2. well, I don’t know about the changes but it say about server security update…

  3. hosting company name is mochahost

thanks teefers


(Doug Bennett) #8

Hosting limits are usually not for individual files but for total space you use for the account.
Have you checked the total space you are using for your account?

Looks like the hosting company has a KB article on FileZilla, have you tried connecting with that or another ftp client?
http://www.mochasupport.com/kayako/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=656

Judging from the cPanel screenshot you might be over the limit, RapidWeaver doesn’t delete anything, if you have published files in the past to a wrong path, those files are probably still there and eating up your file space.


(marantz pratama) #9

Hello Teefers,

thanks for the reply… after using the Cyberduck or FTP client now is solved.
Apparently, file manager in the cpanel can’t be used for uploading the content.

Well for the next 3 years I need to upload manually to get webpage update… T_T
better to find a better hosting company next time…

Thanks again Teefers and Rob for guiding me.

Marantz


(Rob Beattie) #10

I still reckon it’s your host! :sunglasses:


(Joe Martin) #11

I noticed that you don’t have the website address defined.48%20PM

Also the path…that is not a normal ftp address, normally it is something like:
/public_html/xxx


(Doug Bennett) #12

Why don’t you give us a screenshot of the Cyberduck settings?

You gave us a screenshot of the RapidWeaver publishing settings so someone here can probably figure out what’s wrong.


(Don H) #13

It would also help to see a screenshot of the Cyberduck window immediately after connecting, so we can see what directory you are placed in after login.


(marantz pratama) #14

with the cyberduck connected to the file manager…

I simply just drag and drop all the files from Rapidweaver as the path or root files directory… and all is done…

since this is manually setting with the same server ID… is there anyway some problem with the rapidweaver publishing setting even not showing any error?


(marantz pratama) #15

well, I got the path after I register the domain to the FTP account…

my other websites has the /public_html/xxx

but some are not…


(Doug Bennett) #16

In RapidWeaver have you tried to clear everything out of the path field and hit the Browse button?
You should get a similar looking pop up to the screenshot you have in Cyberduck.

If you see a directory called bcpeckasa.com try selecting it.

I never have used CyberDuck so I don’t know if there’s a settings area that you have specified any path.