Publishing failed / Blank page

I am using a second server for test and discussion purpose. It worked perfectly until few days ago. After deleting files and publishing a copy of my website, I could see only a white, empty page. However server is running perfectly, ftp works and shows uploaded files.

As a workaround we switched of Apache and website was accessible again. However due to need to change to PHP service for a function in progallary stack I need the Apache.

What could be the problem?

Do you have multiple index pages?
One that’s php and one that’s html.

No. I just saved file as … with you name. Then changed settings for publishing and published at a different server. And it worked (!) To avoid conflicts with former sites I deleted files by Filezlla and published. But when accessing by browser an empty page will appear.

How exactly did you ”switch off” Apache?

Are you self hosting the site, on a VPS or what?

Do you have a URL?

I talked with the provider where I host my website. He did it. I am not IT specialist.
He identified something unclear watching the publishing process and just tried.
But he could not explain. As I want to use progallery with CSV option from stacks 4 stacks which requires PHP we switched Apache on again. Now the empty page is again reality. or https.//

Well, the site is completely empty, so no index files.

Have you tried to export the site locally (please make sure that you “mark all pages and ressources as changed” and upload this directory to the folder for the subdomain “relaunch”?

(And have you checked if PHP is enabled on the server?)

And, if PHP is enabled, checked it’s logs?

If some code is causing an error on the page, it could prevent PHP from writing any content to page. Since PHP is server-side code, you won’t see the errors with most default PHP setups.

1 Like

I have access by Filezilla and can see all files are there. Before I deleted all from the directory. Publishing process by RW shows as well no problem and indicates successful publishing. Once it worked. Than after 2-3 x publishing suddenly empty page appeared.
Right now I try to identify the empty page. When it is solved I will focus on php. However I will ask my provider. But I am sure it is.

Ok. But all files are uploaded. But how to identify an invisible error code?
However the provider checked during a call directly the process and status and could not see any problem. As it worked once it is very strange.

I would ignore Rapid Weaver for the moment, I believe your problem is on server level:

  1. Clear the whole directory for the subdomain
  2. Upload a plain index.html with just bare “Hello World” (something like below) and hit that url with the browser. This confirms that the subdomain is properly setup and running (currently, the request to server simply fails, “no one is picking up” so to say)
  3. Change index.html to index.php, perhaps change the heading as-well, just to be sure you see a difference. This confirms that PHP is set up and running (but doesn’t do that much)
		<h1>Hello World</h1>

Thank you very much. This is allows to analyse problem step by step. I will do tonight when back.

You would need to look at the PHP log files on your server. You should have access to a control panel which allows you to view them. Any PHP errors should be logged there.

I emptied the subdomain. Then I uploaded the file created with Textedit, saved as html and named index.html and after Hallo.html. When accessing the website, it showed following error message.

It was a problem by using capital letters. now it works. The result shows, that the server settings are correct as a non RW website is displayed.
So, what should I do?

Did the PHP file work as-well?

I do not use an PHP file as far as I know. However after the upload of a totaly different index file (nothing else) of my provider, the uploaded website worked properly. Then I deleted this html file and published my website and it worked. But deleting all files and again publishing a copy of my website (saved as) produced the the same error again.
Is there a possibility that something hidden remains on the directory which causes problems?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.