Home page is blank


I just published an updated version of my website www.zozobanana.com (code to get in: 302618), and all went well, except that the home page is now completely blank. All other pages were published just fine.

Anybody any clue why this is happening?

The only thing I can think of that may have something to do with this is that after publishing RW gave me a prompt saying that I am using two different indexes (php and html). Strangely though, as far as I can see - and I just rechecked - all my pages have ‘index.php’ filled in the Filename area in RW.

Thanks for your time and help in advance,


PS: These are the Meta Data windows for the home page and the first page after that…



This can happen for a number of reasons. You may need to go in to your hosting and manually delete the index.html file.

I’m not sure why the home page is blank, though. Have you tried to ‘republish all files’? Is it displaying correctly when you preview it?

Hi Jason,

OK, I deleted the index.html file in my hosting and indeed that took care of the dual indexing problem. Thanks.

Yes, it’s all displaying fine in preview. And after publishing ‘all pages’ the issue of the blank Home page did not go away. Which also means the indexing issue had nothing to do with that, but that was a long shot anyway,

Thank you for your input!


On the published page there is basically no content.
If it looks okay in preview in RW, try preview in browser.
If that is okay then something isn’t publishing, or you have a server issue.

Thank you Scott.

It looks fine in both the RW and browser previews. So then indeed something is not publishing - but why not? - or I have a server issue. I am in touch with ChilliDog hosting about this issue too, and this is what they wrote to me:

Blank page is a php error on the page. Check the php version requirements for the software you’re using. You may have to change it via the php selector in the control panel

Now most of that answer I do not understand: I don’t know how to change something in the ‘php selector’ in the c-panel as I have never done that before, I don’t know what to change it to, and I cannot even find such a selector in my c-panel. Also, I am missing the logic, for why would a php issue only influence one page, given that all my pages have the same index info in the meta data?

Anyway, I have replied just that to Chilli and I am awaiting their reply. Their service is great so I suspect they will help me find a solution soon. They probably just need to dumb down their advice to me so I can follow it.

log into your control panel on your hosting and make sure you php version is at least 7.2 (I think 7.4 is latest) Under the software section there should be “multiPhP manager” that’s where you set it.
as for why only one page, it could be that’s the only page you have that needs php.
What’s on that page? any forms, cms data, etc?

If it was a php version issue, wouldn’t that impact the other pages on the site? Those are all working from what i saw.

not if the other pages don’t need php…

They’ve got Page Safe on them which needs it, I think.

Anyway, I’m sure Chillidog will get Jim sorted…

Thanks Scott, but that did not help. I upgraded to 7.3 (7.4 was not available), but that not do the trick.

Did not work, but at least with your input I was able to change the PHP. Is good to know!

I looked at the source on that published page and it’s practically empty.
What does that page look like in RW edit mode? What is on that page?

Can you export(publish locally) that page and send it to me?
This doesn’t make any sense, it’s like RW isn’t creating all the source or something when you publish.

You don’t have the bulk of it in a stack set to “not publish” by any chance do you?

EDIT: are you using anything like the Agent stack on the page?

This is the entire contents of the page body:

<body class="antialiased">
  <div class="blur_wrapper">   	
<div id='stacks_out_1_page18' class='stacks_top'><div id='stacks_in_1_page18' class=''><div class='slice empty out'><div class='slice empty in'></div></div></div></div>
  <!-- Base RapidWeaver Javascript -->
  <script src="rw_common/themes/Foundry/javascript.js?rwcache=605122230&rwcache=605122230"></script>
  <!-- Load jQuery -->
  <script src="rw_common/themes/Foundry/js/jquery.min.js?rwcache=605122230&rwcache=605122230"></script>
  <!-- Tether.js || used for tooltips -->
	<script src="rw_common/themes/Foundry/js/tether.min.js?rwcache=605122230&rwcache=605122230"></script>
	<!-- Latest compiled and minified JavaScript -->
	<script src="rw_common/themes/Foundry/js/bootstrap.min.js?rwcache=605122230&rwcache=605122230"></script>
	<!-- Style variations -->
	    	<!-- User defined javascript -->
	      <!-- User defined styles -->
		// Initializes dropdowns
		// Initializes popovers
		$(function () {
  <!-- Foundry theme v1.0.1 -->

There is no content.

There is a lot of content on my home page, or should be. Here is a link to two screenshots of RW in edit mode…

How do I export only that page? I know how to export the whole site, but not just one page.

I don’t think I have it in a stack that is set to “not publish”, but I would not know where to check or uncheck such a setting, so maybe by mistake…

I don’t think I am using an Agent stack as I have never heard of that.

Right click on the page and publish (locally)

You are sure you republished all files from the file menu.
What happens if you remove PageSafe?

I was able to publish the page locally, but I am such an amateur that I cannot find the exported file! :blush: I checked all the usual spots, but I do not see it.

Yes, I am sure I REpublished ALL the files: I did so several times. Just now again.

I removed PageSafe and that made no difference. Because of you I did notice that on the Home Page I had three PageSafe stacks in stead of one, which made me somewhat optimistic, but after deleting first two, then all three, and republishing all pages after each step, the home page still remained blank.


You can look in your publishing settings for local publishing to see where it’s set to publish.

One other thing. Is there anything in your .htaccess file?
Did you add any “code” on the page.

This is one of the strangest issues I’ve ever seen…

Trouble shooting.
The next step assuming it’s actually publishing to your server would be to start removing stacks and publishing. Duplicate the page first and set the duplicate to draft so you have a copy “as is”

Then on the real page, remove the bottom half and publish. If it works you know the issue in with the bottom half, if not, put that half back (from the copy) and remove the top half, publish.

once you determine which half is causing the issues, cut that half in half, finches and repeat until you narrow it down to the culprite.

Thanks for hanging there with me!

I can find the Publishing Settings for publishing on the web, but not for local publishing. Where would I be able to find that?

This is going to sound repetitive, but I cannot find a .htaccess file. So sorry. I looked in my c-panle file manager but do not see that. Is that where it should be?

No, there is not page specific code for this page.

I will start on the trouble shooting!

I’m no longer on my computer so can’t send you a screen shot. You could do a spotlight search for rw_common ( which would export to the root just like your index.php) that may reveal where you are exporting to.

No rw_common in SpotLight, other than the email I got with your message!