Publishing stops in same place and won't finish


(Emily Alexander) #1

I opened my rw6 project in rw7. When I try to publish the site it goes along smoothly until it comes to a certain page and then just stops. I deleted and rebuilt that page but the same thing happened. Then I just deleted the page and it simply went to the next page and stopped there.
I cannot export the site either. It does the same thing.
My server, username, password and path are all correct. I am using 1-slowest and Mode: extended passive.
I can still publish my project in rw6. I made changes in the rw7 project so would really like to get it to publish.
Any ideas? Thanks.


(Scott Steven) #2

Try the logs and what are the components on the page


(Patrick Mooney) #3

hi it’s an issue with rw7. The solution is to publish your site in parts. You can do this clicking on each page (or hold the shift key and select a few) and the press the ‘ctrl’ key and at the bottom of the menu you’ll see publish page. This way your uploading your site in sections and this avoids the problem. I have a large site and if I hit publish it stops (if it’s a multiply page change). If yours stops you’ll have to click ‘cancel’ and it’s best to quit Rapidweaver and reopen and sometimes you’ll get the message that it’s publishing, even though it is not if you don’t relaunch.

Hope that’s of help


(Emily Alexander) #4

Thanks so much Patrick. I finally got a chance to try your trick (busy day) and am not sure if it is working for me or not. I am fiddling with different possibilities. First off, I cannot find the ‘publish page’ choice in any menu. I have tried both the control key and the option key in both the RW publish button and the file menu in the menu bar. Where is the choice to publish just one (or a few) page?

I unmarked all my pages. Then I selected a few and marked them as changed. Then I simply clicked the publish button in RW7. It seems to be working for me that way. It said it published just those pages.

I have to leave soon and will not be able to get back to working on this until sometime tomorrow. I will definitely let you know how it goes and if it works for me. My fingers are crossed and it does seem to be publishing the pages. Have not checked it out in a browser yet tho. Let me know about that publish a single page choice.

THANKS!


(Brian LaPan) #5

Right (or ctrl) click the page you want to publish and the menu popup will give you the opportunity to Publish Page.


(Patrick Mooney) #6

Was just going to show you what LaPan has already shown. You first make sure you have selected a page in the left margin "Page’ which should turn ‘blue’ then use the hold the ‘clrl’ key and click on then the menu as shown above should appear, then go down to ‘Publish Page’ and that should do the trick. Then repeat on each page. You’ll then know if there is a issue with a page or not. If there is it you’ll get a warning message and most likely it’s a plug in being used on the page. The plug in ‘Header Pro’ can cause a few problem in case your using it.


(Rob Mallows) #7

I am getting exactly the same issue for the last week or so, running 7.0. I’m trying to upload a vanilla site to a hosting service I know is working fine, as it’s hosting an older version of my site.

Using Rapidweaver publish, it starts uploading about six files out of 126, then just stops, and each uploading line says “timeout” cannon upload to the server.

Below is a screen capture. Anyone anything they can offer. I’ve de-installed and re-installed Rapidweaver 7.0 but nothing’s working - what am I doing wrong, or is this a software issue. In which case, what’s the point of Rapidweaver if I can’t upload a website.


(Rob Mallows) #8

I’ve just tried uploading one page, with 116 files - same thing happening . Just stops trying to unload. Getting to tearing hear out stage.


(Gary) #9

Just an idea that Dan suggested to me, but you could try unchecking the “Preview Using:” in RW7 Prefs.


(Jason Bostick) #10

I’ve noticed this very infrequently (and a stab in the dark but maybe it will help) but I’ve gone into my cPanel, gone into the FTP session control, and cancelled active sessions, and then re-uploaded, and that has worked.

Again, though, not sure your issue is what I’ve had in the past.


(Rob Mallows) #11

Okay, I’ll see what that does.


(Rob Mallows) #12

Sorry, what do you mean by cPanel - control panel. On Rapidweaver? Where’s that?


(Rob Mallows) #13

It’s already unchecked.


(Jason Bostick) #14

Yeah, sorry. It is the control panel that I have access to with my host. (Not specific to rapidweaver).


(Rob Mallows) #15

ah, that makes more sense. I’ll see.


(Rob Mallows) #16

Couldn’t see anything in my hosting control panel equivalent to FTP session control.


(Rob Mallows) #17

The issue is that I’ve previously used Freeway, successfully, to upload my site to my server. Have not once been able to upload anything using Rapidweaver - not once. Wonder why I bought it now.


(Jason Bostick) #18

I’ve been lucky with publishing so I don’t know I can be of that much help. If the publishing is starting, I presume that all your ftp credentials and paths are correct?

There are a few other troubleshooting tips here http://kb.realmacsoftware.com/article/42-how-to-fix-ftp-publishing-issues but you may have been down that road already.

If you can export and use an ftp client like Transmit or Yummy, others use that as their preferred method.

Sorry I can’t be of much more help - ftp isn’t anywhere in my area of expertise


(Rob Mallows) #19

Thanks, I’ll look into those. Perhaps an ftp clients the way to go. But why would Rapidweaver - at least for me - have such a major flaw? Thanks.


(Emily Alexander) #20

Patrick
Was gone over the long weekend with no ‘working’ access to the internet. Back home now and have successfully uploaded all my pages. It took a while because I did it in rather small chunks and it froze twice. On the freezes I restarted RW as you suggested and all went well on my next attempt.

I didn’t realize you meant ‘right-click’ but I do know that on a one button mouse with a Mac that control-click is the same as right-click on a two button mouse…it just didn’t click with me - Ha Ha.

So I am all set and I thank you so very much. My site as many individual pages. I had to change each one of them when rebuilding them as responsive. Now that that is done, I will not be modifying any of those pages and so will not need to do a whole site upload again. I can easily simply upload the few pages that change periodically.

Thanks, again.
Emily