Publishing successfully but site unchanged


(mike) #1

Hey RW Crew,
As the title suggests I am editing, saving then publishing successfully, but the site remains unchanged.
I’ve tried a few fixes and the boys at HQ are helping but I was wondering if any of you have had a similar experience.
I have updated plugs, theme and add ons…
Cheers,
h


(Robert Ziebol 🖖🏼) #2

Sounds like you added something to your page that changed the filename from .html to .php, and if both exist on your server, it will show .html over .php. You need an FTP app to go onto your server and remove the .html file.

You can check this as well, change the file name of your URL from .html to .php, if you do not see that on your url, it means it is using index.html, so you will have to add index.php to the end of the URL to see if it works. If the page shows up, then we have the issue solved.

Make sense?


(mike) #3

Zeebe,
Thanks… I think so…
To check it do i change the URL in publishing setup?
h

Actually that’s really good information… I just wish I knew what it meant… : )
I reckon I will find out though… stay posted… thanks again…


#4

If you have tidy URLs turned on, you will not see the file extension in the address bar, but If zeebe is correct (my money is on him being right), you should see different content if you manually add .php or .html to the end of the URL.

If something in RW changed the page type to PHP, you will most likely want to stick with that and get rid of the earlier .html one. The problem is that browsers default to the .html extension when both file types are in the same place on your server, so you will need to use a FTP program like Transmit (paid) or Cyberduck (free) to browse your site’s server and do the cleanup. If you don’t plan to be a power user, you can also do this through your host’s control panel file browser, and avoid using any new software. The third party solution is usually better interface, but doing it in the control panel is functionally the same.