Uploading my website seems to work but

…when I visit my site, all I get is the hosting page.

The publishing settings seem to be correct as far as RW is concerned. Everything looks to be uploading properly and finishes as you’d expect.

But it just takes me to the hosting page when I enter my website address into the search bar.

I have contacted my hosting company who are helpful but they think the problem is with RW.

Any help would be very helpful thank you!

What is the URL of your site?

It could be something as simple as your home page now being index.php rather than index.html and the providers default index.html being displayed as that’s what browsers will default to if there are both html and php pages.

Or, you might be publishing to the wrong place on the server.

1 Like

Thank you for your response… is there any way to find out whether my homepage is php or html?

My website URL is www.supermarkmusic.com

I suspect that you have uploaded your site to the wrong place on the server.

An easy way to check if the page is php - either look in the RW page inspector, or just use it as the URL like this:

http://www.supermarkmusic.com/index.php

However, that comes up as not found, as does:

http://www.supermarkmusic.com/index.html

I’m assuming here your homepage is index.html or index.php?

The host guide doesn’t help much, as it doesn’t say where on the server you should upload to. Often you need to upload to the /public_html directory. When you go to the RW publishing window and click on the ‘Browse’ button, what do you see? A screenshot of that might help us to help you.

1 Like

This is what I see when I use the RW publishing ‘Browse’ button. See how my website is published to /public_html and you can see the index.php in there which is my home page.

1 Like

Thank you so much!

I will investigate and get back here with any news

Hi Gary,

This is what I see when I click “browse” on the upload options. I did click on the index.html option and it started looking like it was publishing but it didn’t make any difference. It was maybe a rookie move on my part…

It would also be interesting to see the publishing settings that are hidden behind the browser window - the publishing path for instance.

I don’t think you should be publishing to the path /www.supermarkmusic.com maybe to the root directory/

Where did you get the server address upload.lcn.com, the default page suggests ftp.supermarkmusic.com

Is this what you mean?

See the Path you have set to /www.supermarkmusic.com/

I think that is wrong. I think you should leave that empty or just have / so the files load to the root on your server.

This tells you to upload files to the folder you see and warns you not to load any files outside this folder. You are effectively uploading your RW files to a folder called /www.supermarkmusic.com/ which is incorrect. So your web files on the live site would be in https://www.supermarkmusic.com/www.supermarkmusic.com/ if you get my drift?

I don’t know how up to date the lcn support page is, but the instructions on the page suggest that the correct path is in fact /www.supermarkmusic.com/web/

1 Like

Thank you so much for all your help, Gary.

I have followed all your suggestions but with no luck. I think by the looks of it the problem is with my hosting company so I will contact them…

I think that’s the best option. Get them to look at your hosting space and see if they can see your uploaded files and if they are in the right place. It’s easy for them to just say it’s RW - and it still might be if you are uploading the the wrong directory - but get them to look.

I’d always advise using an FTP app to look at the hosting space too. You don’t need to use it to upload, but you can see much more of how the directory structure on the server is configured.

Let us know how you get on.

I finally managed to get everything up and running!

The “server” and “path” fields were incorrect.

I really appreciate your help, Gary, thank you.

My pleasure, glad you got it sorted :+1: