Rapid cart Pro and paypal


(E) #1

I am testing a shop made with Rapidcart pro

I have added a test item for $1

So far it works with stripe. But paypal … I select paypal method then hit next and a pink sign comes up saying select method of payment

Any idea where Ive gone wrong?

Here


(David) #2

@Figory
It might be the setting for “skip first image” is ticked in RCP. This is at customization > settings > product > gallery
Try unticking that box and see if that helps.


(David) #3

@Figory
Upon a closer look it appears that you have named the missing images with an apostrophe in “Farmer’s”. Removing the apostrophe should fix things. Apostrophes in file names can bugger things up, so best to avoid them in file names or links.


(Matt Wilson) #4

Lovely site! Hope you get this worked out. Can you share if the apostrophe removal fixed the issue?


(E) #5

Thank you Thang!

YES … I added images in a rush. As a result have to redo

I had made errors in that I had spaces in the image names and even in the resource folder names.

Somehow it worked for a while, but then images vanished randomly.


(David) #6

glad it helped fix the problem.


(E) #7

I know I’m pushing my luck asking if you know about this error !


(David) #8

The pink warning thing happened to me a few days ago. RCP was getting an error message when trying to connect with PayPal. It seemed to be a problem PayPal was having in their developer “sandbox” accounts, which then resolved itself later that day. Not sure if that’s what’s going on in your case though.


(E) #9

YES!
Thats it!

THANK YOU!


(David) #10

Did that resolve itself spontaneously or did you have to change some settings?

Paypal’s been driving me nuts since last week as the notifications for test orders i’ve made have not been showing up in the developer’s page. I can see that the transactions are completing successfully, and i get notifications on the individual sandbox account pages, but not on the developer dashboard. So while i think it’s all really working OK, i’d like see the notifications working on the developer’s page before proceeding and going live with RCP. I put in a support ticket with PayPal, and got a reply, but they haven’t replied as to what or where the problem is and when they will resolve it. Quite frustrating when everything else is ready to go.


(E) #11

I re entered the live key from paypal
Then I also created a new secret code in paypal
its all working well for me now

I followed these steps in RCP manual:
For enhanced security, in App feature option section (for both Sandbox and Live) enable only Accept Payments, then click Save.
Now copy and paste access credentials (API Client ID and Secret).

If you checked Use Sandbox (for testing purposes), use Sandbox credentials. Use Live credentials otherwise.


(David) #12

Thanks for the report. I asked PayPal if using a new key might help fix the problem i am having, and have so far not heard back from them, but i think i will go ahead and make a new key. Haven’t even tried the live key yet, glad to hear you didn’t have any surprises with that.


(Figgy the Firefly) #13

I am getting the same error. Select a payment method when setting up paypal

everything seems to be in place…


(Figgy the Firefly) #14

I solved my issued. When I double clicked to copy the Client ID and the Secret from Paypal and pasted into Rapidcart Settings in RW7.

It added an extra space that I had to delete. So when I pasted into either the api client ID or the secret i used the down arrow and it showed a whole new line. I had to backspace once to clear it out.

I published and voila! works

Whew – happy to clarify more if the above doesnt make sense.


(Jason Bostick) #15

That’s a good little tip. I spent what seemed like hours trying to get a Stripe checkout on my site working (with a Yuzool stack, not RCP) and it turned out that double clicking/copying the Stripe keys added a single space to the end. Hard to notice when the keys are often longer than the text input area in the settings


(James from HK) #16

I just installed RW7 and Rapidcart pro 4.8.7. I added Paypal to my site.
Then try the Paypal payment.
A banner comes down on my browser “Select a payment method” when I clicked next.
I have unchecked the “skip first image”.
I have also set the customization/settings/stack store URL to http://colours.hk/gardens/mshop/index.php
I have marked the web address in “general” of RW7 as http://colours.hk/gardens
But, when I clicked “Check the deployed page”, the paypal displays “the requested URL returned error 401”.
I asked paypal to check, but they reported “no data is ever recived on their server”.
Any suggestion is welcomed?


(jol yates) #17

The little pink box

I think some people are not seeing the toggle switch in Paypal’s Dev tools.

For live settings, you need to flick this switch to ‘live’ and copy the settings there (as opposed to ‘Sandbox’)

Remember also - in App feature option section (for both Sandbox and Live) enable only Accept Payments, then click Save (for better security)

Hope that helps those fighting the little pink box : )


(Ruaridh Litster-Campbell) #18

I’m having trouble with the little pink box saying "please select a payment method when PayPal is the only payment option. I have re entered the client ID and the secret a couple of times, didn’t see any spaces that had been added when I copied them. Also made sure it is on the live version. I’ve also clicked only Accept Payments and saved it. Hopefully someone might have an idea what I’m doing wrong as it’s pretty frustrating when everything’s all ready to go
Cheers!


(Andrea) #19

Guys you made my day.

I checked all your tips and it now works (I made a trivial mistake in the API copy & paste)

Let’s start selling