Rapid Weaver 8 (403 Error)

I am currently using Rapid Weaver 8 and have been for a long time.

I am getting an error message and nothing I do seems to help. The error message is 403 Forbidden.
My computer is running Sonoma 14.2.1.

Could anyone help with this?

Hi @vmgsds,

Can you post some screenshots of where you are seeing that 403 error exactly in RapidWeaver? Usually you’d see that kind of error on a published website.

I see the 403 error after publishing in the browser. My website hosting company says it’s a problem with Rapid Weaver. When I check the connection to the host it says its was successful. As I get to the end of the upload I see several messages of “Idle” I don’t ever remember seeing that before.

Could be a few things:

  1. You might be publishing to the wrong folder/directory at your web host.
  2. The folder/file permissions might be set incorrectly.
  3. Some other server side issue.

Sort of feel like your web host is redirecting the problem back to RapidWeaver without investigating. Unfortunately it’s hard for us to troubleshoot these types of issues because we don’t have access to your hosting account or server logs.

Can you tell us your website address and who your web hosting provider is?

My website. www.mathausen.com

Webhost provider www.bluehost.com

Thank you. I feel like the web host just doesn’t want to help.

No problem.

Can you confirm your page filenames are either index.html or index.php? They should look like this:

If the filenames look good, can you check your publishing settings and confirm the path is set correctly? It needs to be set to upload to your website’s web directory/folder at your web host (Bluehost). If it’s not set to upload to the correct folder, that could be why you are seeing a 403 forbidden error.

You can confirm the correct folder to upload to in your Bluehost cPanel. If mathausen.com is the primary domain on your account, you would upload it to the public_html directory. If mathausen.com is an addon domain on your account, there’s an article here that shows how you can find the correct directory to upload to.

If you click the “Browse” button next to the path field in that above screenshot, it makes selecting the correct directory to upload to easier. You can just click on the folder to upload to and it will automatically get set in that path field for you.

Let us know how it goes.

I have checked all of my settings. Everything looks correct.

The version of Rapid Weaver 8 that I am running is 8.9.4. Would that have anything to do with it?

No that wouldn’t have anything to do with it.

If you are open to a live session we could schedule one so that you could screen share so we can check your RapidWeaver settings.

We can also check your Bluehost settings to make sure everything is set correctly and the website is getting uploaded to the correct spot. This is something Bluehost should be helping with, but if they are not able to we can pick up the slack and work through it with you.

If you’d like to schedule a live session let me know and I can get an invite link sent out to you.

Hi Dan,

Sorry about the slow reply. Things got very busy for me last week. What evening would work for you? I am available after 4:30 pm most evenings. I am on eastern daylight savings time.

Best Regards,

Hi @vmgsds,

No worries. I will send you a DM to get something scheduled.

Ok sounds good. Thanks.

1 Like

Happy to report we got this resolved. :slightly_smiling_face:

Long story short, it was an issue with the publishing path. We got that corrected and got the website files uploaded to the correct spot, then cleaned up the hosting account a little as there were files/folders in places they shouldn’t be.

All looking good now and publishing via RapidWeaver is working great.

Thanks @vmgsds for taking the time out of your Friday afternoon to join the live session. Happy we were able to get this sorted for you. Let us know if we can help with anything else.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.