Unable to publish website from RapidWeaver 6.3.7


(Anne Jordan) #1

Had a website ages ago on an older version of RW, and just upgraded straight to 6.3.7. I can’t seem to publish a 2 page site (as a test) - I get the error message “Couldn’t sign in to your FTP account. Couldn’t connect to server.” I checked with my hosting company and it looks like I have the correct server/password details.

I am really a beginner with all this, so any help (in words of one syllable!) would be very much appreciated!


(Brad Halstead) #2

There is a specific process to upgrade to RW6, I hope you followed the directions here

The main things to check are that you have (in site setting) the proper domain name that you are to publish to (using the proper case of the letters… i.e. http://mysite.com/ (Wrench Icon, General)

Next, in your publish settings (bookmark) make sure to have the proper root folder for the uploads to go to (Path specifically… depending on your host it could be /, /public_html, /public or anything else the host sets up).

Other than that, what is the name of your hosting company? Maybe someone else here with that specific host can help you more OR you can contact support@realmacsoftware.com and give them details of your server to see if there are any known issues with that host.

HTH
Brad


(Anne Jordan) #3

Thanks, Turtle. I’m pretty sure I followed the upgrade directions but I’ll double check. My hosting company is Omnis - had no problems with earlier versions of RW but I really didn’t use it very much. Thanks for the info. I’ll check it out tomorrow - my brain’s been trying to figure this out for days, so it needs a new day to try again!


(Anne Jordan) #4

Just out of interest, I tried uploading from RapidWeaver 5 (5.3.1) and get the same problem. Is something on my computer or internet connection stopping the upload? Some kind of permissions missing? I have no idea what I’m talking about, but it just seems that the problem isn’t with RapidWeaver or Omnis.


(Brad Halstead) #5

@AnnieJ

When was the last time you Restarted you Mac? Try that and check again for publishing.

Do you have any anti-virus that does internet snooping protection installed or Little Snitch or clean my mac or anything like that installed on your system that may be intercepting/blocking your publishing?

Brad


(Anne Jordan) #6

I restarted my Mac, plus checked my Norton firewall software, and all the permissions for Rapidweaver 5 & 6 are good. There’s obviously something else going on with my computer. If I type in my URL into the web browser I get “Forbidden 403 - you don’t have permission to access on this server” so I’m trying to work on the internet and computer side of things.
Thanks.


(Brad Halstead) #7

@AnnieJ

Oh my… if you like, you can PM me your url and I can have a look to see if I get the same issue and we can go from there…

Basically though, it sounds like 1 of 3 things

  1. There is a .htaccess file that is preventing your connection on your server in your login folder

  2. You are trying to publish to the wrong server folder

Either or both could be happening, or even something else…

Brad


(Anne Jordan) #8

It’s not looking good!! I’m just going to check what’s happening with my laptop and see if anything is different “behind the scenes” on my MacBook as opposed to the desktop. I think I’m okay with the server details as I’ve confirmed them with the hosting company but I still get the same Forbidden 403 code when I type in my URL on my phone.

Thanks for your help so far - it’s good to know help is out there. I"ll see what happens next with the laptop.


(Brad Halstead) #9

@AnnieJ

I’d be placing another call to the hosting company to see what’s going on, perhaps they are having server issues at present. Tell them your error message and your URL and they should be able to fix you up ASAP

Brad


(Anne Jordan) #10

Brad
Thought you might like to know what happened with my publishing problem. After days on various forums - RapidWeaver / Apple / Omnis / Comcast - it turns out that the was a problem was with my internet connection. It works fine, nothing obvious wrong with it, if a little slow, but the end result is that Comcast came today and dug a trench in my front garden to re-lay a new cable for me. I only figured this out when I ended up having to take my laptop to someone else’s house and my website uploaded in seconds!
Thanks for your help.
Anne


(Brad Halstead) #11

@AnnieJ

Thank you so much for updating the forum on the issue you were experiencing. I am very happy to hear it wasn’t a computer or RapidWeaver issue but rather a connectivity issue caused by old cable underground.

:slight_smile:

Brad