Still in trouble with Rapidcart Pro, I would pay for help!

After a couple of years of not updating I finally decided to partially rebuild my website: I used RapidCart in the past, I was not 100% satisfied with but I always put the blame on me and on my lack of competence, I am an illustrator and I I have less knowledge on site building that I should have. But the online store worked.

Now, after updating to the latest version of RCP and reuploading the whole site from scratch the store page is just… empty! as nothing is in it.

I also just realized that there is no longer direct support for the product, and that upsets me a bit, because there was support once and I suppose the company is still running since they sold me the latest versione of RCP.

NOW: I would be glad to pay someone with more knowledge in the topic than me to teach me how to set up the store correctly and make it run!

Am I spending my efforts in a dead end? any hint would help!

I’ve just implemented my first website with RapidCart, so not an expert, but I got great support from the developers. If you post a link to your site people here people can better advise you.

Did you do a clean (erase all the files first) update?
Maybe your new design has folder names that were different from your last upload?


Thanks Yon!
yes, I uploaded the new site on a clear slate
I am using RW8 with Aspen theme from Nick Cates Design
you can view the published pages here:

the store is on a unlisted page here:

The source code on the RCP test page has classes related to Cartloom in it. Is Cartloom installed in the page too?

During the build I accidentally put the cartloom stack in another page and then removed it, but was not placed in the page I provided the link to

this is how that page looks like in RW

Try doing a complete republish.

When I had issues with the store loading, it was because I had folders that were there from the first version of my test upload. I had to use Fetch, to look at what was actually stored on the site, and delete it. RapidWeaver’s ‘Republish all Folders’ didn’t clean out all the files.

Maybe you have this part already, but the Store stack can’t be seen in RapidWeaver (or previewed locally on a browser), it has to be viewed online, as in live from your site. Otherwise you get the image below.

I think that is a RapidCart grid stack we are seeing, not the ‘Store.’ The ‘Store’ you show above is the page populated by the catalog section of RapidCart, that was put in your project with the ‘RapidCart Pro’ page you added, which I think of as the interface. It’s the place you built your catalog, and set your server setting. From that page you should be able to test if your site is ready by clicking this button.

That will show you if all the parts are there, and where the store is housed on your site. If it’s all good there, more trouble shooting.

The other ‘store’ is the store stack. The ‘Store’ stack has to be added on a separate page. This one should really be called ‘Facade,’ as Rapid cart stocks that page with what you put in the RapidCart Pro Page (interface) and uses your formatting of that page to house the ‘Cart’ and ‘Catalog.’ That is what the picture above is from.


First of all, thanks for your detailed reply! Now, answering to your points in order:

  • yes, I cleared anything from previous website manually using an ftp program;

  • yes you are right, what you are seeing in my last pic is a view of the RC interface seen from inside RW: the odd thing is that my previous site was published that way… and just worked! Transaction reports had some little problem but the sales just went on and the page looked as in RW but…

  • …This time I also used the Store stack and a Product stack too, creating two other unlisted test pages: strangely these appear completely black… I mean completely! below I’ll paste the links so you can see for yourself , never seen something like this, I’m stuck :-/

That page is full of errors, some of which seem to relate to the page you have the RCP stack on?

Assuming you’ve read the manual and are adding RCP to the site in 100% the correct way, I’d start over with a new theme and see if that fixes things. It might well be the theme is somehow breaking things.

My instinct though is that you’ve not setup RCP correctly within the site.

Thanks Repo, due to the image you posted I just checked the RW publishing folders… and they are basically empty! the files are just not there! it’s RW not publishing the site, now I just have to figure out why :-/

Doing a complete republish :slight_smile:

It really isn’t, at least, it’s highly unlikely it isn’t. Without sounding harsh, it’s almost always (like 99.99999% of the time) a user error.

Check that you’ve changed all the pages with RCP elements on them to PHP, not HTML. Also, check you’ve added the correct URL’s for the store to the RCP settings.

I’d offer to look at the project for you, but I don’t have the Aspen theme. And bear in mind that since Nick Cates departed the RW world, that theme is no longer supported, so if you get an issue with it, you’re stuck.

As you are rebuilding it, it might be an idea to also change theme.

1 Like

yep! when I wrote “rw not publishing the site” I meant “me not using RW correctly to publish the site”: now I am uploading all the files, let’s see… all the things you suggest are in check, if that does not work out I’ll have probably to change theme and maybe start from scratch

Now everything works fine! in the end it was the dumbest of al issues, so dumb that I did not even bother to check: files just not being there! lesson learned, thanks to all for your support !

You are using an unsupported theme, and from what I understand NC’s themes although brilliant (I’m told) are complex, so sooner or later you are goingto have to rebuild with a different theme. It’s just a case of doing that in your own time, or when Aspen falls over.

yes there is that risk. It is also true that Nick Cates themes are really well done, used some of them for years and never had a problem. one day I might have to rebuild it all again. ONE DAY. today it works =)))

BTW: you say it is an unsupported theme, so there is a list of themes that are supposed to integrate with RCP in a better way?

What I mean by unsupported is that the developer is no longer active, no longer supporting his products. So, if there is an issue with the theme, perhaps as browsers change the way they do things, the theme may no longer work with no one to fix it. Of course, you will get no warning of this. One day it’ll work, the next it won’t. then you’ll be forced to rebuild immedaitely.

You can of course continue to use it and hope. It’s not perhaps the best way to do things, but it is a way.

Glad to hear you got it all sorted in the end but not sure why you say RCP is not supported by the developer. RCP has an active support site and do answer my emails, the latest being last week.

Can you please point me out the actual page to get in touch with them? all I can see on their page now is the troubleshooting page and manual page