🌊 RapidWeaver 7.1 Beta Now Available


(Dan) #1

Hey Weavers,

If you’re on the beta track for RapidWeaver 7, there’s now a 7.1 (18224b) update available.
If you find any bugs please report them here and we’ll get them fixed up.

You should take all the usual precautions before using beta software:

  • Backup your existing projects before working on them in 7,1
  • Projects saved in 7.1 are NOT backwards compatible with 7.0.x builds of RapidWeaver.

UPDATE: 31st August
If you get the following error when launching RapidWeaver 7.1:
"Couldn’t obtain plugin principal class Would you like to check for updates?“
We think this is caused by the “CodeComplete” plugin, you should remove the plugin to fix this error.

Happy Weaving!

Cheers,
Dan


When will RW 7.1 be released?
(Dan) #2

(Fred Dalzell) #3

To make sure we get the latest, what is the build number for this?

TIA


(Dan) #4

Sorry about that, it’s Version 7.1.0 (18224b) - Have updated the post above too :slight_smile:


(Jean-Paul FLIES) #5

Hi Dan,

RW crashes when trying to relaunch after automatic install of RW 7.1 beta. Is there an alternative way to download this beta version?

Thank for your feedback.

Jean-Paul


(Bruce Kieffer) #6

Seems that with every RW update projects upload all files after any minor change. Once the first entire site upload is complete, then it works as expected with only uploading changed pages. Is this normal?


(Doug) #7

Removing “CodeComplete” plugin resolved this issue for me; however, I wasn’t even aware I had this plugin installed as it did not appear in the Add-on window in Rapidweaver.

It should be stated that you need to look in the Rapidweaver add-on folder buried deep in the Library folder:
User/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application Support/Rapidweaver/

The fastest way to get there is right click a control click any plugin (ie. stacks) to “Reveal Add-on in Finder”.


(Linda Lang Pierce) #8

I have updated to the 7.1 beta and cannot export or publish a site. Crashes every time.


(Simon Maddox) #9

Does it crash when exporting a particular page/plugin? Have you sent the crash report using the reporter that appears after the crash? Can you share your project, plugins and theme with support?

Thanks!


(Linda Lang Pierce) #10

It crashes or fails on single page or all. It crashes on export. The crash reported crashes.
Theme is theme flood media 6.1, stacks (latest), waterfall, offsite, pluskit, sitemap, contact, faqmaker, infinity box, fx slider, clean gallery stack,


(Linda Lang Pierce) #11

I have taken all of the .pdf resources out of the site and moved them to the server. I am not able to publish chunks at a time so perhaps it’s a memory thing. :slight_smile:


(Bruce Kieffer) #12

No CodeComplete on my drive anywhere.


(Dan) #13

(Gary Wann) #14

Version 7.1.0 (18224b) installed and running OK. No issues so far, v7 project loaded without any problems and publishing is OK. It’s nice to be able to preview my Sitelok pages again.


(Konstantijn Van Calster) #15

Me too, I have delated all my site files/folders on the site manager at my hosting and republish all my site from 0. You can do it also on your computer if you have a FTP client nevertheless easier to do it from your hosting. First of all make sure to get a proper backup of your DNS. Now it’s working fine, no problems anymore to publish with RW.


(Ronny Roeske) #16

Hi
Great update! Now everything from YourHead is not there!
Nothing works now !!!


(Dan) #17

Hi @Gelbseidenraupe could you be a little more specific? We’ve had no other reports of this…

  • What plugins are you missing?
  • Did you move form RW 7.0.4 to 7.1?
  • Have you tried restarting RapidWeaver/Your Mac?

Thanks,
Dan


(Justin) #18

We do we go to see whats new in RW7.1??


(Dan) #19

@j303 there’s a list of what’s new along with a download link here: 👍🏻 RapidWeaver 7.1 Release Candidate 1 is go!


(Doug Stansfield) #20

I upgraded to 7.1.0 (18224b) and am confused. See below:

I am uncertain why I now have two versions, and also why are they in Downloads and not in Applications.

How do I correct?

Thx!