👍🏻 RapidWeaver 7.1 Release Candidate 1 is go!


(Dan) #1

Hey Guys,

After much testing we think RapidWeaver 7.1 is ready to ship, here’s a link to the current build that will go live later this week: https://dl.devmate.com/com.realmacsoftware.rapidweaver/18228b/1473069778/RapidWeaver-18228b.zip

IMPORTANT

Projects saved in 7.1 are NOT backwards compatible with 7.0.x builds of RapidWeaver. Please back them up before Installing this update.

** What’s New in 7.1**

  • Opening large projects is now much quicker (after initial migration)
  • All exports are now faster due to concurrency (although Stacks does not yet take advantage of these new changes)
  • Exporting projects with plugins that generate multiples pages is now much faster
  • Added a sheet to show what RapidWeaver is doing during export
  • Added back in support for re-publishing all files for a single page
  • SiteLok plugin no longers breaks Preview mode
  • Colour arithmetic in themes now works again
  • Fixed an issue where the Filename extension was ignored when exporting (again)
  • Fixed an issue where an updated resource would not get re-published
  • Resizing Gifs now works (animation is not supported in resized gifs, yet)
  • Cleaned up plugin loading code, it’s good to be clean!
  • Fixed an issue under Sierra when using the Web Inspector
  • Updated Voyager theme (Thanks Adam!)
  • FTP setting name changed from “Fast as Hell” to “Fast as Lightning”
  • We’ve fixed up a bunch of issues and crashers with export introduced in the previous beta (sorry!)
  • Fixed an issue where Photo Album pages would not be generated correctly
  • Migration to global data storage now only happens once per page
  • Media queries that span multiple lines will now be minified correctly
  • Fixed an issue where RapidWeaver would crash when you removed a global meta tags
  • Cache busting links option is now saved between launches
  • Fixed an issue where plugins would sometimes fail to load
  • Export should no longer sometimes hang (Refactored manifest generation to prevent conflicts)
  • Minify can now handle non-ascii characters correctly
  • Thai characters no longer crash RapidWeaver’s code view
  • Added a “cancel” button on “change Theme and Apply?” dialog
  • Fixed an issue where Site Notes would sometimes not save
  • Tooltips in page list now look much nice
  • Project window now shows when RapidWeaver is unregistered
  • Preview now works with the Sitemap plugin
  • Fixed an issue with the contact form not saving correctly
  • Many other minor fixes, and under the hood enhancements.

If you find any show stopping bugs please let us know ASAP - support@realmacsoftware.com

Happy Weaving,
Dan (& Team Relamac)


🌊 RapidWeaver 7.1 Beta Now Available
(Gary) #2

Export problem emailed in to Support.


(Dan) #3

@webdeer I don’t see it (we get a lot of email), some information or email address to search would be useful.


(Gary) #4

I will send directly to you Dan. Although this is the same problem I have had several email conversations with RM support about since v7 was initially released.


(...) #5

It is a holiday week in the US and Canada. Your response rate may be limited. Might want to consider next week for release after everyone gets back and can help test. Just my 2¢


(Bruce Kieffer) #6

This version looks good, but once again RW needs to reupload all of my resource files even though nothing has changed.


(Gary) #7

After a short flurry of emails Dan has only gone and fixed it. Unchecking the “Preview Using:” setting in RW7 prefs fixed my ongoing Export problems when Exporting to a local folder. Many thanks. RW7.1 is all go.


Mac OS Sierra - Is RW ready?
(Dan) #8

@bruce did you re-convert your project from 6 to 7 ? or is this from an older 7.1 beta to the latest one? Some more details would be appreciated as this is not normal behaviour.


(Bruce Kieffer) #9

@dan, All of my sites were made with RW6 and then converted to RW7, and I was running the 7.1 beta before the one released today. I see this behavior wth all of my sites, and it seems to occur every time there’s any RW update. I open the project, make a minor change, and sometimes all my pages want to reupload, and today it was just all project resources.


(Jan Fuellemann) #10

BUG: If you change the name of a site from index.html to index.php you can not select any option in the upcoming “Change Homepage Filename” window. It just opens and opens and opens again and again and again:

Please fix before the release :slight_smile:


(Dan) #11

@Fuellemann thanks for the report, we’re fixing this up now!


(Dan) #12

@bruce you say you make a minor change, but it really depends on the change you make. Sometimes what seems like a small change can actually effect all pages.

  • Can you give us reproducible steps, or let us know what triggered these changes?
  • Does it happen every time you make a change or just sometimes?

Some steps to re-create the issue would be good :slight_smile:

Cheers,
Dan


(Matthias Ficht) #13

@Fuellemann @dan Yes, the same for me here. Just mailed a movie showing this issue to Aaron, since he could not reproduce it. http://d.pr/v/13Ryd


(Bruce Kieffer) #14

All I do is click into an area to make RW think a change has occurred. Then I save and publish, and RW reuploads all of my resources. This happens every first time there’s a RW update, then it clams down to normal. I’m not having trouble with my sites that have no resources. I can send you my project if that helps?


(Mark Medford) #15

One huge problem that I’ve been having is periodic freezing up in switching to Preview mode or changing from full to mobile when in Preview. Theme is Rustic by Elixir (have not tested others). I have to save constantly. In the midst of a huge project that must go live by Friday so am wondering how stable 7.1 will be and if it addresses the Preview freezing issue. Thank you!


(Doobox Software) #16

I was seeing that same hanging behaviour in 7 also. Since installing 7.1 I have not seen it again (fingers crossed), that’s all I can say.


(Mark Medford) #17

That’s encouraging, thanks!!


(Linda Lang Pierce) #18

I am also having all sorts of problems with this round. Can’t do anything without it crashing.
I have replace host file and that did not fix the problem. I dragged all the files to a fresh theme thinking maybe that was the problem. Still can’t view the settings to update. Each time it starts exporting it crashes.


(Linda Lang Pierce) #19

I tried this and it did not work for me.


(Linda Lang Pierce) #20

I just removed Pluskit (latest) version and now I can preview and everything is behaving as it should. Bad think is I have used pluskit throughout and will have to do something different.