Unable to Publish After Upgrading to 7.4


(Bill Hall) #1

Hello- Just updated to 7.4 and am now unable to publish.

Symptom: It starts to publish, but then suddenly ends with messages saying, “Operation Was Aborted By Application Callback”. I’m enclosing a picture for reference.

Nothing was changed except a very very small modification to a Yabdab Form page.

Setup: RW Version 7.4 (18678) - Macbook Pro 2015 8/512, 10.11.6

I’ve Tried: Restarts, slowing publishing down (from 7 to 1). Still no luck.

Any thoughts? Thanks!


Are we considering RW 7.5.5 "it"?
(Chris Loneragan) #3

I’ve got the same issue. No reply from Rapidweaver @dan @simon etc to my comments on the release thread or my email. Reboot doesn’t fix it. I have now been able to publish some pages one by one, but the blog page won’t publish. Need help please.


(Chris Loneragan) #5

@SteveB thanks for the tip. Downloaded and installed 7.3.3 and same problem. It used to work but since installing 7.4 I’m unable to publish.


(hardy) #6

The same for me after upgrading.


(Bill Hall) #7

Went back to 7.3.3. and I was able to publish.


(Hiroshi Ishibashi) #8

Same here. Without any error message or warning. It quit in the middle of publishing a site with many pages. Reverting to 5.3.3 resolved the issue. I have encountered a similar problem in an earlier version also and the bug has crept back in again.


(David Walsh) #9

I wish I’d looked here before accepting the download invitation. Can’t publish either. :frowning:


(Jason Bostick) #10

@Davy, you can just go here and download the previous working version then you’ll be back to normal:
https://kb.realmacsoftware.com/section/4-release-notes


(David Walsh) #11

Thanks but ‘normal’ has disappeared over the horizon it seems. I’ve reverted to 7.3.3 and also rebooted my mac. Now I can’t event get a test connection to my server to work. I wonder if it’s worth going back to an even earlier version or just manually publish pending some sort of help from the RW people… Or maybe I’ll just forget the whole thing and enjoy the sunshine.


(Bill Hall) #12

Try this: If you have a blog, right click on the blog page and select ‘Mark as Unchanged’ and then try publishing (assuming you’re back to 7.3.3).

Does this help?

Probably a better idea to push the update on a Monday instead of a Friday (that’s when I got the notice). This way, they are around for the bumps.


(David Walsh) #13

Thanks. I have tried republishing a slightly modded page in 7.3.3 with no success. Is there any significant reason for using the blog - will this behave differently? Agree on the timings but also think it’s obviously a flaky update; not good at all.


(Steve Jenkins) #14

I have not had any publishing issues until this release, now I am getting the same as the original post. I must force quit RW in order to get out of it.


(David Walsh) #15

Ditto.
In case it’s of any help to anyone afflicted by this fiasco: I have found that by deleting my installation of 7.4, emptying the trash and rebooting. Then reinstalling 7.3.3 there has been a partial return of publishing ability.


(Richard Wood) #16

I had the same issue after updating to v7.4 yesterday. RW kept crashing when I tried to publish my site. I rolled back to v7.3.3. and everything is back to normal.


(Simon Maddox) #17

For those with publishing problems, we need the following things:

  1. A screenshot of the error shown when you press “i” in the publishing window
  2. A screenshot of your publishing settings

I’m fairly certain we’ve asked for these in another thread, and only had a couple of responses so far.

If you find that you can’t publish in an older version of RapidWeaver then I’d suspect that your issue is either with the settings you’ve entered or with your host. In this case, if you contact support@realmacsoftware.com they’ll be happy to help, and will forward more complicated issues onto us.


(Martin Waring) #18

I’ve had some publishing issues lately with both 7.4 and before that with 7.3.3. In 7.3.3 my uploads were getting ‘stuck’ on certain files (not even very big ones) and I’d have to Force Quit RW to get out of it.

Having sent Realmac several error logs they suggested I change the mode.

Before now I have been using Extended Passive for years without issues. With my 7.3.3 problems I changed to Passive and that seemed to work until I upgraded to RW 7.4. Now what it seems to require, for me at least is Active mode which is currently working OK. I have no idea why or what the differences are between the various modes - but worth a try before jumping back a version.


(Bill Hall) #19

Hey @simon - Is this what you’re looking for (I removed the info from the publishing settings and I’m using Chilidog for hosting)

Thx.


(Mathew Mitchell) #20

Have you tried Extended Passive. Works great for me with Chilldog. I have connections speed set to 6. The key is the extended passive.

In addition I don’t believe you need that forward slash before public-html in the path box.


(Pam Vigil) #21

@Mathew Thank you for suggesting that, changing it to Extended Passive fixed it for me as well - I use GoDaddy.


(Bill Hall) #22

want to double check what @Mathew and @PVigil are suggesting:

  • You were not able to publish with 7.4 until you changed the publishing settings to extended.
    OR
  • You find it better to publish extended
    OR
  • You were not able to publish on 7.3.3 and 7.4 until you changed to extended

Please clarify this so it helps the others who may not be able to publish with one or the other versions.

Thanks!!!