Rapidweaver 8.1.4

Nothing but trouble with RW 8.1.3 and 8.1.4.

Do NOT use.

I am running 20+ sites with RW 8.1.4 and have no problems whatsoever. So such a general warning is a little out of place here.


Want the truth? That has been my experience, and I have a clue.

But, you are not explaining what your problems are. I use 8.1.4 and am having no issues at all


Well, how about these problems.

For some reason, a change was made to the way RW 8 handles code in the prefix area. This causes an Incompatibility with SiteLok. (Adrian and I have spent a great deal of time on this one.) Next, changes to the destination directory in publising parameters and site url do not take and get reflected in published site within RW. Same issues are in export site to local directory. We are having significant problems with published sites not containing our JPGs. Links to pages within site have crashed. Published pages do not consistently contain dimensions and layout of theme and stacks. Incredible amount of time wasted on all of this. Unsat.

We would like to roll back to what everyone considers the most recent stable version, particularly before the change was made to how RW handles prefix code.

That said, it is possible that the version of RW we have installed has been corrupted. If so, it is not clear how to reinstall the app.

BTW. We had none of these issues prior to upgrading to 8.1.4. Everything was stable.

We have tried a great many things, including changing themes, etc. No joy.

From reading all the related posts on this forum, I would agree with notimeflat…updating to 8.1.4 is just not worth the risk.

Way too many issues still floating around with all versions of 8.1…from publishing issues to resource links…just not worth the risk and extra work necessary if you end up being one of the people that experiences the various problems.

In my humble opinion 8.1 should still be in beta.

I am also having issues with 8.1.4. I’ve not published my site recently, but don’t feel confident that I can. Billboard text is no longer working, video plus is no longer working. Footer now appears as header. I have no idea how to fix it and am not happy about it. Can I roll back from 8.1.4?

I also use Sitelok by Vibralogix and love it, I was waiting years for Adrians solution!! Love it!

For all those having issues with 8.1 and beyond, what OS X are you using?

I am running OS X 10.13.6.

How do I get back to RW 8.0?

I have done a pretty extensive Google search, and I can find no way to do this. No 8.0 app out there?

Do you have any ideas?

Just search this forum :slight_smile:
Download here:

8.1 projects can not be opened with 8.0 afaik.

1 Like

Uh huh.

That means all of our project files that have been converted to 8.1 and above, and to which we have added a huge amount of work are marooned with a version of RW that simply does not work.


I have read the release notes for 8.1 and higher. Nowhere do these notes meniton a change that we have picked up. That is the way RW 8.1.4 handles code in the prefix of a page. Does not mention any problems associated with publication, this area also has obviously been changed.

Next. None of the notes cover file compatibility between 8.0 and 8.1 and higher. When project files are converted from 8.0, RW simply overwites the older verion making it impossible to go back. There is no conversion utility to reverse the change. In additoin installatoin of RW 8.1 overwrites 8.0.

Again, this is outrageous. Not to mention amateurish.

Anyone have an idea why RW 8.14 has dumped ALL of my images except for the banner images. Also it won’t let me drag and drop images or add images in any way into my pages???

This is the first time I have had issues with the RW program itself vice a stack etc. Kind of lost on how to add my images back. Using Mojave 10.14.3 with RW 8.14

No issues with previous versions of RW…

1 Like

I am running 10.14.2

I’m still on RW 8.0.3 and on 10.14.3

Obviously RW 8.0.3 is working fine, I luckily did not upgrade to 8.1 but I have downloaded 8.1.4 from Realmac (I did not use the upgrade feature in RW).

I made full duplicate copy of all my RW project files and renamed that folder RW 8.1.4 Projects and also renamed my version of RW to 8.0.3

And then tried out 8.1.4 only opening my duplicate projects in my new 8.1.4 Projects folder…not going anywhere near my 8.0.3 projects!!

8.1.4 seemed to work for me…I tried out a few projects and all seemed to work fine. Resource links seems ok…but…I did not dare publish. I am very cautious about 8.1.4 now and in fact have now deleted it from my computer and also deleted that duplicate project folder too. I did not want any of my 8.0.3 projects to get “8.1.4 infected”.

Not sure if the upgrade feature in RW is a problem but direct download from Realmac seems better…and before you use any of your projects make duplicates first and keep your 8.0.3 projects separated.

Good luck everyone and I hope Realmac get this issue sorted…I must admit they seem very quiet on this forum which doesn’t give me a great deal of confidence in the long term future of RW now.

1 Like

I had 8.0.3, which fouled up two of my projects, to the point where they wouldn’t even open, so I started on the betas in desperation more than anything else. I never did get to the bottom of what the issue with 8.0.3 was. All the betas worked to varying degrees, but I backtracked on one, which seemed especially flaky. The 8.1.4 beta worked fine and the 8.1.4 official release is working without any issues at all for me. That is just my experience though.

I think that it is important to be sure of your ground before coming on here and stating that 8.1.4 doesn’t work period, as experience has shown me in the past that often the problem is user interface issues. Not reading the instructions about re-linking resources is one thing I didn’t do for instance. Once I did, I realised that I had been mis-understanding what had happened. I took the opportunity to reorganise the files scattered all over the place into a single folder and haven’t had an issue since. Simple really. In my case.

This is a good place to come to for help in understanding problems you might be having and there are a lot of very knowledgeable people only too willing to help. This does mean letting people know exactly what the problem is and what versions you are using. Tagging @dan helps as well, if you want a response. Being seen as aggressive, as one poster on the forum has been recently helps precisely nobody, although it probably made the poster feel better for a couple of minutes.

I have had EXACTLY the same problem. MacOS has nothing to do with this problem. I am running High Sierra.

I have found that publishing is a major source of problems in of 8.1.4

Publishing with and when exporting sites to a local directory also screwed up changes made to the url of the target directory and website name.

I cannot tell you how much time I wasted on bugs in 8.1.4.

Worse, I cannot get back to 8.0.

This is totally unsat. Customers are screwed.


I’m having the same issues. My files were fine before but none of them will publish or even preview. I emailed customer support and they told me they were fixing the bugs of 8.1.3. But 8.1.4 is no better. Yes i’m screwed.

1 Like