RapidWeaver 8.1.6 is now live!


(Dan) #1

Hey Weavers,

We’re continuing to working tirelessly to make RapidWeaver better, and this latest release is no exception.

What’s New in RapidWeaver 8.1.6?

  • Fixed a crash when generating the web icon package
  • Remove/relink resource buttons now works on the correct item
  • Fixed a crash when updating links
  • Fixed some issues with the simulator window menu items
  • Various other fixes

Hopefully you’re finding RapidWeaver 8.x more stable than ever (Our stats are showing a massive reduction in crashes over all previous builds of RapidWeaver). However, If you’re still experiencing issues please let us know so we can fix them up.

Download RapidWeaver 8.1.6 or update directly in the App

Happy Weaving,
Dan & Team Realmac


RW 8.1.5 - Deletion issues [resolved with 8.1.6]
(Jan Fuellemann) #2

Thanks for the quick update!


(Dan) #3

As always, you’re more than welcome!


(Dan) #4

(Scott F) #5

Hi all,

I love to hear some feedback on how this update 8.1.6 is compared to the previous 8.1.x updates and how it is working for people?

Are all the bugs sorted, especially the resource links issue.

I’m still on 8.0.3 and not yet confident to move on from this version.

All comments and feedback would be appreciated…and not just the bad stuff. I’d like to get a balanced sense of how 8.1.6 is and if I should update or leave it.

Thanks Scott


(Dan) #6

Download the latest build directly, make a copy/backup of you project and give it a try!

If you hit any issues you can simply go back to using 8.0.3 and your backed-up project.

I’m pretty sure you should be able to upgrade smoothly though.

Happy Weaving!


(Keith Cass) #7

Thanks for the update. Just one problem. When I click on “Install and Relaunch” the app closes and then…nothing happens!

If I leave it a while and open the app, it tells me that version 8.1.6 is available and we go through the cycle again.

Any advice please?

Keith


(Keith Cass) #8

Problem solved. I downloaded the revised version from the link above. It would still be interesting to know why the attempts via the app itself were not successful.

Cheers


(chuck berhain) #9

I tried the new version and had the warning, it seemed easy enough to relink but next time I opened the project there was the warning again, so I returned to my prior version 8.1, just because it works for me and I can be patient. I only tried it because I had skipped a couple of updates and wondered if it was problem free.


(Robert K Brumbelow II) #10

I noticed I cannot save a project file because it contains a pdf and throws the following redacted error message:

Couldn’t save a sandwich of type “Resource”, because duplicating a file from /Users/redacted/Downloads/AlsoRedacted/somefilename.pdf, to /var/folders/w4/spm7swb94v781thclz4n4n6w0000gn/T/com.realmacsoftware.rapidweaver8/TemporaryItems/(A Document Being Saved By RapidWeaver 8)/EIC.rw8/Resources/AC894C68-C28A-46B2-907F-361A277EBDCE/somefilename.pdf failed with an underlying error of Error Domain=NSCocoaErrorDomain Code=513 ““somefilename.pdf” couldn’t be copied because you don’t have permission to access “AC894C68-C28A-46B2-907F-361A277EBDCE”.” UserInfo={NSSourceFilePathErrorKey=/Users/redacted/Downloads/AlsoRedacted/somefilename.pdf, NSUserStringVariant=(
Copy
), NSDestinationFilePath=/var/folders/w4/spm7swb94v781thclz4n4n6w0000gn/T/com.realmacsoftware.rapidweaver8/TemporaryItems/(A Document Being Saved By RapidWeaver 8)/EIC.rw8/Resources/AC894C68-C28A-46B2-907F-361A277EBDCE/nameoffile.pdf, NSFilePath=/Users/redacted/Downloads/AlsoRedacted/somefilename.pdf, NSUnderlyingError=0x6000065f0390 {Error Domain=NSPOSIXErrorDomain Code=1 “Operation not permitted”}}


(Robert K Brumbelow II) #11

Update: By moving the onto my desktop , export can proceed. This looks like it is an OS level block of moving something from the downloads folder to a different location. However, I still cannot save the project as it continues the same class of error.


(Dan) #13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.