Stacks 4.1 crashing

Installed 4.1 and RW started to crash when saving and publishing. I re-installed 4.0.4 and all seems to be functioning ok-any one help on this. the new update has some great features which I would like to use.
Im using Mojave OS

I’m running Mojave and stacks 4.1 and not seeing what you are (no crashes).

Publishing does a save, so I’m guessing that it has to do with the saving.

Did you try it with another project by chance?

What version of RapidWeaver are you using?

Tagging @isaiah, he might need a copy of the project file.

Hi Doug Im on the latest version of RW. Yes I did try it on another project the same thing happened. I also tried “save as” but no joy

If you want to spend more time with it, you could try updating again, just to see if maybe the copy you got was corrupted.

If not than wait for @isaiah.

I install Stack 4.1 + Rapidweaver 8.7 and I was not able to publish crash all the time I try. Go back to RW 8.6.2 and keep Stack 4.1, same thing crash all the time while publishing. Go back to Stack, 4.0.4 and everything is back to normal! I’m on Catalina 10.15.7!

That’s exactly what I did but I’m on Mojave. I wonder what’s causing it? Maybe conflicting plugin-ins?

All the best John
www.johnspringate.com

Are you folks using formloom 4 by chance?

No, I’m not using Formloom in this project!

I don’t use form loom either-so I presume wait for the next stacks update hopefully it may sought the problem out

Hi John,

I’m afraid this is not a widespread problem. We are tracking one other crash – but it is very specific to unpacking very specific Templates.

My guess is that this has something to do with the contents of the files – or since you are seeing it in more than one file – perhaps another installed plugin (whether or not it is currently being used in these projects).

Since one of these is easy to check, and one is a lot more difficult, let’s try the easy one first and the hard one second:

Easy – Maybe it’s some other plugin:
Temporarily disable everything else. Even if your projects use the other plugins, just disable everything, this is just a temporary check to make sure Stacks is the culprit.

  1. Open the RW Prefs and choose the Addons tab.
  2. Uncheck everything but Stacks and the built-in RW plugins.
  3. Restart RW.

Did things improve? If yes, then great – you’ll have to enable them a few at a time to try figure out which one. But once eliminated, you can get back to work.

Medium – Post a crash report
Post a crash report + details

  1. Make it crash by doing the simplest thing that you know crashes it every time. The simpler the better.
  2. Launch RW.
  3. A dialog box will appear informing you of the obvious: it crashed. Click on the Report button.
  4. A larger window will open – DONT click send. Plugin developers don’t get a copy of that crash report. Everyone that does get a copy won’t want it.
    Instead, copy the text, save it to a text file, and post the file here for me to see.

It also helps to have the details about what you were doing at the time of this particular crash. The more detail the better. Where you opening a project? Publishing? Saving? Did you use them pull-down menu? Or Cmd-Key shortcut? Was there anything visible on the screen before the crash? Was there anything selected? Anything at all that you think might be interesting. I will be interested to read it.

Hard – Everything else
The next step is to send me everything I’ll need to open the file and make it crash here on my machine too. This is not because I don’t believe you, this is because I need to make Stacks crash in Xcode with the debugger running so that I can see what’s going on. Here’s nice description of how to send this stuff to me. Feel free to send it here or on the Stacks Slack channel where we can chat about it, or via our support link (at the bottom of every page of our website) if you prefer.

Thanks for reporting this one. Hopefully we can get this working for you ASAP.

Isaiah

2 Likes

Wierd, my system crashes too (it’s not stable enough to do any serious work ATM), but of all things, the FormLoom Export worked for me…

Same challenge here.

RW crashes randomly (better: closes unexpectly) from time to time, yesterday evening I lost the work of an hour. I was about to refactor the footer of the pages into a partial and while placing the partial on all pages, RW simply closes. The other day RW crashes after I tried to copy / paste a stack from one page to another.

I personally wouldn’t do any production work with the current version of RW 8.7 or Stack 4.1. I can’t even tell what causes the problems as a) I updated both , RW and Stacks, at the same time (mistake) and b) there’s not always a crash report I could send.

(Attachment Crash report .rtf is missing)

I’m having a similar issue; after updating Stacks to 4.1, the project takes longer to open, and clicking on any page in the project makes RW crash. I’m on RW 8.7 (20860) and Stacks 4.1.

I’ve also migrated the file to another Mac, with a pruned set of adding and plugins, and Stacks 4.0 – just to see if I can work on the file – but precisely the same thing happens.

It seems that the crash under stacks 4.1 has damaged my master file, and I can now no longer update my website: pretty serious for us. If that wasn’t bad enough, I can’t clear or generate crash logs: I get the following error;

DevMate crash reporter is not enabled

I’m now having to de-archive backups and re-install Rapidweaver and addons just in the hope that we can re-access our work. In the run up to Christmas, a damaged file is the last thing we need.

An update: the crash occurs when clicking on any subpage in my project.

@isaiah,
Don’t know for sure but I think these publishing/export crashes are related. Are you using DevMate in stacks development? It seems to be popping up and preventing publishing logs.

4.1 is super crashy here too. No pattern to it. I just exploded a partial and it went. I’m lucky to get 20mins of work before it goes. Mohave, RW 8.6.2. UIkit3. No formloom here, most Uikit3 stacks plus some Core stuff. Been on this project since June and it’s only been crashy today, after 4.1 update.

Anyone got the link to roll back S4 handy?

The Stacks archive is here: http://info.yourhead.com/stacks/

Star, thanks.

I’ve managed to prune a copy of RW back (8.7, latest), and install only the stacks and addons for one particular project (the crashing one), and it seems fine with Stacks 4.0.4. I’ve yet to make edits and publish, but at least I have a working copy.

If that works, I’ll try to update to 4.1, and see if it works on the pruned RW. If so, it could be something interacting with 4.1 that’s causing the crash, not Stacks 4.1 alone.

Is it possible that another stack, preference, or add-on became corrupted when the crash happened? Seems odd that it only affects one setup, which use multiple addons / stacks for multiple projects.