Rapidweaver 8 hiding utilities in finder menu bar

When I have RW8 open, I can’t see my various utility icons in the Finder menu bar - date/time, volume, wireless, bluetooth, hazel, f.lux etc.
If I click in the area of the icon, the controls appear, but not the icon itself.
All the expected RW menu items are there to the left of the menu bar, but nothing on the right.
Not a problem with RW7 or other applications.
Any suggestions?

As a longtime Mac developer I can tell you that there is nothing that an app can do that can hide that stuff (called Menu Extras in AppKit parlance). My guess is that some other utility you have or even the OS itself is acting up. I’d probably recommend a reboot and a check for macOS updates.

If the problem persists I’d recommend trying to find incompatibilities between utilities you’re using and RW – but try a reboot first.


1 Like

Thanks Isaiah but rebooting didn’t fix the problem.
I’ve been having other problems, like RW8 publishing settings not holding the ftp password - I have to re-enter it each time I open RW8.
BTW The MacExtras are OK when RW opens and shows the project window. As soon as I open a project they disappear.
I’ve trashed RW8 and gone back to RW7 in the meantime in the hope that this is a known problem to someone out there in RWland.
I don’t believe I have installed any utilities in recent times, certainly not since installing RW8

Sounds like a Mac user account problem to me, curious, have you tried as a different user on your Mac?

1 Like

Thanks for the suggestion Scott. I’ve been having all sorts of problems with my OSX (including not being able to drag RW8 from applications to another folder - had to trash it then drag it to another folder; and Mail not opening)
Anyway, I think I’ve got OSX up and running properly again.
Before trying RW8 again I think I’ll do as you suggest and try another user account.
BTW, referring to Isaiah’s rely, I did install Zoom (to join Joe’s RW8 meeting). Probably nothing to do with it but I’ve trashed it anyway.

I have the same problem after re-installing RW8.
I haven’t tried scott’s suggestion of setting up a new account because I’d prefer to sort the problem rather than start on work-arounds.
I presume no-one else if having RW8 problems.

What about minifying the App? Resizing?

Screenshots please :wink:

I suspect the idea of trying it in another user account is just for testing, just in order to diagnose what is causing the issue, not a permanent solution.

If the problem persists in another user account it limits it to just a few sorts of things: a bad Kernel Extension (a sort of utility that is installed at the user level) a HID or other device driver (like something for a mouse or a microphone). All of these things are in very prescribed locations in your system and there are usually only a few installed – so if you can narrow it to these then the issue is as good as found.

If the problem does not persist in another user account – if the menu works fine there – then it’s a good indication that there is something installed in the user area that’s causing the problem. The list is quite a bit longer there, but in 10 minutes of testing you’ll at least have eliminated the system-level things.

I would pay special attention to the Zoom install. I’ve installed it before too and it seems to work quite well with my system, but it did install a few goodies at the system level (i think to record system audio???). I don’t think these are removed by simply trashing the app. They are likely still running in the background on your system, or at least installed and waiting to run (well, unless you ran an uninstaller to remove them of course).

Anyway… the point is, to try to find ways to eliminate the various bits installed on your system from the list of possible culprits. Running under a second user account is a good start. :smiley:


Thanks Isaiah. Very helpful, as I have never had these system level problems before.

After a full uninstall of Zoom the menu bar for RW8 is looking like it should, and I am not having to re-enter the ftp password each time I open a project.
Thanks to Isaiah and Scott for their help in working through this.
And apologies to Jannis for not replying to your post.
There seem to be some residual system problems but at least the RW8 issue has been resolved.

Spoke too soon. Problems returned after quitting and reopening RW8. Back to the drawing board.
I’ll close this topic and get onto sorting out the system as Isaiah and Scott have suggested.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.