RapidWeaver not utilizing all possible connections, slow upload

publish
rapidweaver
publishing

(Brad Miller) #1

My uploads (publishing) have slowed to a crawl regardless of my settings. I’m pretty sure this happened after I updated to RW 7.4.1.

When I first publish my site, RW will only upload to 1 of the possible 6 connections (Lightning Fast). After some time, one of the other connections will start being used. And by the time my site is done uploading, there may be 3 or 4 of the possible 6 connections being used. All of this makes uploading site changes slow and tedious.

I would appreciate any help.
Thanks

!


(Greg Schneck) #2

“Publish” (export) to a local folder and then upload the files with your favorite FTP app. It is MUCH faster that way if you have lot’s of files. Also make use of single page publishing when you can.


(Brad Miller) #3

Hi Greg,
Thanks for the reply. I do know about and use the options you suggest at times. However, I would still like to fix RWs built-in publishing so that I can use it when needed.
Any thought on that?


(Greg Schneck) #4

If you browse the forums (forgive me if you have and you’ve been around to see it) but some users just seem to have troubles with publishing. I don’t have issues with it but it’s just slower for me. Some can’t seem to get it to publish at all (at times) and others seem to have random issues. Could be the host, the particular Mac config, type of add-ons used, I just don’t know…


(Brad Miller) #5

@Aaron I’d love to know if you have any insight here.
Thanks


(Keith Flanagan ) #6

I don’t know who your ISP is but I will tell you from my experience that if I am using my ISP to upload sites I only can do one site at a time. If OTOH I go through my VPN it will upload 6 files at a time. I don’t know why this is the case but I can always duplicate it. My ISP is Spectrum and I noticed the change about the time that Time Warner Cable was integrated into Spectrum.

I had thought it was just what the OP stated as well, something to do with RW7.1 but it is more to do with the ISP rules on uploads.

YMMV. Good Luck.


(Brad Miller) #7

Hey @barchard. Any thoughts here? Could I have some cPanel settings messed up?


(Gregory Barchard) #8

As I’m aware, this is a RW thing. Nothing on the server side would set the functionality or content of this window. If RW has more debug info, send it to RealMac. They’ll reach out to me if there’s anything they need from me.

Greg


(Brad Miller) #9

Thanks Greg. always very helpful. :smiley:


(Simon Maddox) #10

Hi @firedude2894,

Could you try with the RapidWeaver 7.5 beta? http://blog.realmacsoftware.com/rapidweaver-7-5-beta/

In Preferences, you’ll see an option to “Verify Uploaded Files”. Turn that off, and see if it makes things better for you.

Simon


(Brad Miller) #11

I downloaded the 7.5 beta, turned off “Verify Upload Files” and published a single page. RW would only upload to 1 of the 6 possible connections. No improvement for me.

Any other ideas?


(Brad Miller) #12

I just went back to RW 7.3.3 and had the same issue with slow publishing. GRRR.


(Brad Miller) #13

I just sent my upload logs to Realmac Software. Hopefully, this will provide some answers.


(Gregory Barchard) #14

Cool. As always, @simon let me know if there’s anything you need from me.


(Brad Miller) #15

@simon I’m giving this a bump. Still an issue with no answers.

Brian LePan was emailing me regarding this issue, then just stopped answering over a week ago?


(Brad Miller) #16

Hey Greg,
The issue is that RW seems to only open one connection at first. Then after several minutes another. A few minutes later, another. And maxes out at 4 connections. This has only been happening for the last month. Before that, all 6 connections opened and lightning fast.
You have a KB article from a few years back that suggests 2-4 connections, even though 6 worked well for me. Is there anything to this article?
https://kb.chillidoghosting.com/publishing/rapidweaver/sftp


(Gregory Barchard) #17

If it’s working reliably for you, then you can stick with it. The guidance was before RW made any changes to the connection scheme.


(Brad Miller) #18

I’m trying not to be cynical here but wanted to let RW support folks know that I just installed RW 7.5 and this issue was still not resolved. :thinking:

Ember Library Mediator

On a brighter note, previewing in Safari is working again for me! :smiley:

@Aaron @dan


(Keith Flanagan ) #19

As I commented above, it is not RW that is the issue here, it is your ISP. I can and do upload 6 streams at once when I am running my VPN. When I am not on my VPN connection and just using a standard ISP connection I only get one active connection and the same issue you do for the other 5 connections.

I would suggest you experiment with different VPN’s to see for yourself. You might also try different FTP software. You will experience the same result. To get the issue resolved will take you speaking to your ISP to have this issue resolved from their end or just bypass them and use a VPN.

Not sure who your ISP is. I use Spectrum Cable. Ever since TimeWarner was bought by Spectrum I have experienced this issue.

20 AM
VPN On.

28 AM
VPN Off.

Don’t get me wrong, there are a lot of issues that RW needs to work on but this is not one of them.


Publishing/connection anomalies
(Brad Miller) #20

Thanks Keith for taking the time to explain this so thoroughly. I will be looking into this.

P.S. It’s strange that no one at RealMac Software ever thought to bring this up! Haha!