Reason Theme Site Not Working

I’ve just had a client contact me to say that on her website the hamburger menu has stopped working on handheld devices…

The site is using Reason Pro, an old NCD theme but it was working fine when I published the site some time ago. I guess developments in browser architecture has broken it?

Can anyone advise if this is fixable otherwise I will have to explain to my client that it needs overhauling and I will probably rebuild the site using a new theme?

Looks like you have JavaScript errors.
Mixed Content on the jQuery library.

Did you convert the site to https?

What version are you using of Reason?

Looks like the jQuery is hardcoded to HTTP: at the bottom of the theme.

Since Nick Cates is gone you’d need to change the theme yourself or pick another theme.

1 Like

BTW. without the https works fine.

So once you fixed the mixed content you need to do redirects to https.

1 Like

Hi Doug,

Thank you so much for taking a look at the site issues I have. Yes it is an old version of Reason v1.1.1 and I have other sites built in v1.2.4 so I don’t even know if this is the latest version of that theme. It’s such a shame that Nick is not supporting any of his RapidWeaver projects now and looking at other posts I haven’t even bothered to contact him about this. I notice that SuperPlex banner stack is also no longer working but I fixed that by using JW’s Cycler stack.

I shall try and fix this in Reason and maybe even implement v1.2.4 if there isn’t another more recent version available.

Could you advise me on what I need to do to fix the https on the jquery? I have pasted this code (with https)…

into the JavaScript panel in the Code panel of the site settings but it’s not fixed it so clearly that needs to go somewhere else?

I have uploaded a development site version here…

I hope you can help?

Hi David - hope you’re well! If you are building even a small number of client sites you should consider one of the blank theme frameworks. One product to build multiple sites in as many styles as you want… Not going to recommend one over another here but take a look if you haven’t already.

Yes you’re right, all my recent sites have been built using Foundation which I much prefer, it’s just this is an older site that I am trying to patch up to keep it going, I’m sure at some point I will rebuild this site for them.

First thing I’d do is check on nick’s old site, there’s an order lookup. If you provide the email address that you purchased the theme with it will send you a link to download the last version.

I’m not at my Mac right now, but I have it and the jQuery was fixed.

If that doesn’t work then let me know and I’ll give instructions on how to repair the version you have.

1 Like

Hi Doug,

The latest version is 1.2.6 and I have just republished the site using that theme and I think it has fixed it…

Do I need to do something so that if anyone goes to the http version of the site it redirects to the https version?

Hey David,

I just ran your home page through why no padlock. The mixed content is fixed. But it reported a strange error on your certificate.

You have an invalid or missing intermediate (bundle) certificate. This may not break your padlock on all browsers, but will on others. Please contact your SSL Vendor for assistance with this error.

Never seen that one before?

Yes, once you are comfortable with your site not having any other mixed content or errors (I’d probably run more than just the home page through why no padlock).
You should add some redirects to the htaccess file.

1 Like

Did you edit the theme code?
Looks like there are script tags inside script tags throwing syntax error in browser console.

Thank you to everyone for their advice in this thread, I think I have fixed the issues now. Updated the htaccess file and fixed the java script error as I had manually added a line of code in to the Code settings of the RapidWeaver project.

If you are able to check it for me that would be very much appreciated.

1 Like

Hi Doug,

I added the code…
RewriteEngine On
RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} ^www. [NC]
RewriteCond %{HTTP_HOST} ^(?:www.)?(.+)$ [NC]
RewriteRule ^ https://%1%{REQUEST_URI} [L,NE,R=301]

to the htaccess panel in the RapidWeaver file and then I have run it through the htaccess tester and got some red flags, have I overlooked something?

The htacess tester test a single directive at a time, just like Apache does. It’s telling you whether or not each condition has been met or not.


RewriteCond %{HTTPS} off [OR]
This condition was not met but the [OR] option made it pass.

Is saying the the URL that you entered to test was an https URL so the condition being tested (https being off didn’t get met. It also says that there’s an OR option so it gets passed to the next directive.

So these aren’t ”red flags” just telling you line by line what conditions are met and what are not.

The important thing to look at with the tester is if in your case, you enter a URL to test that starts with HTTP it shows a new URL that starts with HTTPS. Or if you enter www at the beginning it removes it from the URL.

Thank you Doug, I am learning a lot about htaccess.

So does this mean my site is all as it should be?

Going back to the choice to go for Remove www or Force www I chose to remove (on the understanding that this is a more modern choice? Does it matter which choice to go for?

Do the settings in my RapidWeaver project need to coordinate with my choice to Remove or Force?

Here are the settings for this file…

Really doesn’t matter, just need to choose one or the other. Be consistent everywhere you post the address. If you want www then use it every place, if you don’t want www then never use it.

You do need to have web address in RapidWeaver set to what you want. In your case you have it set to www but then the htaccess rule is set to redirect it to remove the www.

I personally think removing the www is nicer as it creates a shorter URL as long as it’s a “common” TLD (top-level domains) like .com or .net. If it’s one of those newer TLDs like .club or .info, which people might not recognize as a website, then I’d force the www.

The most important thing is to be consistent with what you use, even on printed stuff and signage.

1 Like

So I have updated the web address to not have the www in it but the folder it gets uploaded to on the server is titled “www” but I guess that doesn’t matter.

However when I type in…
the site doesn’t load.

But as soon as I add the www. it does.

Also if I remove the s so that the address is…

the address works but says the page is not secure and doesn’t redivert to the https version.

Is this correct?

1 Like

No, that isn’t correct.

Do you have anything else in the htaccess file?

Do you have any other redirects like from a control panel?

I’d remove everything from the htaccess file right away, until this gets figured out.

Change the r=301 to r=302 while you’re testing this. 301’s are permanent and have no expiry date so they get cached.

1 Like

I have decided to upload the Force www htaccess code…
RewriteEngine On
RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} !^www. [NC]
RewriteCond %{HTTP_HOST} ^(?:www.)?(.+)$ [NC]
RewriteRule ^ https://www.%1%{REQUEST_URI} [L,NE,R=301]

So it redirects.from http://www to https://www which is great but still nothing working without the www

It’s really hard to say what might be causing the issue. What you posted still shows 301’s, I hope you took my advice and changed them to 302’s until you get this worked out.

If you have or had a something as simple as a typo or syntax error, it might be cached by browsers and proxy dns servers indefinitely since a 302 is a permanent redirect, meaning the old URL’s are never coming back.

You haven’t answered the other questions yet:

Those redirects for forcing https and either removing the www or forcing the www are being used all over the place. So my suspicions are something else is causing the issue.

As I said and I can’t stress this enough, switch to 302’s right now.

Who are you hosting with? Might help me assist you if I can have a quick look at any knowledge base they have.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.