Round of crashes exporting or publishing on 7.1.x (Solved 7.1.3)

I’m very sorry Dan, but 7.1.3. does NOT fix the issue.

This version seems to run thru the export fine, then starts to upload, but gets stuck after about 50 out of my 3500 files.
Another attempt leads to this message:
Exception while exporting site
*** -[__NSArrayM removeObjectsInRange:]: range {16, 1} extends beyond bounds [0 … 15]

Then I tried to export locally: This runs for a while but not to completion, and then freezes RW completely.
Trying again, I got this:
Exception while exporting site
-[LHFileCopyDelegate rangeOfString:]: unrecognized selector sent to instance 0x61000a220ea0

Dan, I’m not an alpha tester nor a beta tester. We are running a business here and rely on RW since many years.
But what happens since the upgrade above 7.x here is simply unacceptable. It causes damage to our business.

Hope it fixes the problem I did download the 7.1.3 a few hours ago that one did not work,FYI

Sorry to hear you’re having issues.

It could well be down to a third party plugin, stack, or theme (it’s not always RW at fault), can you email and send us a copy of your project file and we’ll take a look at the problem.

@PonyVigil try the latest build we just uploaded!

Still the same link as before, maybe it will be different…:worried:

@PonyVigil until the Release Notes page is updated, you should be able to use the in-app updater (“Check for Updates”) to get the latest build.

Ok. I’m uploading my project file to our FTP server and send you a mail when complete for download.
Can’t send direct - our provider does not allow 135MB.

If the reason is a 3rd party plugin, I can only question why up to RW 7.0 everything worked just fine.

Ok downloading :dizzy_face:

Nope still same issue and lost a client, so bummed, oh well someday this will be fixed I hope. Can’t loose very more clients. Especially the big ones who like my work…

Help SOS:scream:

Not sure what I’m looking at there, @PonyVigil. Can you share some more details, and perhaps a higher resolution screenshot?

I’m not entirely sure what @PonyVigil problem is either. 7.1.3 seems to have solved both the saving and the exporting problem for me. Published all my webpages. Thanks guys.

If I have any new problem I’ll be reporting it at this thread.

1 Like

Hi Dan,

Just downloaded the latest build (18338).

First, I tested by FTP connection in Publish Setup - Connection test successful.
When publishing, the export went thru fine (I believe), but the I got the message:
Can’t connect to your FTP server, Weird server reply.
I tried several time - always the same.

So, still stuck.

Tried again, RW crashes shortly after start of export.

Tried to export locally: RW crashes shortly after start of export.

I updated to 7.1.3 and it crashed my version of Rapidweaver asking me for activation codes for Rapidweaver and Stacks. I’ve lost about 2 hours of work for a client. I did try and save these but it kept brining up an error message when trying to save.

Losing faith in Rapidweaver since version 7… gutted…

Ok, I’m going to post a workaround for those of you who can’t make your projects work in 7.1.x.
It’s not supposed to work, because it involves downgrading your project to work from 7.1 to 7.0, so I assume YOU WILL MAKE A COPY FIRST.

  • Grab yourselves a copy of Rapidweaver 7.0.x (Anyone that works for you) at RapidWeaver Release Notes
  • Go to your project location, right click on it, and clock on Show Package Contents
  • Open “Contents.plist” with a Text Editor.
  • Go to the line where it says “Minimum Application Version”, and change the line below. It should be “7”, not “7.1”.
  • Save, you are good to go. Try to open it with your RW 7.0.4.

Again, not responsable if you broke your project. Make a copy. And if this doesn’t work, share the project with the Realmac guys with details about what’s happening to you. They can’t fix what they don’t know or what they can’t reproduce.

Hope this helps for those in need.

Dan: Unfortunately that created more issues, such as clicking on themes icon causes a crash. This was an issue quite a few updates ago.

@Pete can you send your project file into so we can take a look.

I can confirm that 7.1.3 fixed the crash that I was seeing.
Well done. And on a weekend too.

1 Like

I have a very large site (630MB file) and that is with image warehousing. Zero problems publishing in Version 6 or Version 7 up until Version 7.1. I have tried every version of 7.1.x with no success. In addition to not being able to publish, I have lost many hours work due to repeated crashing. This is not just while trying to preview pages, RW 7.1.x just seems to crash whenever it pleases.

I noticed a slight improvement in 7.1.3 in that it put up the new publishing related sheet prior to crashing. Before I would hit publish and it would crash immediately or give me the spinning beach ball of death cursor.

I can’t believe we have gone from 7.0.x, which was the stablest version of RW ever, to 7.1 which is the least stable version I have ever used. This is going going back to Version 3. To say I am VERY upset after over a week of this is putting it mildly.