Round of crashes exporting or publishing on 7.1.x (Solved 7.1.3)


Dan suggested to disable PlusKit … and publishing went OK.
His suspicion was correct! No more crashes.

Guess this is the way to be able to work again with RW!
Yourhead Software will have to correct the issue.

Dan - again, big thanks you for finding this out!


RW 7.1.3 did NOT help my publishing problems, however as Marian’s post above suggested removing Plus Kit solved the problem. The new theme I had switched to no longer required me to use the @import command to bring a header into the top of a blog page. I removed Plus Kit, removed all the @import commands and life is good for now. Thanks for your post Marian.


I will add a follow up to my post confirming that the removal of PlusKit allowing me to publish. After my site was published I had some corrections to make. To my great surprise the removal of PlusKit also seems to have sped up the page load time within RW 7. Most pages now load instantly with the spinning colored beach ball cursor appearing for a split second or so. I had some pages that took 30-60 seconds to load before and now they load in 5 seconds or less. This had been going on for a while and I figured it was the complexity of the page. Evidently not. It seems PlusKit was holding up the works for some reason. Bottom line I would suggest seeing if you can live without PlusKit for your site and it may just speed things up.


I’ve updated to 7.1.4 and it is still impossible for me to publish anything. I have just three very simple sites and all of them hang and have to be Force Quitted.

When I tried to publish my site with 7.1.4 I get

Exception while exporting site
*** -[NSURL initFileURLWithPath:]: nil string parameter

I also had this problem with 7.1.3.

Is this related to the other issues reported in this thread?

@ajvcali and @JanSteele - (assuming you are using one of my plugins) can you send your file in to our support folks. i’ll take a look and see if i can pinpoint the problem. and if you’re not using any of our plugins then probably best to send to Realmac Software.

Yes Isaiah I am using Stacks. I will send you the project file. Must emphasize though that this issue has only happened since upgrading to RW 7.1. Previously there were no problems. And it is not confined to just the one file, it happens with all my sites

@JanSteele - It’s a group effort. :smiley:

If the bug is in Stacks, I’ll fix it. If I find the bug is in RapidWeaver I’ll be able to provide their devs with details direct from the code.

The goal is making the total package better.

Finger pointing, blame, and saving face – those are things for young developers. I got over it 20 years ago. :stuck_out_tongue:

Bugs happen. They need to be fixed. The sooner the better.



I’m also using Stacks. I can send the project file also.

I’ve received one project. Thanks. It has many dependancies: 3rd party stacks and plugins. Please also include a copy of those too. Thx. :slight_smile:

I can’t seem to upload my project file (too big at 77MB?). I could upload it to my site and send you the link if you want to download it directly.

@ajvcali - yes, we usually recommend:

  • collect a copy of your project and any themes, plugins, and stacks we’ll need to open it into a folder
  • zip the folder (cmd click on it and choose Compress)
  • put the zip file on Dropbox (or your favorite file sharing utility)
  • share the public URL with us.