RW 5.4 not exporting style or background


(Chris Palmer) #1

After a few years of being ill, have recently tried to update my site. Was having trouble getting a few minor changes to take even though it showed that it was updating, so I republished the site and now it looks as if it’s from about 1995. No background, nice headers, etc.

I found a similar post from a few days ago, someone using RW5.3 and another user suggested clearing the publishing cache. My version does not have this option.

I know this happened to me years ago but it’s been so long I can’t remember what I did to fix it. Am very cautious to upgrade because then my stacks don’t work. Took me six weeks to backtrack and get versions that would play nice with each other so can’t afford to change!

Any help is much appreciated! The web site is www.SpeechLanguageNeighborhood.com


(Mark Sealey) #2

You’re using the Veerle Theme, aren’t you?

A quick look at your source code suggests that the CSS files aren’t loading, can’t be found; that would account for what you’re seeing.

You ought to be able to make it look better by trying a different Theme - directly from within RW.

Save a copy and work from that. Try different Themes and see if there’s one whose look you like. Good luck!


(Chris Palmer) #3

Mark, you’re my new hero! Will try post haste. Thanks so much for taking the time to respond. You’re very kind. - Chris


(Chris Palmer) #4

Well, no luck. Tried a bunch of other themes and all with the same result. Any suggestions for how to force load the CSS files via FTP?

Thanks!


(Mark Sealey) #5

Chris,

If you have an ftp client, you could try it - from within the RW Theme. But…

… I hate to say this; it’ll not be what you want to hear:

if you’re intending to maintain the site, it’d really be best to find out what’s gone wrong, whether any of your RW files are corrupt. Themes’ contents - such as CSS - are integral to the site’s working and shouldn’t really be uploaded like that. Apart from anything else, there’s a good chance that all your good work will be overwritten the next time you come to publish.

I think my next step would be to Export the site locally and see what works there.

Then I really would suggest a clean install of RW - perhaps on another Volume, keeping all your existing files - and try and get a good, serviceable install. Even better would be to move up to RW6. A lot of work, I know; but probably less work in the long run.


(Michael Forte) #6

Chris,

I took a look at your source code and see all of these resource links to http://speechlanguageneighborhood. com.temp.guardedhost.com/rw_common/themes/webbusiness/styles.css

If you remove .temp.guardedhost.com from the path then the page should load correctly.

Mike


(Chris Palmer) #7

Thanks Mike and Mark, good suggestions from you both, and much appreciated. Tomorrow is another day… Will report back if I’m able to figure anything out. Would be open to a different theme, just the thought of having to type in all that information again… Even with cut and paste, not a happy thought. Oh well, me and my first world problems…

Thanks again, guys!


(Mark Sealey) #8

Chris,

With a change of Theme (after making sure you have everything backed up) you shouldn’t have to retype anything.

In the first place I’d suggest upgrading to RW 6. It’s a big leap if for no other reason than that resources are stored in a new location in your Library. But you’re going to have to do it sooner or later… RW 7 will be here within six months, probably.

That ought to give you a clean start. Try a new/different Theme to see whether that makes the CSS whose absence seems as though it may be behind your current display probs behave properly. Good luck and let us know how you get on!


(Chris Palmer) #9

Mike, you gave me the clue I needed. It turns out that under setup the web site was listed as speechlanguageneighborhood.com.temp.guardedhost.com

Once I changed it under the settings for the web site it published correctly!

I vaguely remember publishing to a temp directory when I briefly changed hosts a few years ago. I guess I forgot to change that path back.

MAJOR brain fart! Thanks so much to you both for your help!!!