RW7 (17706) / Publishing Bug


(Robert M. Münch) #1

Version 7.0 (17706)

If the publishing path configuration is: /Library/Server/Web/Data/Sites/…

This is wrong. From the log-file:

24.05.16 13:37:59,878 RapidWeaver 7[7787]: Creating directory '/Users’
24.05.16 13:37:59,904 RapidWeaver 7[7787]: Creating directory '/Users/www_upload’
24.05.16 13:37:59,930 RapidWeaver 7[7787]: Creating directory '/Users/www_upload/Library’
24.05.16 13:37:59,955 RapidWeaver 7[7787]: Creating directory '/Users/www_upload/Library/Server’
24.05.16 13:37:59,981 RapidWeaver 7[7787]: Creating directory '/Users/www_upload/Library/Server/Web’
24.05.16 13:38:00,007 RapidWeaver 7[7787]: Creating directory '/Users/www_upload/Library/Server/Web/Data’
24.05.16 13:38:00,033 RapidWeaver 7[7787]: Creating directory ‘/Users/www_upload/Library/Server/Web/Data/Sites’

Look you use ~/ as doc-root instead of the file-system root when giving a trailing /…

Please fix ASAP.


(Dan) #2

We’re aware of this issue and are working on a solution now. Expect an update “ASAP”.

In the meantime, use the new “Browse” button when setting up a Publishing location to make sure you’ve got the right directory.

Also, make sure you report any bugs to support@realmacsoftware.com - we find it easier to keep track and log them via email :slight_smile:

Cheers,
Dan


(Robert M. Münch) #3

Bug reports: Will, do.

The current “Browse” button behaviour doesn’t help as I can’t exit my home directory.

Robert


(Gordon Valentine) #4

Had RW Version 6.4 (15176), did a successful FTPS to Yahoo site earlier today, then upgraded to RW Version 7.0.1 (17728).

I did a few edits, saved, tried to FTPS to my site. I first did a test, and kept getting

Couldn’t sign in to your FTP server
Timeout was reached.

When that didn’t work, I checked my credentials to Yahoo, which are correct, and tried to do a direct FTPS publish, and the app crashed, not once, but twice.

Before version 6, I was about fed-up with both RW and Yahoo for not talking to each other, but in V6, RW enabled FTPS. I then fell back in love with updating and changing my website, however this isn’t a very good start to RW7.

I’m reading others are LOVING this update, however, I’m not impressed…thus far. Any ideas on work-arounds, or ideas what may be the problem?

Thank you,
Sluggo


(Steve Yalisove) #5

The browser won’t work since you are logged into a Mac OS X server as your account. Until they let you navigate to the root it just doesn’t work.

I fount a simple UNIX work around. Just put two dots in front of your path.

So instead of
/Library/Server/Web/Data/Sites/

Use
…/Library/Server/Web/Data/Sites/

Hope that helps,
Steve


(Robert M. Münch) #6

I can navigate to other places with my account, the problem is that the RW browser has no “upward” function to move up the directory tree. It just let me move down.

That doesn’t work. What effect should this have? …/ is just the “directory” above… First my place is not one level up, but at the root of the file-system, second, RW uses ~/ as starting point so ~/…/… just doesn’t make any difference.

– Robert


(Steve Yalisove) #7

It works great on my Mac mini. I agree that the RW from server won’t go up the directory. Sorry it doesn’t work for you.


(Robert M. Münch) #8

Maybe you have installed the server stuff for a local user, than it might work. Whereas I’m not sure if this is possible.

Or you have created a symlink from the system wide install place to your local folder.

Otherwise it shouldn’t work or better it might only look like it’s working because of this, but the cause is something different.