RW 7.3 Skip Backup Doesn't :(

rapidweaver

(Fred Dalzell) #1

Earlier today, I was doing some test of an issue with a stack and needed to publish a temporary page to complete testing. I have my publishing setting to backup my site every day to the server (I have lots of local backups). So. when the publishing window displayed, I clicked the Skip Backup button. And it said that it was skipping the backup - and then proceeded to upload the backup file anyway, still saying it was skipping it.

I’ve attached a screenshot to show the fun.

Also, when fixing this, could we have a way to backup the file to the server manually (from within RW)? There is no way to manually invoke the backup if skipped.

Thanks, Fred


(Rob D) #2

I don’t often do this, but yesterday I did exactly what you described – and it worked for me. After exporting was done and the backing up process started, I pressed “Skip Backup” and after few seconds it stopped. When I looked in the local export folder the backup was not there.


(Fred Dalzell) #3

Rob - interesting. What OS are you running? I’m currently on 10.11.6 on my desktop. Also, please note that it was the backup to the SERVER, that was not skipped. I always export to the Local Backup folder.

Fred


(Rob D) #4

My system is OSX 10.11.6 as well, RW 7.3. And I stopped using publishing directly to the server a long time ago, because it almost never worked for me.


(Fred Dalzell) #5

Rob - well, at least we have the same software versions. I (knocking on the hardest wood around - my head) haven’t had any of the publishing issues of others to date on any version.

Hopefully, someone else can be a guinea pig and try the skip backup while publishing to server to see if it’s my system or a RW bug.

Fred

Update to tag Dan @dan


(Rob D) #6

We can try to “lure” Brian @lapan or @simon to this topic. Maybe they will have some constructive suggestion for you… Anyway, good luck!


(Simon Maddox) #7

Hi @smokyhills and @Rovertek. Thanks for reporting this. It’s more a complex issue than it sounds, but it’s on our list of things to look at for the next release of RapidWeaver :thumbsup:


(Fred Dalzell) #8

Thank you @simon, it’s not often that I expect to do this and I’ll just not have it set when I need to test changes.

Fred


(Michael Hogan) #9

Hi, folks - just experienced the exact same issue described above by the OP while running 7.4.1 - clicked on the “Skip Backup” button before the backup process began while publishing (in lightning fast mode); the button grayed-out and then, lo-and-behold, I had to wait while the backup process began and finished. Came to the forum to see if it was indeed an issue, and found this thread. Not a huge annoyance, but will be pleased to see a solution implemented. Cheers~