RW 8.7 Foundation 6.7.4 Crash! Bang! Boom!

Hi!

I’m stumped trying to figure out what is wrong! I can create a new project, add a page, add stacks, add F6.7.4 “site styles” & when adding any other F6 stack it crashes! Over & over!

I’ve started up w/ Option key, run disk utility, reboot after each crash, etc, etc. Nothing works…

I don’t know if this may be a clue, but when I upgraded to RW 8.7, there were several old plugins that needed updated… going back to RW3,4,5,6. ((Collage2: Plugin is not codesigned by the developer, PayLoom: Plugin is not codesigned by the developer, Waterfall: Plugin is not codesigned by the developer Would you like to check for updates?))

I also cannot get stacks 4.1.4 plugin to install. I had Stacks 3.x. I get in a loop with “Security & Privacy” permission & this message: “Stacks: Couldn’t obtain plugin principal class”

Another clue: I renamed RW 8(7) to 8.7, now have current files in 2 folders in “Group Containers” directory.

So, is there any hope for me, er, my project??

First off, I’d restart Rapidweaver with the opt key and Deselect the use of 3rd party plugins.

I’d then reveal the addons folder and delete all those old outdated plugins.

Here’s a post with some screenshots

I think you have to have stacks 4 for Foundation 6.
So after you get a “clean” start of RW without those warning messages try stacks 4 again.

If you can’t get S4 going I would post back here for help.

Thanks, those tips are getting me further… I’m thinking I have 2 directories that I need to clean/purge.

I will work on this tomorrow & post my SUCCESS!! You are the BESTEST!!

You can download all new plugins (which will automatically pick up your existing license codes) from our site: https://yourhead.com/

But I’d recommend downloading only what you are using right now. You can always go back and install more later. But keep things as simple as you can after a big upgrade.

Good luck.

Isaiah

Thanks Isaiah, I’ve done that.

Now I have stacks in the library, but “not installed” Plus in Preferences I now have blanks

What’s the plugin window show?

As for the blank stacks @isaiah might be able to help.

Foundation 6 requires Stacks 4.x. This is why it’s crashing when you have Stacks 3.x installed.

1 Like

Thanks for the response. I have Stacks 4.x installed, but when I came home and started computer again, Stacks isn’t installed.

By using Add-on folder view, I find I have several RW folders

If someone could provide the correct RW folder layout, I can move files into the correct one and see if that helps.

I appreciate the help. It seems I get something installed, reboot & a new problem arises.

With RW open, use cmd+7 to open the addons folder that its using.

As Joe said, that’s the one being used. You can also change the folder to where you want in the addons manager.

If you have an hour to kill @isaiah has a really great video on the addons folder

Well, I’m back to where I was a few days ago… I have followed all the suggestions and have learned a lot. Still not getting stacks 4 to install, but I’m closing in on the solution. I’ve created my own add-on folder location & working out of there.

My problem is that I am only a casual user of RW, so opening it to start a new site meant a lot of updates. A year ago, I installed a SSD & moved the RW files to an external drive. When I ran RW, I think thats where all the different folders came from. It didn’t want to run from external drive, so I moved RW to boot drive. Then I compounded it by my zealous instinct for tidiness. My files/ etc go back to 2009, so I had a lot of STUFF. I didn’t realize I could purge STUFF till I saw Isaiah’s video mentioned above.

I am so impressed with the dedication and expertise of this group. As a 70 year old Mum with no formal computer training & who got herself stuck in a corner, I sincerely believe this group will be vibrant for a long time to come.

Kind Regards to All