RW 7 -- Problem Publishing to Local Folder


(Mark Meyer) #1

ANY IDEAS? – I’m trying to publish to a Local Folder – RW7.

Went to the Publishing item in the Page List sidebar, and selected Add New Destination.
In the Publishing Method pop-up menu, i selected Local Folder.
I selected the folder RapidWeaver should publish to after navigated to the preferred folder in the Chooser Popup Window. I clicked on Choose Folder.

Nothing Happens!

The desired path does not propagate into the Publishing Setup Window. It remains blank.

This screen shot was taken AFTER the folder was selected. (several times)

If I try to publish to this publishing destination bookmark I get this…

Any Suggestions?


(Anne Bourdon) #2

I have had the same problem, solved after reboot of my computer.


(Mark Meyer) #3

Thank You Anne,

:blush: After a simple RESTART, all is well. Problem solved. :thumbsup:

MM


(Gary) #4

I get this same problem and a reboot doesn’t fix it.


(Jody Joy) #5

Yep, me too. A restart doesn’t help, and I cannot choose a folder in publishing settings. It stays blank. Why?


(Mark Sealey) #6

For me, the second time I do it, it prepends the server’s file structure to the docroot to the Local publishing location.


(Lemuel Jordan) #7

When I try to publish locally, my publishing dialog box has a field for the website address. It will not let me publish without something there, and the published files have the links broken. I am attaching screen shot of the dialog box. Is this a bug, or is there something that I should be putting in the web address box to make it work locally.

I am attaching a screen shot.


(Lemuel Jordan) #8

I am using RW Version 7.4.1 (18708)


(Greg Schneck) #9

The Website Address is only used if you select FTP options in the Publishing Method pulldown. So when setting up a local folder you need only choose the folder and that’s all. Leave Website Address blank.

So you only configure this once with your folder… then when you want to publish use the Publish pulldown menu and select your location or whatever you named it. It is not obvious but in the picture above you can click on “Untitled Destination” and name this “path” to anything you want, such as “Local mywebsite.com”. You can then even add additional Export locations under different names.

If you have multiples locations defined you will see them all in the “Publish” pulldown menu. Once you have selected your output then publish via any of the normal methods. You’ll find your “published” (exported) files in your defined folder.


(Lemuel Jordan) #10

Thanks, the dialog for what ever reason was requiring me to enter the website address. It now does not. However when I publish to a local folder and then try to view the site, locally the links will not work. Looking at the code generated the links are configured to go only to the folder that the page (index.html) file is stored in. If the folder is not on a web server then the link just takes you to the folder in the finder instead of displaying the index.html page that is in the folder for that page. I tried to simply rename the pages so they were descriptive of the page such as contact_us.html and removed the folder name which then defaults to the / to create subdirectory in the published folder. This works as far as the links go, but then my layout breaks, I loose virtually all styling relative to layout items. This is a real pain the butt. I need to be able to generate a site that can be viewed locally, in other words the links generated in the page need to be direct links. This is the code that RapidWeaver generates for the menu links

href=“domestic/” rel="">Domestic

what it needs to generate for viewing in local folder is

href=“domestic/index.html” rel="">Domestic

I need to be able to create a website that can be viewed locally without needing it to be placed on a server.

If I am doing something wrong please give me some pointers. If I use command p to view from within RapidWeaver everything works fine but it looks like I am viewing it within the Mac built in server. This is the link http://127.0.0.1:64923/domestic.html

Thanks


(scott williams) #11

I believe you will need to run Mamp or a similar web server on your Mac. in order to do what you want.


(Lemuel Jordan) #12

Thanks, but I should not have to do that for a simple html website. I used to use Freeway Pro, this was not an issue. I have Quick and Easy Web Builder, not a problem, Themler, not a problem, Pinegrow not a problem. It would be simple fix if RapidWeaver would generate their links to go directly to the actual page that you are trying to reach instead of only to the folder that contains the page.


(Doug Bennett) #13

Under settings turn off tidy links. That will generate full page URL’s not just folders.


(Greg Schneck) #14

As stated above… Publishing to a local folder will not allow the site to work locally because the links won’t work. You can try setting all your links to “relative to site” or better yet as suggested, use MAMP. Publishing to a local folder is (I believe) intended to be used so you can FTP your files up to your server rather than have RW upload (publish) them.

Why are you publishing to a local folder? What is your goal?


(Lemuel Jordan) #15

I like to enter some of the design contest, primarily to practice my skills, for those that are requiring a website design I would need to provide a file that they can view locally.


(Lemuel Jordan) #16

Thanks that was the solution that I was looking for. All is well.


(Doug Bennett) #17

Again go to your settings, under advanced and turn off tidy links. This should work for html only pages.

Tidy links removes the file name from your pages and navigation and just presents the folder name. The web server then will look for index.html index.php or index.cgi and serve the first one it finds.


(Lemuel Jordan) #19

Thanks aging Doug, I am relative new with Rapidweaver, have only designed one site that I was paid for since I started using the program. Still learning the quirks of the program.


(Lemuel Jordan) #20

Well Rats it is doing it again. I started a brand new project. Set publishing to local folder and when I try to publish I get the error that I need provide a web address. I also turned of tidy links in the settings. First pict is the setup for local folder, second pict is the requirement that I enter a web address when I try to publish.

Error

Is this a bug in Rapidweaver?

Need help


(Lemuel Jordan) #21

further experimenting, I just typed gibberish in the web address box above, nothing was placed in the publishing set up window area for website address. The next time I tried to publish, I did not get the error. Really weird.