RW7 unable to publish to path starting from / on Mac OS X Server


(Mike Schienle) #1

Hi all -

I have a co-located Mac Mini that I’ve been using to host a handful of sites over the years. I just changed from RW6 to RW7 and tried to publish my site via SFTP. The path I provided is the default one for Mac OS X Server (Mavericks) of /Library/Server/Web/Data/Sites/domain.com. However, with RW7 is is publishing to ~/Library/Server …, which is based on my home folder. I can’t seem to make it start with /Library.

Clues and suggestions welcomed.


(Scott Steven) #2

hmm I have 3 servers with out issues are you using Server or have you loaded something like mamp or CrushFTP


(Mike Schienle) #3

No MAMP installed, but I did have an inactive CrushFTP for a project that didn’t make it out of the womb. I made sure CrushFTP wasn’t running and disabled the daemons, etc. Restarted the server and still no luck publishing directly to the path. I just made an alias in my user path to point to the correct path and republished. That worked fine. So, it’s a mystery with a workaround, at least.


(Robert M. Münch) #4

I have the same problem, still not fixed in 7.0.1 :frowning:

But the idea with the alias is a good one. Will try that as well.


(Scott Steven) #5

I have no issues reset up FTP in the server app clear out the account access on the server and add it back. It may the issue. Also check the permissions on the root folders to the data location . I called apple on a site that stopped working and a couple of folders up from the data had some how been changed. fixed in a click.


(John Abraham) #6

Me too. Did someone file a bug report?


(Scott Steven) #7

Ok I see the issue and will open a ticket. I have gone through all the settings in RW 7 FTP and found issues in FTP with OS X Server at least in El Capitan.

If you follow Apple location the OS X Volume /Library/webserver/data/mysite it will not write to the folder using FTP.

As I have a SSL on the server I switched to SFTP that did publish the site but not where I wanted it to. it sent it to OS X Volume /Users/My Account/mysite. This would be fine if I wanted them there and maybe with multiple Accounts publishing it would make sense but thats not where I want them.

This all worked out I will send a email to Support and if they need it I can create an account for them on one of my servers.


(Scott Steven) #8

I Sent in ticket FTP folder path is really haywire in OS X Server. Offered them an account if they need it. lets see what turns up. FYI did not notice this as I was still using Transmit in my work flow.


(Mike Schienle) #9

Thanks, Robert. I sent an email to support and got an auto-response on Friday. I corrected one thing in the email, which is I’m seeing this on a Yosemite Server, not Mavericks, as originally mentioned. Also, I am seeing this only with SFTP, I don’t have FTP enabled. You mention opening a ticket. I didn’t see a formal way to do that. Can you point me to the right place for doing so next time?

Good comment about using Transmit. I have a folder on the server that is auto mounted/synced with one of my workstation folders via Transmit.


(Steve Yalisove) #10

I too serve my sites on a Mac mini and reported this problem over a week ago during the beta. Dan Counsell did not seem to understand the problem. I am also using SFTP and El Capitan Server. But I figured out a simple workaround. Just put two dots in front of your path as if you were navigating in a UNIX shell. So instead of:

/Library/Server/Web/Data/Sites/Default/site name

Use this:

…/Library/Server/Web/Data/Sites/Default/site name

That will point you to the proper folder from the root, even when you log into you Mac mini with your user account. It works for me. I hope it works for you.
Steve


(Scott Steven) #11

Thanks will try the work around. I offered support access to one of my servers if need be.