RW8: Where can I find my main 'index.php' file?


(Roger Hobden) #1

Hello,
I have just created a new project that i have published on a new hosting website.
When i try to view my new website I get this response that I have attached.
Locating the ‘index.php’ of the hosting site is easy enough with CyberDuck.
But where can I find “my own” index.php file ? I have looked on my laptop everywhere. Where is it hiding ? Any help will be most appreciated.

BTW, all my project pages have an ‘index.html’ file on each page, except for the contact form page, which has an ‘index.php’ file, but I don’t believe that this is the right one.

I am using the ‘Mountain’ theme.


(Doug Bennett) #2

Not sure exactly what you are asking. The screenshot you posted is default from A2 Hosting.

If the page you have is an index.html page then with an FTP client (CyberDuck) you should have both an index.html and an index.php (according to the screenshot) in the same directory if you published correctly.

Do you see that with CyberDuck?
If you don’t see both (And I looked and couldn’t find it) then you didn’t publish correctly.


(Roger Hobden) #3

Hmm …
So how do I tell RW8 to publish correctly ?
And how come I don’t have ‘my own’ index.php file on my laptop ?


(Doug Bennett) #4

Rapidweaver keeps all the stuff you have set up in a project file. The previews or simulator are generated on the fly. You need to “publish” the pages in order to use them outside of rapidWeaver. You can publish to a local folder if you want to use a stand-alone FTP client like Cyberduck. You can also setup RapidWeaver to publish directly to the hosting company.

In the upper right side of the RapidWeaver menu bar, you will see a publish button. It also has a drop down to select setup, bookmarks etc.

2019-02-02_11-17-06

This KB article and Video will help you get started:


(Roger Hobden) #5

So I published my project on my laptop and here are all the files in the destination directory.
I still can’t locate ‘my own index.php file’. the only one that has that name is in the contact-form directory, which is obviously not the one that i need.

publish%20laptop


(Doug Bennett) #6

Index.php files and index.html files kinda do the same thing. You have an index.html file. If you use CyberDuck to copy these files to a2 hosting then you would delete the index.php file (default one from a2 hosting) and your site should be live.


(Roger Hobden) #7

So this is the result that i get when I remove the site index.php file and replace it with my own index.html file.

Among other things, the theme does not load at all, and, it is impossible to navigate to any other page.


(Gary Wann) #8

Why aren’t you publishing with Rapidweavr, that way all the files that you need to run the site (including everything that makes the theme work) get uploaded.

Publishing to your laptop and then uploading the files means you might have missed something. If you look at the developer console in your browser, you will see errors that show that the theme files are not on the server.


(Roger Hobden) #9

Actually, I have been publishing only with Rapidweaver.

The only time I haven’t were the following: the file upload of ‘index.html’ and the file delete of the ‘index.php’ website file, that I just did moments ago.


(Doug Bennett) #10

As Gary (@Ruyton) points out you should have no problem publishing throughRapidWeaver. If you do want to publish with your own FTP(Cyberduck) you will need to PUBLISH all the files.


(Gary Wann) #11

If you ftp to the site, can you see the /rw_common/themes directory and does it have anything in it?


(Doug Bennett) #12

try re-publishing all files from the drop-down menu, or file menu or opt+command+K


(Roger Hobden) #13

This is what i can see in the themes directory:


(Gary Wann) #14

None of your other pages are on the server either, none of the /styled pages.

Either you haven’t actually published them, or they haven’t been published to the right place on the server.


(Roger Hobden) #15

I suspect that there are not published to the right place.


(Gary Wann) #16

You need to publish to where that index.php page was and to where you put the index.html page.

Go to the RW publishing settings and click on the Browse button. That will show where the site is being published. Navigate around the server until you find the index.html file, it will be by itself without the other RW files. Why not upload a dummy file to where you put the index.html file to help you find the right place. Just ftp an empty text file, say dummy,txt


(Roger Hobden) #17

here is where i am published


(Doug Bennett) #18

from a2 hosting

In the Path text box, type public_html.

https://www.a2hosting.com/kb/getting-started-guide/publishing-your-web-site/publishing-your-web-site-with-rapidweaver


(Gary Wann) #19

But is that where you are supposed to publish? You say you uploaded the index.html by ftp and that is showing correctly but without the theme and all the other pages. Wherever you put the index.html file, that is where you should be publishing.


(Roger Hobden) #20

The mystery has been solved !!!

Thank for very much to all for your help.

Much appreciated !!!