Show a PDF file on my site

I have both “Embed” and “PDF Embed” but I cannot get my PDF file to show on either Preview, or on my published site. It seems the only way I can show my PDF files is by extracting each page and embedding them as images. This is not what I want, as I would like the files to open in a PDF viewer and be downloadable or saveable.

I move the PDF files to Resources and point to the URL, but as I said they neither show in Preview or when I publish to site.

HELP !

You said you published, do you have a URL?

withdrawn… withdrawn…

Here is a sample…yell if you need help.
http://www.ibize.com/timberline/Plans/

Nice approach.
Would you mind explain a bit?

TIA

I sent you a message

That “Read Now” link could open a lightbox with my PDF Embed stack in it. What was not working for you before?

Hi Doug, When I say published it is a members only site still in development. I haven’t yet opened it to members.
Thanks

Hi Joe, Apologies for not getting back. COVID19 really upsetting the day to day activities currently. I like the set up of your site. I am guessing you are using more wide-ranging stacks than I have in my stable, and due to budgetary considerations its not likely to grow much larger than it currently is. The frustration is that I can currently see 1 PDF file, but the other 3 that I currently have uploaded don’t show up. It seems that for some reason, the URL of the one file works, but try as I may using both the Macro option, and the URL to point to the file in Resources, nothing seems to change. I am wondering the file is corrupt and if I need to delete the site and re-publish. Failing that perhaps re-write the site from scratch.

Hi Joe, I am using your PDF Embed Stack but am not using Google Docs to prepare it. I use Affinity Publisher to create my Newsletter the export to a PDF, which I then reduce in size for the Web. I import the PDF files into Resources then use the copy Macro to paste the address into the PDF URL in the Page Inspector PDF Embed page. I currently only have 4 PDF files uploaded; One works but 2 tell me they can’t find the PDF file. I tried manually uploading the file to a folder on the site then pointing to that file still to no avail. I do feel as though the file is somehow corrupted. I am currently deleting all files on the site and will try re-publishing. If that doesn’t work I will re-write the entire site from scratch & see if that works.
Cheers
Don

Hi Joe,
As I suspected I must have had a corrupt file on the server which wasn’t being updated. I deleted the entire site and re-published. Following the instructions on your site I then uploaded the PDF files to the resource folder on the site and after a little jigging sorted the correct URL and the PDF files now load & show perfectly.
Thanks again Joe, problem solved
Don

1 Like