SOLVED: Upgrade to RW8 and now Addons not showing in Library


(Adam Shiver) #23

Hi @Jerome

Others are not likely running into this bug otherwise they’d be popping up here to share their story too. Since you’re having a problem with Stacks you should try doing as others here have suggested a few times — contact the Stacks developer, @isaiah, at YourHead Software. I’m sure he can help you out.


(Paul Dennison) #24

I think something has gone wrong with your Stacks plugin installation as well.

I think you should try reinstalling it as I’ve previously suggested. However Isaiah might be able to suggest other paths to take or bits to remove to give a completely clean install if my suggestion doesn’t work.


(Isaiah Carew) #25

If you go into Stacks and choose “Show Stacks Library in Finder” from the gear menu there what pops up?
Pasted_Image_9_12_19__9_29_AM

No matter what is reported by RapidWeaver or by any other source, this folder that opens is where Stacks is looking for your stacks. There are two possible outcomes here – and about 90% of the time I hear this problem the first solution fixes it. And 90% of the rest get things fixed by the second. Occasionally there’s someone with real hard drive issues beyond that – but we can cross that bridge when we come to it.

  • If this folder is empty or contains fewer items than you expect, well, there’s the problem.
    Solution: move your stacks into this folder, Quit, then Re-launch RapidWeaver and you should be back in business.

  • If the folder opens and contains all of your stacks, then RapidWeaver and Stacks are looking in the right place but don’t have permission to see this directory.
    Solution: Un-set and then Re-set the Addons location. This will tell macOS that you’re giving RapidWeaver permission to see this folder. Here’s how to do it:

Before we begin, you need to know where your RapidWeaver addons folder is currently located. It seems from the above descriptions of the issue, you have a good handle on that, so I won’t explain that bit – but if you do need help feel free to contact our support. Christi can walk you through this in more detail. :slight_smile:

Un-set the location first

  1. Open the RapidWeaver preferences
  2. Click the Addons tab
  3. Click the Addons Location popup menu and choose Managed by RapidWeaver
  4. Choose “Change Folder” from the popup menu.
    You will then need to Quit and Re-Launch RapidWeaver.
    When RapidWeaver starts up it may say your plugins are missing – we’re expecting that.

OK. Now let’s re-set the location. This is a repeat, but we’ll set a location instead of clearing it.

  1. Open the RapidWeaver preferences
  2. Click the Addons tab
  3. Click the Addons Location popup menu and choose “Other…”
  4. Choose “Change Folder” from the popup menu.
    You will then need to Quit and Re-Launch RapidWeaver

With a little luck this will have corrected the permission problem for the folder. If it did not, then definitely contact support and we’ll see if we can dig a bit deeper and discover what else could be the matter.

Isaiah


(Jeroen Born) #26

Hi all, it is SOLVED. I just double clicked the Stack plug-in. But, to be completely up-to-date, I also upgraded Stacks to 4.

Again, thanks all for helping out!
J.


(Adam Shiver) #27

@Jerome – Just to satiate my curiosity since I’m not clear – What is it you double-clicked on specifically to fix the problem? Do you mean you double-clicked the Stacks icon to install Stacks into RapidWeaver?


(Isaiah Carew) #28

from the screenshot you can tell that he definitely had Stacks 3 running inside of RapidWeaver 8. however it might have been an old copy of Stacks.

my guess is that somehow the upgrade played havoc on the addons folder and some older version was moved over that was not very compatible with the latest RapidWeaver 8.3. perhaps there is more than one copy of something installed?

i think it merits a fine-toothed comb look inside of the add-ons folder to see what’s what. i did a video on that if it helps: https://www.youtube.com/watch?v=FcalwrsJt7g


(Jeroen Born) #29

Hi @Elixir and @isaiah, yes I think the upgrade got mixed up, as I have not been tidying up recently. I now ‘let’ RW manage the folder. The pathway is somewhat long, but at least RW has sorted what and where it needs all the addons. I have deleted my old folder.

I had double clicked the old version of Stacks plugin but now have also the Stacks4

which did the trick to get everything back again.

Once again, thanks.


(Indrid Cold) #30

It feels almost underwhelming. After all that I was expecting a much more complicated explanation than just your stuff being in the wrong location/folder. Specially when it’s a folder you can identify through Stacks itself.


(Isaiah Carew) #31

As I mentioned just pointing things at the right place fixes about 90% of the issues.

The situation seems to arise primarily while updating.
The process of moving things from the old folders to the new ones seems to be less than perfectly robust in some situations. Perhaps @tpbradley and/or @dan could take a look at this at some point to see if there are any improvements that could be made as it seems this issue is posted here on the forum pretty regularly.

Isaiah


(Koenraad) #32

I am having this (exact same) problem too, since upgrading to RW8 from RW7.
Just saying.