Stacks Help, Website Homepage not showing up


(Matt McGuigan) #1

This has happend a few times and I though I fixed it but I guess not. It seems to only be happening to my home page and an issue with Stacks. When you go to my home page all you see is the lego logo for stack and not my home page.
Any help with this would be greatly appricated thank you!

Here is the link to my website

http://www.nhahperd.org/


(scott williams) #2

First thing I would try is going to file menu and selecting republish all files and resources


(Isaiah Carew) #3

well, that’s definitely a very strange thing. is this a recent version of Stacks/RapidWeaver?

there was a very similar symptom of a bug – but not for a very long time – I think in Stacks 2 and RapidWeaver 6.

i would presume that you would have mentioned it if you were running a years out of date version though.

in any case, i’d very much like to hear what the setup is:

macos version
rapidweaver version
stacks version

as well as any other details that might be significant. are you using “extra content” in this theme?

any other plugins? PlusKit (also, version number if so)?

isaiah


(Matt McGuigan) #4

I am using Rapidweaver 6.4 and I believe my Stacks 2 is updated. On the home page, I am also using an add-on called Superflex. It is a placeholder for photos and maks it a kind of automated slideshow. The Stacks version is 3.5.5

Matt


(Matt McGuigan) #5

I tried that is published successfully but the home page is still showing up as the stacks lego image.


(Isaiah Carew) #6

Without detailed info, I’ll definitely send you off in the wrong direction instead of the right one. Would you mind terribly answering the other questions I asked? And since you said both “Stacks 2” and “Stacks version is 3.5.5” could you double check which is correct?

But I can probably provide you with a few good tips to try in any case:

  1. Try UNchecking these three preference items (see picture) and then do a Republish All Files from the File menu. Please be aware that Republish All Files is VERY DIFFERENT than just clicking Publish. It will force every page to upload even if RapidWeaver doesn’t detect a change – this is essential in this case.

  2. Make sure that you don’t have any old copies of RapidWeaver or Stacks mixed in or accidentally installed somewhere. I haven’t seen this bug in well over a year – I was under the impression that it was fixed in the RW v6.4 and Stacks 3 pairing – so I have a niggling doubt that maybe you have an old version (perhaps on a Time Machine drive or somewhere else equally insidious).

  3. And the simplest solution: Upgrade RapidWeaver. Although this is a Stacks bug, it is triggered by RapidWeaver 6 only. Upgrading RapidWeaver will resolve the issue.
    Also: A new upgrade to Stacks is in the works and will support RapidWeaver 7 & 8 only – so perhaps it’s a good time anyway.

If any of these things work, please let me know. I’m curious to learn more about this issue and its resolution.

Pasted_Image_1_11_18__8_29_AM|593x500


(system) #7

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.