Stacks picture not showing up after published

I have not done a website or updated anything in a while, i went to log in and noticed that RW was updated so i paid the update fee and then began to familiarize myself with it again. i published a site but the pictures that i dragged from my dropbox folder to the stack image shows on RW but when i publish it is not showing up. Why? Thanks in advance (also i noticed it says “not secure”)

it looks like the upload didn’t complete or RW thought those files had already been updated.

anytime Preview differs from the actual site there is one and only one solution:

–> Re-Publish All Files.

Just choose that from the Publish menu and go get a cup of coffee – it may take a while. But it will ensure that the project file is synced up with the web host.

As for the “not secure” means that you need an SSL certificate to “secure” your site. You can read more about what to do here:


im still so confused, i have removed the pictures and then republished and then reattached the pictures and republished they are still not showing up on my site. I then took each picture i dragged and dropped in the stack (image) and put them in a folder in the same location as the sites are backed up on. Why are they not showing up on my page? I have updated RW to the newest one and also Stacks to the newest one, anyone?


As I said before there is only one solution to this problem. It sounds like you have done “Publish” but not “Re-Publish All Files”

They are different and the difference in very important.

Only Re-Publish All Files will ensure that all resources are re-published, otherwise RapidWeaver will skip over the things it thinks have already been published.

I’m still quite optimistic that this single command, done just once, will solve the problem. It takes a while to finish – but once done I think everything should be in the right place with the right permissions. But do remember to clear your cache or visit the pages with a different browser to make sure that you’re really seeing the changes and not just the cached copy on your own computer.

In the unlikely event this doesn’t fix the problem, then we have to dig a bit deeper and gather some more information about the web-server.

If the files truly are in the right place and have the right permissions – yet the web server is not serving them then the only way forward is to check the web-server logs to find out why the images aren’t being served. This will likely involve reading the FAQs for your hosting company to determine how to find those logs or contacting your hosting company to ask for help with that.

But I would not contact them until you were 100% sure that the site has been uploaded with:

Re-Publish All Files

So try that first, then check back here and post a URL to a page that has problems. If that really doesn’t solve it – we can help you gather information (screenshots of the host files in place would be a good place to start) to take the next step. it shows stack images still not showing up. on RW i see them in images. I use and i have sent them emails asking about the “not secure” that is showing because they are supposed to provide Secure from what i was told in email. Funny is it pulls up on my computer but even on my phone sometimes the website wont pull up, however the photos never show on computer or phone.

The server shows a 403 - so the photos could be there but something is wrong on the serverside with permissions. DV Host should look into this also the not SSL connection.

i have sent this to my host and they said they are looking into it, as well as my SSL connection they said im the only client having this issue? i appreciate everyones help, i will keep plugging away.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.