Stacks INFO not working, unable to change any stack settings


#1

I just updated to the latest version of STACKS and now I can’t edit any stack settings. The Info and Inspector buttons no longer work…

RW 6.3.7


Cannot access the Inspector in RW 6.3.4
(Mark Sealey) #2

Have you restarted RW?

OK here… just tested.


#3

restarted it several times. no change


#4

I found a fix;

When I created a new Project the Inspector and Info buttons worked.
I then opened my existing Project and now both buttons work as before… Very weird.
I then CLOSED off the new project
Posting this here in case anyone else experiences the same issue.


(Isaiah Carew) #5

is this problem repeatable for you? is there something i could try that maybe i might see the problem myself (so that i can fix the bug).

Isaiah


#6

It was repeatable until I created a new empty project and now I cannot repeat the problem. Its working perfectly now.


(Isaiah Carew) #7

ok. glad to hear you’re back in business. that’s the most important thing of all.

but… if anyone else stumbles upon this one and can tell me how to duplicate it or can send me a file that makes it happen then I can fix it otherwise I guess we’ll just write it off as a fluke


(Mark Sealey) #8

I tried it by opening a (copy of!) and existing project - and did not get this behaviour; I add that in case the create-a-new-project-first is a co-incidence.


#9

This is happening again. I think its related to my external display.

If I use the external display (bigger screen resolution) then I can see the STACKS INFO stuff. If I then quit out of RW and use my MAC screen (without the external display connected) then I can’t access the STACKS INFO until I shutdown/restart with the external display connected.

When I start RW without the external display I can see the STACKS INFO briefly flash on the screen and disappear, almost as if it realizes it won’t fit on the screen and shuts it off.


(Isaiah Carew) #10

@britinusa - what mode do you view the info in? sidebar? window?


#11

Sidebar; When the problem occurs I cannot get the Inspector window to Open at all. Not sure if the Inspector pane is part of native RapidWeaver or if its part of Stacks.

Here are the Prefs for Stacks Info:


(Ric) #12

@isaiah
I had this same problem a few days ago.

@britinusa
I’d suggest you are right in your external display assumption.

I usually use my 15" Macbook Pro with dual external screens by connecting with a Henge Dock to a 27’’ Thunderbolt and an ageing 21’’ Apple Cinema Screen.

I recently started RW6 with only the laptop and the Inspector sidebar pane was missing and wouldn’t open with either the inspector button or the stacks edit button.
I gave up thinking it was me and the problem would cure itself.

Back at my desk I opened RW in the dual display mode but the inspector pane was still missing.
The solution I found (on a forum search via Google) was a terminal command:

Open Terminal.app
Copy/paste:
defaults delete com.realmacsoftware.rapidweaver6 “NSSplitView Subview Frames Main Document SplitView”

Press Enter
Reboot

I’ve not had the problem since but my ‘spider sense’ made me take a note of the solution that worked for me.


(Isaiah Carew) #13

terminal commands are all well and good, but even as a nerdy programmer i try to avoid them. here are some things that i might try first:

  1. hide the library (click the Library button to hide)
  2. hide the page list (chose Hide Source List from the View menu)
  3. put the library into window mode.

try other options in the Stacks Prefs (the screenshot shown a few posts above). try selecting something other than Sidebar for “Info starts as a:” – and try checking/unchecking the Closed on startup.

it’s not entirely clear to me why this is happening, but it is certainly a bug. in normal circumstances when you switch to a smaller monitor, Stacks will try to make sure that there’s enough space on the screen to display things. if there isn’t, it hides something.

clearly this process is getting a bit confused for some reason. some particular set of settings/screen-sizes/etc is a corner case that i’ve not tested and is going off the rails. unfortunately this is probably pretty difficult for me (or anyone else) to reproduce as there are many possible screen combinations and many possible settings combinations. given the rarity of this bug i’m guessing only one (or a very small number) of those combinations triggers this event.

my hope in asking you to adjust some of the settings is that it kicks it out of this particular scenario. however there is a distinct possibility that once you’ve contacted this bug it is difficult to reverse. if that’s the case then you’ll have to try the terminal command – or adjusting settings when you’re plugged into your larger display.

let me know if you find anything else out. and if you have a chance, please post a bit more info about your setup:

  1. what is the resolution of your large display(s)?
  2. what is the resolution of your small display(s)?
  3. was RapidWeaver/Stacks running when you disconnect the display?
  4. can you take a screenshot of RapidWeaver on both displays?

with this set of data i probably have a much better chance of reproducing this bad scenario and – with a bit of luck – fixing the bug.

Isaiah


#14

Below are the settings for the monitors, the MacBook and the External Display (DELL)

I changed the prefs to have both CLOSED at STARTUP and to use the SIDEBAR.

Now I cannot reproduce the problem… which is both a good and a bad thing I guess.

Next time this happens I will refer to your instructions and try changing the prefs (if I can access them).

I think the solution is going to be something in that PREFS screen, the only issue is that when the problem occurs I cannot access that PREFS screen as it only shows when the Inspector/INFO panel is open.

Is there a way to add a keyboard shortcut to access the PREFS screen (or maybe CTRL/CLICK on the INFO button) that would open that PREFS as a WINDOW so that it could be changed if needed ?


Pages and Resources Pane is Gone
(Isaiah Carew) #15

Glad to hear that things are improved. And thanks for the info. I have a machine that I can use to mimic these. Do you normally run the 13.3" display open? or keep that closed when using the big display?

Even if this wasn’t a bug that would be a good idea. Consider it added to my short list.

Isaiah


#16

I usually close the MacBook when using the external display.


(Russell Warner) #17

Just had this happen for the first time. Cannot get the inspector button to respond


(Russell Warner) #18

So I worked out when it happens but no idea why. I have no extra monitors attached.

If I open any project and then click a page and then on inspector top right.
I can toggle thru all 4 of the genral settings, sidebar, etc fine however the minute I click page settings, thats the end, the inspector disappears and the button becomes inactive.

First time I have experienced it tonight but very frustrating


(Jamie) #19

I just had the same thing happen to me for the first time today - was driving me nuts till I checked out the advice from @isaiah re:
hide the library (click the Library button to hide)
hide the page list (chose Hide Source List from the View menu)
put the library into window mode

Hiding the page list worked instantly for me - thank you:)
Once I’d done that even toggling page view back on again didnt affect the Page Inspector.

FYI I’m not using any external monitors - just a regular MB Pro running latest RW and Stacks…


#20

Getting this problem again. I selected Hide Source List and not I cannot get the Source to show again. Clicking the option in the Menu does not work.

None of the Inspectors work at all. RW is now unusable