Stacks Not Publishing Correctly


(Joel Cain) #1

I have been experiencing issues with Stacks when publishing my website. Everything looks fine in RapidWeaver preview - I have an image on the left and text on the right. However, when I view the published website on my desktop (browser is full screen), the text is under the image. I had this issue previously and after a day or so it worked itself out without me changing anything. Now after re-publishing, the problem has returned. I don’t know if there is a way to control how the published view appears.


(scott williams) #2

Can you post a URL to the page in question so we can have a look?
Did you try republish all from the file menu?


(Joel Cain) #3

joelcain.com

The main “about” page is supposed to have an image on the left and text on the right. The margins and padding doesn’t publish correctly on the “resources” page, either. The “lessons” page is supposed to alternate between an image on the left with text on the right, and text on left with an image on the right. The only page that publishes correctly is the basic contact form, which doesn’t use Stacks.


(Joel Cain) #4

And right after I replied, I refreshed my site and everything looks good again. I’m not sure why it does this.


(Joel Cain) #5

Yes, when I publish I am selecting File -> Re-Publish All Files.


(scott williams) #6

Glad it’s sorted for you, may have just been your browser cache messing things up. One reason we ask for a URL, to see if it looks okay for us.


(Isaiah Carew) #7

There are many caches involved in publishing, serving, and viewing a web page. Those caches really make life hard for people making sites like us – but they make the site nice and fast for users browsing to that page – which is usually a tradeoff worth making.

More specifically:

Publishing Cache
There’s a built-in publishing cache inside of RapidWeaver. This cache is actually for you. It means that you don’t have to upload every single file every time you make a tiny change. RapidWeaver does its best to find only the things that changed and upload those. As @swilliam suggested, you can bypass that cache and force RW to upload EVERYTHING by choosing Re-Publish All Files from the File menu. This can take a while, but when things seem strange it’s a good thing to try.

Server Cache
Many hosts have built in compression, caching, and other more complex ways of streamline what data they send out to the user. But that compression takes time to run, and caches are only reloaded occasionally. On my personal server there’s about a 1 minute delay between uploading new content and the content actually showing up when I browse there. Depending on which server, host, and the options they have set up – those things will all vary widely. Savvy users can tell their host to restart the web-server or even reboot the whole host machine to force this cache to clear. Or, if you’re me, you just go get a cup of coffee after pushing the publish button. :wink:

Browser Cache
All the browsers come with extensive caches. And it’s not a one-size-fits-all type deal. There are image caches, content caches, Javascript caches, DOM (Document Object Model) caches – and more. The user-facing “Clear Cache” menu option only clears some of those things. Other ways to trick the cache into clearing:

  • Inspect Element (In Chrome Only) defaults to disabling caches.
  • Enabling Developer Mode (In the Safari Prefs) gives you a Develop menu. Choose Disable Cache there.
  • Open an Incognito/Private window (Cmd-Shift-N) – these keep a separate and very limited cache.
  • Open another browser – If you’ve been using Chrome switch over to Safari or Firefox.
  • View the page on a different device – use your phone or a tablet to browse to the page.

Clicking the reload button (even with the Shift key and/or Option key held down), restarting the browser, and republishing the site will have some limited affects on the cache, but will miss many others – so don’t trust those.